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Introduction

Welcome to the Red Hat Enterprise Linux Step By Step Guide!

By now, you should have read the Red Hat Enterprise Linux Installation Guide and successfully in-
stalled Red Hat Enterprise Linux. This manual is designed to help new and intermediate Linux users
navigate and perform common tasks. Keep in mind that Linux looks, feels, and performs differently
from other operating systems you may have used. Forget about the conventions of other operating sys-
tems and, with an open mind, approach Red Hat Enterprise Linux as a new, interesting, and versatile
alternative.

This manual is task-oriented. You will find useful tips, hints, warnings, and screen shots interspersed
throughout. First, you will learn the basics of using Red Hat Enterprise Linux, such as familiarizing
yourself with the desktop, learning to use the shell prompt, and navigating through files and folders.
Once the basics are covered, the manual moves on to more advanced topics including setting up an
internet connection, configuring a printer, and working with documents.

Most users choose to work within either the GNOME or KDE graphical desktop environments (other
desktop environments are also available). The Red Hat Enterprise Linux Step By Step Guide focuses
primarily on how to perform tasks in these two environments.

Topics discussed include:

• Using the graphical desktop environment

• Managing files and directories

• Working with documents

• Using the Web and email

• Working with a digital camera

After conquering the basics of your Red Hat Enterprise Linux system, you may need information
on more advanced topics. You can find this information in the Red Hat Enterprise Linux System
Administration Guide, the Red Hat Enterprise Linux Reference Guide, the Red Hat Enterprise Linux
Introduction to System Administration, and the Red Hat Enterprise Linux Security Guide.

HTML, PDF, and RPM versions of the manuals are available on the Red Hat Enterprise Linux Docu-
mentation CD and online at http://www.redhat.com/docs/.

Note

Although this manual reflects the most current information possible, read the Red Hat Enterprise
Linux Release Notes for information that may not have been available prior to our documentation
being finalized. The Release Notes can be found on the Red Hat Enterprise Linux CD #1, online at
http://www.redhat.com/docs/, or in the /usr/share/doc/redhat-release-4<product>/ directory
after installation, where <product> is AS, ES, WS, or Desktop.

1. Architecture-specific Information
Unless otherwise noted, information contained in this manual applies only to the x86 processor and
processors featuring the Intel® Extended Memory 64 Technology (Intel® EM64T) and AMD64 tech-
nologies. For architecture-specific information, refer to the Red Hat Enterprise Linux Installation
Guide for your respective architecture.
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2. Changes to This Manual
This manual was previously published under the title Red Hat Linux Getting Started Guide. It has
been renamed and incorporated into the Red Hat Enterprise Linux documentation set. It has been
modified to include new features in Red Hat Enterprise Linux 4 and to reflect changes in documented
procedures that are not supported in Red Hat Enterprise Linux. Changes to this manual include:

Removable Media

The title and contents of this chapter have been changed from Diskettes and CD-ROMs to re-
flect expanded media options: both DVD-ROMs and USB flash drives are now included in this
chapter.

Web Browsers

Firefox has replaced Mozilla as the default web browser.

Email Applications

Thunderbird has replaced Mozilla Mail.

3. Document Conventions
When you read this manual, certain words are represented in different fonts, typefaces, sizes, and
weights. This highlighting is systematic; different words are represented in the same style to indicate
their inclusion in a specific category. The types of words that are represented this way include the
following:

command

Linux commands (and other operating system commands, when used) are represented this way.
This style should indicate to you that you can type the word or phrase on the command line
and press [Enter] to invoke a command. Sometimes a command contains words that would be
displayed in a different style on their own (such as file names). In these cases, they are considered
to be part of the command, so the entire phrase is displayed as a command. For example:

Use the cat testfile command to view the contents of a file, named testfile, in the current
working directory.

file name

File names, directory names, paths, and RPM package names are represented this way. This style
should indicate that a particular file or directory exists by that name on your system. Examples:

The .bashrc file in your home directory contains bash shell definitions and aliases for your own
use.

The /etc/fstab file contains information about different system devices and file systems.

Install the webalizer RPM if you want to use a Web server log file analysis program.

application
This style indicates that the program is an end-user application (as opposed to system software).
For example:

Use Mozilla to browse the Web.
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[key]

A key on the keyboard is shown in this style. For example:

To use [Tab] completion, type in a character and then press the [Tab] key. Your terminal displays
the list of files in the directory that start with that letter.

[key]-[combination]

A combination of keystrokes is represented in this way. For example:

The [Ctrl]-[Alt]-[Backspace] key combination exits your graphical session and returns you to the
graphical login screen or the console.

text found on a GUI interface
A title, word, or phrase found on a GUI interface screen or window is shown in this style. Text
shown in this style is being used to identify a particular GUI screen or an element on a GUI
screen (such as text associated with a checkbox or field). Example:

Select the Require Password checkbox if you would like your screensaver to require a password
before stopping.

top level of a menu on a GUI screen or window
A word in this style indicates that the word is the top level of a pulldown menu. If you click on
the word on the GUI screen, the rest of the menu should appear. For example:

Under File on a GNOME terminal, the New Tab option allows you to open multiple shell
prompts in the same window.

If you need to type in a sequence of commands from a GUI menu, they are shown like the
following example:

Go to Applications (the main menu on the panel) => Programming => Emacs Text Editor to
start the Emacs text editor.

button on a GUI screen or window
This style indicates that the text can be found on a clickable button on a GUI screen. For example:

Click on the Back button to return to the webpage you last viewed.

computer output

Text in this style indicates text displayed to a shell prompt such as error messages and responses
to commands. For example:

The ls command displays the contents of a directory. For example:
Desktop about.html logs paulwesterberg.png
Mail backupfiles mail reports

The output returned in response to the command (in this case, the contents of the directory) is
shown in this style.

prompt

A prompt, which is a computer’s way of signifying that it is ready for you to input something, is
shown in this style. Examples:

$

#

[stephen@maturin stephen]$

leopard login:
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user input
Text that the user has to type, either on the command line, or into a text box on a GUI screen, is
displayed in this style. In the following example, text is displayed in this style:

To boot your system into the text based installation program, you must type in the text com-
mand at the boot: prompt.

<replaceable>

Text used for examples, which is meant to be replaced with data provided by the user, is displayed
in this style. In the following example, <version-number> is displayed in this style:

The directory for the kernel source is /usr/src/kernels/<version-number>/, where
<version-number> is the version and type of kernel installed on this system.

Additionally, we use several different strategies to draw your attention to certain pieces of information.
In order of how critical the information is to your system, these items are marked as a note, tip,
important, caution, or warning. For example:

Note

Remember that Linux is case sensitive. In other words, a rose is not a ROSE is not a rOsE.

Tip

The directory /usr/share/doc/ contains additional documentation for packages installed on your
system.

Important

If you modify the DHCP configuration file, the changes do not take effect until you restart the DHCP
daemon.

Caution

Do not perform routine tasks as root — use a regular user account unless you need to use the root
account for system administration tasks.

Warning

Be careful to remove only the necessary partitions. Removing other partitions could result in data
loss or a corrupted system environment.



Introduction v

4. Copying and Pasting Text With X
Copying and pasting text is easy using your mouse and the X Window System. To copy text, click and
drag your mouse over the text to highlight it. To paste the text somewhere, click the middle mouse
button in the spot where the text should be placed.

5. Using the Mouse
Red Hat Enterprise Linux is designed to use a three-button mouse. If you have a two-button mouse,
you should have selected three-button emulation during the installation process. If you are using three-
button emulation, pressing both mouse buttons at the same time equates to pressing the missing third
(middle) button.

In this document, if you are instructed to click with the mouse on something, that means click the left
mouse button. If you need to use the middle or right mouse button, that will be explicitly stated. (This
will be reversed if you have configured your mouse to be used by a left handed person.)

The phrase "drag and drop" may be familiar to you. If you are instructed to drag and drop an item
on your GUI desktop, click on something and hold the mouse button down. While continuing to hold
down the mouse button, drag the item by moving the mouse to a new location. When you have reached
the desired location, release the mouse button to drop the item.

6. We Need Feedback!
If you spot a typographical error in the Red Hat Enterprise Linux Step By Step Guide, or if you have
thought of a way to make this manual better, we would love to hear from you! Please submit a report
in Bugzilla: http://bugzilla.redhat.com/bugzilla/ against the component rhel-sbs.

When submitting a bug report, be sure to mention the manual’s identifier:

rhel-sbs(EN)-4-Print-RHI (2005-02-16T01:05)

If you have a suggestion for improving the documentation, try to be as specific as possible when de-
scribing it. If you have found an error, please include the section number and some of the surrounding
text so we can find it easily.
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I. Starting Out

To begin the journey of using your Red Hat Enterprise Linux system, you need to learn the basics.
This part introduces the concepts and terms that help you get the most out of Red Hat Enterprise
Linux, and learn some of its exciting features. From configuring your system with Setup Agent to
using your graphical desktop and the shell prompt, this part helps you get acquainted with your Red
Hat Enterprise Linux system.

Table of Contents
1. Getting Started ................................................................................................................................ 1
2. Using the Graphical Desktop ....................................................................................................... 15
3. Managing Files and Directories ................................................................................................... 33
4. Shell Prompt Basics ...................................................................................................................... 45





Chapter 1.
Getting Started

From booting up to shutting down, whether you are working or playing, Red Hat Enterprise Linux
provides tools and applications to help you get the most out of your computing environment. This
chapter guides you through some basic tasks that you can perform on your Red Hat Enterprise Linux
system.

1.1. Setup Agent

Figure 1-1. Setup Agent

The first time you start your Red Hat Enterprise Linux system, the Setup Agent is presented. The
Setup Agent guides you through the configuration of your Red Hat Enterprise Linux system. Using
this tool, you can set your system time and date, add users to your system, install software, register
your machine with the Red Hat Network, and more. Setup Agent allows you to configure your en-
vironment at the beginning, so that you can get started using your Red Hat Enterprise Linux system
quickly.

Figure 1-2. License Agreement
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The Setup Agent first prompts you to read and agree to the License Agreement, which discusses your
rights in using Red Hat Enterprise Linux. Click Yes, I agree to the License Agreement and click
Next to continue.

Important

You must agree to the License Agreement to continue using Red Hat Enterprise Linux. If you choose
No, I do not agree at the License Agreement screen, the machine prompts you to either re-read the
agreement or decline and shutdown your system. You cannot use Red Hat Enterprise Linux without
first agreeing to the License Agreement.

Figure 1-3. Date and Time Configuration

The Setup Agent allows you to manually set your machine’s date and time, which adjusts the clock on
your computer’s BIOS (Basic Input Output System). To set the day, month, and year on your system,
use the calendar interface. To set your time in hours, minutes, and seconds, use the provided text
boxes.

Figure 1-4. Network Time Protocol
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You may also synchronize your date and time automatically with a network time server — a computer
that sends accurate date and time settings to your system through a network connection. Select, the
Network Time Protocol, check the box labeled Enable Network Time Protocol, and use the drop-
down menu to select a time server. Once you have set your time and date, click Next to continue.

Figure 1-5. Display

Next, configure your display. Red Hat Enterprise Linux auto-detects your monitor and loads the cor-
rect driver. If you would like to choose another driver, click on the Configure... button and browse the
list of available drivers. Select the resolution of your screen and click Next to continue.

Figure 1-6. Red Hat Network Registration Client

You must register your system with Red Hat Network to continue. Red Hat Network provides au-
tomatic updates of your Red Hat Enterprise Linux system, including security updates. If you have
already registered with Red Hat Network, enter your account information in the appropriate field. If
you have never registered, choose I don’t have a Red Hat login. I need to create one.. Click Next —
if you need to create a Red Hat login, the Red Hat Update Agent launches. After you have entered
your Red Hat login information, the Setup Agent continues to the next screen.
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Figure 1-7. Activation

To activate an existing Red Hat subscription, enter the Activation Number in the appropriate field.
Otherwise, select I do not have a subscription number. Click Next to continue.

Figure 1-8. User Account

Next, you should create a user account to use on a routine basis. It is not recommended to log in to
your root account for common computing tasks, as you may damage your system or unintentionally
delete a file. The Setup Agent lets you enter a username, an optional full name for the account, and a
password (which you must enter twice). This creates a user account that you can use to log into your
Red Hat Enterprise Linux system and which has its own home directory on the system to store files.
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Figure 1-9. Sound Card

The Setup Agent probes your system for sound cards and attempts to configure the correct settings
for use with Red Hat Enterprise Linux. You can then click the Play test sound button to play a sound
sample. If you can hear the sample, select OK and your sound card configuration is complete.

Figure 1-10. Installing Additional Software

To install Red Hat Enterprise Linux RPM packages that you did not install during installation, software
from third-party providers, or documentation from the Red Hat Enterprise Linux Documentation CD,
you can do so at the Additional CDs screen. Insert the CD containing the software or documentation
you want to install, click the Install... button, and follow the instructions.

Note

If you are installing a package from the Red Hat Enterprise Linux Installation CDs, you must insert
CD 1, click the Install... button, choose the package(s) or component you want to install, and, if
prompted , change the CD.
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Figure 1-11. Finish Setup

Now that your system is configured, you are ready to log in and start using Red Hat Enterprise Linux.
Press Forward to exit the Setup Agent.

1.2. Introductory Terms
When you learn about a new operating system, you should also learn new terminology. This section
defines a few basic terms you should learn. You will see these terms often throughout all Red Hat
Enterprise Linux documentation including the Red Hat Enterprise Linux Step By Step Guide:

• Command: An instruction given to the computer, most often with the keyboard or mouse.

• Command line: The space at the shell prompt where commands are typed.

• Graphical Desktop: The most visible area of a GUI. The desktop is where your user Home and
Computer icons are located. You can customize your desktop to have special backgrounds, colors,
and pictures to add a personal touch.

• Graphical User Interface (GUI): A general term for interactive windows, icons, menus, and panels
which allow a user to initiate actions such as starting applications and opening files using a mouse
and keyboard.

• Icons are small images representing an application, folder, shortcut or system resource (such as a
diskette drive). Launcher icons usually refer to application shortcuts.

• Man page and Info page: Man (short for manual) and Info pages give detailed information about
a command or file (man pages tend to be brief and provide less explanation than Info pages). For
example, to read the man page for the su command, type man su at a shell prompt (or type info
su for the info page). To close man or Info pages, press [q].

• Panel: A desktop toolbar, located across the top and bottom of your desktop (such as Figure 1-12).
The panel contains the Applications menu and shortcut icons to start commonly used programs.
Panels can also be customized to suit your needs.

Figure 1-12. The Desktop Panel

• Root: Root is an administrative user account created during installation that has complete access
to the system.(Root is also known as the superuser.) You must be logged in as root to accomplish
certain system administration tasks, such as changing administrative passwords and running sys-
tem configuration tools. User accounts are created so that typical user tasks can be done without



Chapter 1. Getting Started 7

using the root account, which can reduce the chance of damaging your Red Hat Enterprise Linux
installation or applications permanently.

• RPM: RPM stands for RPM Package Manager and is how Red Hat builds and delivers its software
files. An RPM is a software package file you can install on your Red Hat Enterprise Linux computer.

• Shell prompt: A command line interface between the user and the operating system (Figure 1-13).
The shell interprets commands entered by the user and passes them on to the operating system.

Figure 1-13. A Shell Prompt

• su and su -: The command su (switch user) gives you access to the root account or other accounts
on your system. When you type su to switch to your root account while still inside your user
account shell, you have access to important system files that you can change (or damage if you are
not careful). Logging in with the su - command makes you root within the root account shell. Use
caution when you are logged in as root.

• X or X Window System: These terms refer to the graphical user interface environments. If you are
"in X" or "running X", you are working in a GUI rather than a console environment.

Although the emphasis throughout this book is on navigation and productivity using the graphical
desktop environment, both the graphical and shell prompt methods of logging in and using your Red
Hat Enterprise Linux system are discussed for your reference.

1.3. Logging In
The next step to using your Red Hat Enterprise Linux system is to log in. When you log in, you are
introducing yourself to the system (also called authentication). If you type the wrong user name or
password, you will not be allowed access to your system.

Unlike some other operating systems, your Red Hat Enterprise Linux system uses accounts to manage
privileges, maintain security, and more. Not all accounts are created equal: some accounts have fewer
rights to access files or services than others.

Note

Red Hat Enterprise Linux applications and files are case sensitive, which means that typing root
refers to a different account than Root. By default, root refers to the root user (also known as the
superuser), or system administrator.



8 Chapter 1. Getting Started

If you have already created and logged in to a user account, you can skip ahead to
Chapter 2 Using the Graphical Desktop. If you created only the root account, refer to
Section 1.6 Creating a User Account to learn how to set up a user account.

If you did not create a user account using the Setup Agent, you must log in as root. After you create a
user account, it is highly recommended that you log in as that user instead of root to prevent accidental
damage to your Red Hat Enterprise Linux installation.

Caution

Because your Red Hat Enterprise Linux system creates the root account during installation, some
new users are tempted to use only this account for all of their activities. This is a dangerous idea,
because the root account is allowed to do anything on the system. You can easily damage your
system by accidentally deleting or modifying sensitive system files. You may be tempted to forego
creating and using a user account during or after installation, but it is not recommended.

1.3.1. Graphical Login
When your system has booted, a graphical login screen is displayed as shown in Figure 1-14. Again,
unless you have chosen to give your machine its own hostname, which is primarily used in a network
setting, your machine will probably be called localhost.

Figure 1-14. The Graphical Login Screen

To log in as root from the graphical login screen, type root at the login prompt, press [Enter], type
the root password that you chose during installation at the password prompt, and press [Enter]. To log
in as a normal user, type your username at the login prompt, press [Enter], type your password that
you selected when creating the user at the password prompt, and press [Enter].

Logging in from the graphical login screen automatically starts the graphical desktop for you.

1.3.2. Virtual Console Login
During installation, if you selected an installation type other than Workstation or Personal Desktop
and chose text as your login type, you will see a login prompt similar to the following after booting
your system:

Red Hat Enterprise Linux release 4
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Kernel 2.4.21-3.EL on an i686

localhost login:

Unless you have chosen to give your machine its own hostname, which is primarily used in a network
setting, your machine will probably be called localhost.localdomain.

To log in as root from the console, type root at the login prompt, press [Enter], then type the root
password that you chose during installation at the password prompt and press [Enter]. To log in as
a normal user, type your username at the login prompt, press [Enter], type your password that you
selected when creating the user at the password prompt, and press [Enter].

After logging in, you can type the command startx to start the graphical desktop.

1.4. Graphical Interface
When you installed Red Hat Enterprise Linux you had the opportunity to install a graphical environ-
ment. Once you start the X Window System, you will find a graphical interface known as a desktop
similar to Figure 1-15 . Unless you specified otherwise, Red Hat Enterprise Linux installs GNOME as
the default desktop. In this manual, desktop-related tasks will first be explained in relation to GNOME.
We will come back to the desktop in Chapter 2 Using the Graphical Desktop .

For more information about the KDE desktop, see Appendix A KDE: The K Desktop Environment .

Figure 1-15. The Graphical Desktop

1.5. Opening a Shell Prompt
The desktop offers access to a shell prompt, an application that allows you to type commands
instead of using a graphical interface for all computing activities. While the Red Hat Enterprise
Linux Step By Step Guide primarily focuses on performing tasks using the graphical interface and
graphical tools, it is sometimes useful and faster to perform tasks from a shell prompt. Refer to
Chapter 4 Shell Prompt Basics for further details.

You can open a shell prompt by selecting Applications (the main menu on the panel) => System
Tools => Terminal.
You can also start a shell prompt by right-clicking on the desktop and choosing Open Terminal from
the menu.

To exit a shell prompt, click the X button on the upper right corner of the shell prompt window, type
exit at the prompt, or press [Ctrl]-[D] at the prompt.
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1.6. Creating a User Account
When you first started your Red Hat Enterprise Linux system after installation, you were given the
opportunity to create one or more user accounts using the Setup Agent. If you did not create at least
one account (not including the root account) you should do so now. You should avoid working in the
root account for daily tasks.

There are two ways to create new and/or additional user accounts: using the graphical User Manager
application or from a shell prompt.

To create a user account graphically using the User Manager:

1. Select Applications (the main menu on the panel) => System Settings => Users & Groups
from the panel.

You can also start the User Manager by typing redhat-config-users at a shell prompt.

2. If you are not logged in as root, you will be prompted for your root password.

3. The window shown in Figure 1-16 will appear. Click Add User.

Figure 1-16. The Red Hat User Manager

4. In the Create New User dialog box, enter a username (this can be an abbreviation or nickname),
the full name of the user for whom this account is being created, and a password (which you will
enter a second time for verification). The name of this user’s home directory and the name of the
login shell should appear by default. For most users, you can accept the defaults for the other
configuration options. Refer to the Red Hat Enterprise Linux System Administration Guide for
details about additional options.

5. Click OK. The new user will appear in the user list, signaling that the user account creation is
complete.

To create a user account from a shell prompt:

1. Open a shell prompt.

2. If you are not logged in as root, type the command su - and enter the root password.

3. Type useradd followed by a space and the username for the new account you are creating at the
command line (for example, useradd jsmith). Press [Enter]. Often, usernames are variations
on the user’s name, such as jsmith for John Smith. User account names can be anything from
the user’s name, initials, or birthplace to something more creative.

4. Type passwd followed by a space and the username again (for example, passwd jsmith).

5. At the New password: prompt enter a password for the new user and press [Enter].
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6. At the Retype new password: prompt, enter the same password to confirm your selection.

Important

You should take precautions when you choose a password. The password is the key to your
account, so it should be both unique and easy for you to remember. Your password should be
at least six characters. You can use both uppercase and lowercase letters, as well as numbers
and characters. Avoid easy selections, such as qwerty or password. If you want to pick an
easy-to-remember but somewhat unique password, consider a variation of a word, such as
a1rPl4nE for airplane.

1.7. Documentation and Help
There are several resources available to get the information you need to use and configure your Red
Hat Enterprise Linux system. Along with the Red Hat Enterprise Linux documentation there are man-
ual pages, documents that detail usage of important applications and files; Info pages which break
information about an application down by context-sensitive menus; and help files that are included
in the main menubar of graphical applications. You can choose any method of accessing documenta-
tion that best suits your needs, as all of these resources are either already installed on your Red Hat
Enterprise Linux system or can be easily installed.

1.7.1. Manual Pages
Applications, utilities, and shell prompt commands usually have corresponding manual pages (also
called man pages) that show the reader available options and values of file or executable. Man Pages
are structured in such a way that users can quickly scan the page for pertinent information, which is
important when dealing with commands that they have not previously encountered.

1.7.1.1. Using man

Man Pages can be accessed via shell prompt by typing the command man and the name of the exe-
cutable. For example, to access the man page for the ls command, type the following:

man ls

The NAME field shows the executable’s name and a brief explanation of what function the executable
performs. The SYNOPSIS field shows the common usage of the executable, such as what options are
declared and what types of input (such as files or values) the executable supports. The DESCRIPTION
field shows available options and values associated with a file or executable. See Also shows related
terms, files, and programs.
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Figure 1-17. Reading a Man Page with the Shell Prompt

To navigate the man page you can use the "arrow" keys or use the [Spacebar] to move down one page
and [B] to move up. To exit the man page, type [Q].

To search a man page for keywords type [/] and then a keyword or phrase and press [Enter]. All
instances of the keyword will be highlighted throughout the man page, allowing you to quickly read
the keyword in context.

1.7.1.2. Printing a Man Page
Printing man pages is a useful way to archive commonly used commands, perhaps in bound form for
quick reference. If you have a printer available and configured for use with Red Hat Enterprise Linux
(refer to the Red Hat Enterprise Linux System Administration Guide for more information), you can
print a man page by typing the following command at a shell prompt:

man command| col -b | lpr

The example above combines separate commands into one unique function. man command will output
the contents of the command man page to col, which formats the contents to fit within a printed page.
The lpr command sends the formatted content to the printer.

1.7.1.3. The man Man Page
Just like other commands, man has its own man page. Type man man at the shell prompt for more
information.

1.7.2. Red Hat Enterprise Linux Documentation
If you have the Red Hat Enterprise Linux boxed set, remember to take a look at the Red Hat En-
terprise Linux Documentation CD. All of the Red Hat Enterprise Linux manuals are on this CD.
Individual downloads of our documentation in HTML, RPM, PDF, and compressed tarball format
(.tar.gz) are also available at http://www.redhat.com/docs/. Once you have logged in to your user
account, inserting the Documentation CD in your CD-ROM drive should automatically start the Pack-
age Management Tool and allow you to install any of the Red Hat Enterprise Linux documentation.
Follow the instructions and choose the documentation you would like to install.
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Figure 1-18. Package Management Tool Displaying Documentation Available for Installation

If you have downloaded individual documentation RPM packages from the Red Hat website at
http://www.redhat.com/docs/ you can install these manuals from a shell prompt. Open a shell
prompt, and type the following at the command line:

su -

Press [Enter]. You will be asked for your root password. Enter the password at the prompt and press
[Enter]. You are now logged in as root. To install all of the Red Hat Enterprise Linux manuals, change
to the directory that contains the RPM files and type the following:

rpm -ivh rhl-*.rpm

Press [Enter].

To install only certain manuals, replace rhl-*.rpm with the full file name of the manual that you
want to install. For example, the file name for the Red Hat Enterprise Linux Step By Step Guide will
look something like rhl-gsg-en-4.noarch.rpm, so you would type the following to install it on
your system:

rpm -ivh /mnt/cdrom/rhl-gsg-en-4.noarch.rpm

Press [Enter]. Type exit at the command line and press [Enter]. This logs you out of the root account
and back to your user account.

1.8. Logging Out

1.8.1. Graphical Logout
To log out your graphical desktop session, select Actions (the second menu on the top panel) =>
Log Out.
When the confirmation dialog appears as shown in Figure 1-19, select the Logout option and click
the OK button. To save the configuration of your desktop, as well as any programs which are running,
check the Save current setup option.
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Figure 1-19. Logout Confirmation

1.8.2. Virtual Console Logout
If you are not using the X Window System, and you logged in at the console, type exit or [Ctrl]-[D]
to log out of the console session.

1.9. Shutting Down your Computer
Before turning off your computer, it is important to properly shut down Red Hat Enterprise Linux.
Never turn your computer off without shutting down first, as you may lose unsaved data or damage
your system.

1.9.1. Graphical Shutdown
If you are in the graphical desktop, log out of your session as described in Section 1.8 Logging Out.
From the graphical desktop logout screen shown in Figure 1-19, select Shutdown and click OK to
confirm.

Some computers automatically turn the power off after shutting down Red Hat Enterprise Linux. If
your computer does not, you can safely turn off the power to your computer after you see the message:

Power down.

1.9.2. Virtual Console Shutdown
To shutdown your computer at a shell prompt, type the following command:

halt

Some computers automatically turn the power off after shutting down Red Hat Enterprise Linux. If
your computer does not, you can safely turn off the power to your computer after you see the message:
System halted.



Chapter 2.
Using the Graphical Desktop

Red Hat Enterprise Linux includes a powerful graphical desktop environment where you can easily
access your applications, files, and system resources. Both new and experienced users can take full
advantage of their Red Hat Enterprise Linux systems using the graphical desktop.

This chapter covers the fundamentals of the desktop and how to configure it for your needs.

2.1. Using Nautilus
Your first view of the graphical desktop looks something like Figure 2-1. The desktop offers the fol-
lowing tools, represented as desktop icons: Computer, User’s Home, and Trash. Each of these tools
is an application of the Nautilus file manager.

Figure 2-1. The Graphical Desktop

Nautilus provides a graphical display of your system and personal files. Nautilus is designed to be
much more than a visual listing of files, however. It allows you to configure your desktop, configure
your Red Hat Enterprise Linux system, browse your photo collection, access your network resources
and more — all from one integrated interface. In essence, Nautilus becomes a shell for your entire
desktop experience.

Working in Nautilus provides an alternative to using a shell prompt to navigate the file system. The
following sections explain how to use Nautilus to enhance your desktop experience.
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2.1.1. Using the Computer icon

Figure 2-2.

Double-clicking the Computer icon takes you to a list of all of the devices on your system. A device
is anything connected to your computer to which data is sent or from which it is received. (You have
probably heard of a ’device driver’ before - this is a piece of software that allows a device to talk to
your computer.) Most modern systems have the following devices: a floppy drive, a CD-ROM drive,
and at least one hard drive. Other devices may be listed depending on the makeup of your system.

Removable Media
Double-click either the Floppy icon or the CD-ROM icon to mount the drive with Nautilus and
open a new window with the drive’s contents. You can also right-click on the drive and then
select Mount Volume from the menu. Note: you must first unmount a floppy before you eject it.
Refer to Chapter 13 Diskettes and CD-ROMs for more information.

Disk
This references the hard drive. If you are using Linux, your hard drive is already mounted, and
may not be accessible from this window. If you have other hard drives available on your system
(possibly used for other operating sytems), they may be mountable here.

Filesystem
Double-click on the Filesystem icon and Nautilus opens a window that shows the entire file
system, starting from the / directory. This is a quick way to reach such useful folders as /tmp/
and /usr/bin/. If you are not logged in as root, some folders will be unavailable. This is to
prevent accidental damage to your system.

Network
Double-click the Network icon to bring up a list of all systems on your network. Linux sys-
tems are listed individually. Systems running other operating systems are grouped under an icon
that reflects this. (For example, Windows systems on your network appear under a Windows
Network icon.) You are only able to browse those machines you have permission to access.

2.1.2. User’s Home

The tool associated with the icon is referred to as User’s Home in this manual. The label
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under the icon varies according to your user name. If you are logged in as root, the label reads root’s
Home. User "joe" would see the label joe’s Home.

Figure 2-3. User’s Home

Double-clicking on the User’s Home icon allows you to navigate through your home directory or the
rest of the file system.

The browser window opens in icon view. The icons are designed to allow easy recognition of file
types; directories are represented by folders, music files have musical notes, and so on. Nautilus
automatically sorts your files by name and arranges them neatly. When you open a directory it opens
in a new browser window.

To move a file from one directory to another, drag and drop the file into the new location, or cut and
paste it. Note that in Nautilus, dragging and dropping a file moves it rather than placing a copy in the
new location. If you wish to copy a file instead, right-click on the icon, select Copy, and paste the file
in the new directory.

Most of these settings can be configured to meet your preferences. (Refer to
Section 2.1.4 Customizing Nautilus for more information.)

2.1.3. Trash
Nautilus includes a Trash icon similar to that of other operating systems; files inside the Trash are
not deleted until you choose to do so. The Trash bin can be opened by double-clicking on the desktop
icon. It opens as a Nautilus window, which allows you to easily move files in and out. To empty the
Trash, right-click on the desktop icon and select Empty Trash Bin.

2.1.4. Customizing Nautilus
You can also change the way Nautilus behaves. To do so, select Edit => Preferences from an open
Nautilus window. A new configuration window opens with many customization options. These cus-
tomization options are categorized by the tabs at the top of the window.
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Figure 2-4. Customizing Nautilus - View Tab

Views Tab

The Views tab allows you to choose how your files and folders are displayed. You can also choose
a Default Zoom Level. Zooming in on icons not only increases the size of the icons, but adds to
the displayed information about each file or folder.

BehaviorTab

The Behavior tab allows you to specify that Nautilus should Always open in browser windows.
If you check this option, opening a folder displays the directory’s contents in the current window.
This behavior may be more familiar to those users accustomed to using the Start Here icon. You
can also choose to include a delete option that bypases the Trash bin.

Display Tab

The Diplay tab features a series of drop-down boxes listing various file details. Selecting these
options sets the order in which these details appear as you zoom in. You can also set the format
for dates and times within Nautilus.

(This only changes the time format for Nautilus. To change the date and time format of the clock
on the Panel, right-click on it and choose Preferences.)

List Columns Tab

The List Columns tab allows you to select which details are shown when folder contents are
displayed as a list. If you click on the description of a detail, you can then change the order in
which it is displayed by clicking Move Up or Move Down.

Preview Tab

The Preview tab allows you to select the types of files that are previewed by Nautilus. For
text files, this means that part of the text is visible on the icon. For image files, this means that
Nautilus displays a thumbnail (or scaled-down view) of the file. For sound files, Nautilus plays
the sound while your mouse pointer hovers over the file. If Nautilus seems to be sluggish on
your machine, try turning these resource-intensive features off to increase the speed.
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2.2. Using the Desktop
Other icons on the desktop can be shortcuts to files, folders, and application launchers. To open a
folder or launch an application, double-click on its icon.

Figure 2-5. The Graphical Desktop

2.2.1. Adding Application Launchers
Some users prefer to access favorite applications directly from the Desktop, rather than hunting
through menus. To do this, you must create an application launcher. There are several ways to go
about this:

• Applications can be dragged and dropped from the Main Menu onto the destop.

• Applications can be dragged and dropped from the Panel to the desktop.

• Application launchers can be created manually.

Creating a launcher manually can be tricky. In most cases, it is best to drag and drop an application
from the Applications or the Panel.

Figure 2-6. Launcher window with gedit information
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To manually create an application launcher:

1. First, you must know the name of the application for which you are creating a launcher. For the
purpose of this example, assume the application is gedit.

2. Next, locate the application. Use the which command from a shell prompt to locate the exe-
cutable file for the application. Refer to Section 4.7.3 Which, whereis, whatis for more informa-
tion on the which command.

3. Right-click on a blank area of the desktop and choose Create Launcher.

4. When the dialog opens, fill in the following fields:

• Name: Enter a name for the launcher. For this example, a good name would be "GNOME
Editor".

• Generic Name: (Optional) Enter the type of program. For this example, "Text Editor" is
appropriate.

• Comment: (Optional) Enter a short piece of information about the launcher - this text is
displayed when your mouse hovers over the icon on your desktop. For this example, use
"This is my favorite text editor!"

• Command: Enter the results of the which command (ex: /usr/bin/gedit).

• Type: Choose the type of launcher to create. Choose Application in this case.

• Icon: Click on the No Icon button to choose the icon for your launcher. You can either pick
one of the icons it suggests, or browse the /usr/share/icons directory to select another.
Click the OK button to save your selection.

• Click OK.

5. This places the launcher on your desktop. Double-clicking the new icon launches the applica-
tion.

2.2.2. Adding File Links
To place a link to a file or directory on the desktop:

1. Open User’s Home and navigate to the appropriate directory.

2. Right-click on the icon of the file or directory and select Make Link. This creates a new icon
with the phrase "link to ..." in its name.

3. Drag and drop this new icon to the desktop. If you were to drag and drop the actual file or
directory, you would move it from its current location to the desktop.
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Figure 2-7. Example of a link to a file

2.3. Using the Panel
The long gray bars across the top and bottom of the screen are the Panels.

The top Panel contains both the Applications and Actions menus. It also contains application launch-
ers, the notification area, and the time and date.

Figure 2-8. The Top Panel

The bottom Panel contains the Workspace Switcher and the Taskbar.

Figure 2-9. The Bottom Panel

Both can contain applets - small applications that generally run only on the panel. Applets handle
simple tasks like controlling sound volume and displaying the status of your system.

The Panels are independently configurable. To alter the default settings, right-click in an unused area
of the Panel you wish to alter and select Configure Panel. This allows you to change the color, size,
and position of the Panel. You may also choose to hide the Panel automatically or manually. If you
choose to hide the Panel, it does not appear on the desktop until your mouse pointer hovers over the
Panel area.

Application launchers may be moved between the Panel and the Desktop. Dragging and dropping
application launchers from the Desktop to the Panel (or from the Panel to the Desktop) creates a
copy of the launcher in the new location rather than moving it. In general, applets may not be copied
from the Panel to the Desktop.
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2.3.1. Standard Applets
There are a few applets that run on the panels by default. These important applets are covered in the
following sections.

2.3.1.1. Workspace Switcher

Figure 2-10. The Workspace Switcher

The graphical desktop allows for the use of multiple workspaces. Workspaces are virtual desktops
— each workspace has the same background, panel, and desktop shortcuts. Using the workspaces
allows you to separate your applications and avoid a cluttered desktop area. Using workspaces can also
organize your work flow. For example, some users will choose one workspace for potential distractions
like email and instant messagers and choose another workspace for their office applications. This
allows them to ignore the distractions until they are ready for a break.

The Workspace Switcher represents the workspaces as small squares and shows the applications
running on each. Clicking on one of the squares moves you to that desktop. By right-clicking on the
Workspace Switcher and choosing Preferences, you can configure your workspaces. You can have
up to thirty-six, although few people use that many. You may also want to name your workspaces.
Double-click on any of the Workspace names and type in the new name. Click the OK button to save
your changes and exit.

2.3.1.2. Taskbar

Figure 2-11. The Taskbar

Next to the Workspace Switcher is the Taskbar. The Taskbar is an applet that shows you the titles
of running applications on any one virtual desktop. This is helpful if you decide to minimize an
application, as it seems to disappear from the desktop. Once it disappears, you can bring it back by
clicking on its title in the Taskbar.

2.3.1.3. Notification Area

Tip

If you cannot see any of the notification icons, then the notification area was removed from the
desktop panel. To add it back to your panel, right-click on the panel and choose Add to Panel...
When the new window opens, select Notification Area.
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Red Hat Network Alert Notification Tool
Part of the Notification Area, the Red Hat Network Alert Notification Tool provides you with
an easy way to make sure your system is up-to-date with current errata and security updates from
Red Hat Network. The applet displays different icons to indicate whether your system is fully
updated: a red exclamation point indicates that there are updates available, and a green check
mark indicates that your system is up-to-date. Double-click on either icon to launch the Red
Hat Update Agent. If you are not registered with Red Hat Network, the registration component
launches. Right-click on the applet icon for a list of options from which to choose.

If the icon is missing from the Notification Area, open the Applications menu and select Sys-
tem Tools => Red Hat Network Alert Icon.

The Authentication Icon
The key icon that is sometimes displayed in the Notification Area is a security notification. It
is displayed whenever you have gained root authentication for your system (such as running a
graphical system configuration tool). It disappears when the authentication times out.

Printer Notification Icon
The Printer Notification Icon allows you to manage your print jobs. Click on the icon to view
running print jobs, and cancel jobs by right-clicking on the job and selecting Cancel. The Printer
Notification Icon only appears during an active print job. If the print job you have is small, you
may not see the icon appear.

2.3.2. Adding Applets and Application Launchers

Figure 2-12. A list of applets and applications for the Panel

You may add more applets and launcher icons to either Panel in order to suit your needs. Right-click
in an unused area of a Panel and select Add to Panel. This opens a window that allows you to choose
either an applet or an application launcher. Clicking once on an icon navigates through the list of
applications, and double-clicking adds an application to the panel. Figure 2-13 shows the Panel with
the Weather Report added to show the current local weather and temperature.



24 Chapter 2. Using the Graphical Desktop

Figure 2-13. The Weather Report Applet on the Panel

Individual applets may also be configured. By right-clicking on any applet icon on the Panel, you are
given a short menu that includes Preferences. These preferences are different for each applet.

2.3.3. Configuring the Panel
You can hide the panel automatically or manually, place it on any edge of your desktop, change its
size and color, and change the way it behaves. To alter the default panel settings, right-click in an
unused area of the panel and select Properties. If you choose to hide the panel, it does not appear on
the desktop until you move your mouse pointer over the panel area.

Figure 2-14. Configuration Dialog for the Panel



Chapter 2. Using the Graphical Desktop 25

2.3.4. Adding Additional Panels

Figure 2-15. The Desktop with two additional Panels

It may at times be convenient to have additional Panels. It is easy to add as many panels to your
desktop as fits on the screen. Right-click on an unused area of the existing panel and choose New
Panel. A blank panel is placed on the Desktop. Once it has been created, the steps above allow you
to configure it and to place on it whatever applets and applications you like.

2.4. Using the Applications and Actions Menus
On the top panel are two menus, the Applications menu and the Actions menu. The Applications
menu expands into a large set of menus that allow you to access the applications on your system. The
Actions menu expands into a list of actions you can perform on your session.

2.4.1. The Applications Menu
The categories of the Applications menu are self-explanatory. For example, the Games sub-menu
holds games like Same GNOME; the Sound and Video sub-menu holds CD palyes, volume controls,
and the Helix media player. For these directories, a few moments spent browsing the contents is
sufficient to familiarize yourself with your system. A few sub-menus are worth additional explanation:

Preferences
Preferences contains applications that allow you to customize your system. Most of
the applications in this sub-menu do not require root privileges to access. Refer to
Section 2.5 Customizing your GNOME session for more information about customizing your
GNOME session.

System Settings
System Settings contains higher-level configuration tools. Most of the applications in this sub-
menu require root privileges to access. You should use caution when using these applications.
For details on these applications, refer to the Red Hat Enterprise Linux System Administration
Guide.

• Date & Time: This tool allows you to set the date, time, and timezone for your system.
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• Printing: The Printer Configuration Tool allows you to add a new printer to your system,
whether it is connected to your computer or is available on a network.

• Soundcard Detection: The Sound Card Configuration Tool tool probes your system for
available sound devices. Refer to Section 10.3 Troubleshooting Your Sound Card for more de-
tails on configuring your sound hardware.

• Users and Groups: The User Manager tool allows you to add and remove users from your
system. Refer to Section 1.6 Creating a User Account for details.

System Tools
System Tools contains applications for utilizing and maintaining your system. This sub-menu
includes the Terminal application, the Floppy Formatter, and other applications discussed else-
where in this manual.

2.4.2. The Actions Menu
The Actions menu contains tasks you will most likely execute on a daily basis. These include: Lock
screen, Log Out, and Search for Files....

Lock screen
This action starts a password-protected screen saver. You must enter your password to return to
the normal desktop.

Search for Files...
This action opens a Nautilus window that allows you to search for files according to letters in
the name of the file.

Log Out
This action opens the Log Out dialog window, which terminates your GNOME session.

2.5. Customizing your GNOME session
The Preferences sub-menu of the Applications menu offers many customization options for your
GNOME session. Below are some of the highlights.
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2.5.1. Configuring your Background

Figure 2-16. The Desktop Background Preferences tool

One way to dramatically alter the appearance of your graphical desktop is to change the background
using the Desktop Background Preferences tool. You can choose from several background images
included with Red Hat Enterprise Linux in the /usr/share/backgrounds/ directory, or you can
use your own image. To start the Desktop Background Preferences tool, right-click on the desktop
and choose Change Desktop Background from the menu.

The Desktop Background Preferences tool allows you to load a background from a directory of
provided images (/usr/share/backgrounds/images/). To add images to the list of available
backgrounds, you can either drag them from your directory into the list (which does not move the file)
or you can click the Add Wallpaper button and select image files on your system.

There are several ways to display your images. The Tiled option displays multiple instances of your
image across the desktop, which is useful if you use a small image or if you use a tile (or pattern) im-
age from /usr/share/backgrounds/tiles/ (or from your own image collection). The Centered
option places your image in the center of the desktop, leaving the default background colors to fill in
any remaining desktop space. To fill the desktop with an image without tiling it, use the Scaled or
Stretched options.

To create a background with your own custom colors and no images, choose the No Wallpaper option
and adjust your colors below Desktop Colors. You can choose either a solid color or a gradient of
two colors. Clicking on the color buttons allows you to change the colors. Click Close to save and exit
the Background Preferences tool.
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Figure 2-17. The Desktop with a new background

2.5.2. Keyboard Shortcuts

Figure 2-18. The Keyboard Shortcuts application

You can create keyboard shortcuts — pressing a combination of keys on the keyboard — to perform
actions within an application or on your desktop. Open the Keyboard Shortcuts application from the
Applications => Preferences sub-menu. The application provides a list of every action to which you
can assign a shortcut. It might be helpful to spend a few moments looking at the default shortcuts;
using them can be a great time-saver. Scroll through the list until you find the action you would like to
assign a shortcut. Click once on the description of the action, and then press the keystrokes that you
would like to use as a shortcut.

To create a keyboard shortcut to switch between workspaces by pressing [Ctrl]-[Alt] and workspace
number:

1. Click on Switch to workspace 1
2. Press [Ctrl]-[Alt]-[1].

3. The Keyboard Shortcut application records that these were the keys pressed, and lists that
under the Shortcut column. (The application notifies you if the keystrokes you have chosen are
already used for another action.)

4. Repeat this process for workspaces 2-4, assigning each of them similar keystrokes.

5. Close the Keyboard Shortcuts application to save your changes.
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6. Pressing [Ctrl]-[Alt]-[2] at any time takes you to Workspace 2. Likewise, pressing [Ctrl]-[Alt]-
[3] takes you to workspace 3, [Ctrl]-[Alt]-[4] takes you to workspace 4, and [Ctrl]-[Alt]-[1]
takes you back to workspace 1.

2.5.3. Sound
The Sound preference tool allows you to set sounds to accompany events. For example, your system
can play a certain sound every time you login. When you first open this tool, you should see a series
of tabs across the top of the window. Under the General tab, check that the Enable sound server
startup box is checked.

Figure 2-19. The Sound Configuration tool

Click on the Sound Events tab, to display a list of actions that can be accompanied by a sound. To
change or add a sound to an event, click on the description of the event, then click on the Browse...
button. Choose a sound located in the file system, and then click Open. Sound files installed with
Red Hat Enterprise Linux are located in /usr/share/sounds/. You may also choose a sound file
from your home directory. Any file with a .wav extension can be used for an event sound. To listen
to a sound that has been selected, click the Play button. (If you do not hear a sound, follow the steps
in Section 10.3 Troubleshooting Your Sound Card.) When you are finished, close the Sound tool, and
your changes are saved.
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Figure 2-20. Selecting sounds to accompany events

2.5.4. Screensaver

Figure 2-21. The screensaver tool

Double-click the Screensaver icon to launch the Screensaver Preferences tool. The list on the left
displays the available screensavers. Nearly all screensavers can be customized by clicking on the Set-
tings... button. To see if this is the screensaver you would like to use, click on the Preview button.
When you have seen enough, click the mouse anywhere on the screen and you will return to Screen-
saver Preferences. When you are finished, close the window to save your changes and exit.
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2.5.5. Removable Storage

Figure 2-22. Options for usage of removable storage

Launch the Removable Storage tool from the Applications => Preferences sub-menu. The
application opens a list of options for the way your system handles removable storage media such as
floppy diskettes and CD-ROMs. One default option is auto-mounting. Auto-mount means that
the data on your removable media is automatically available a few moments after you insert
it; manual mounting is not necessary. For more information on removable media, refer to
Chapter 13 Diskettes and CD-ROMs or the Red Hat Enterprise Linux System Administration Guide.

2.6. Logging Out
To exit your GNOME session, choose Log Out from the Actions menu. You are presented with
the choice of logging out (leaving the system running), restarting the machine, or halting the system
completely. To quit the graphical desktop, select the Log Out radio button and click OK.

2.7. Switching Desktops
Switching desktops refers to switching between GNOME and KDE. There are slight differences in
the look and feel of these two graphical desktops. Choose the desktop that best suits your preferences.

There are two ways to switch desktops. You can either switch for a single session or use the Desktop
Switching Tool to change your default desktop.

To login with a different desktop for a single session:
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1. Select Session from the menu at the bottom left of the login screen. A window appears with a
list of several different desktop environments.

2. Choose one, and select OK.

3. Enter your login and password as usual. A dialog box appears, warning you that this change is
for the current session only.

4. Click OK to continue.

To change the default desktop for your system:

1. From the Applications menu, select Preferences => Desktop Switching Tool.
2. Select from the list of available desktops and click OK. A dialog box opens confirming that the

changes were successful.

3. In order for the changes to take place, you must restart your X Window System. The easiest way
to accomplish this is to log out of X and log back in. Log out of the graphical desktop, then log
back in.
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Managing Files and Directories

This chapter explores the general format of your Red Hat Enterprise Linux file system. It bridges the
differences between using Nautilus to manage the files on your system and using a shell prompt to
manage them. It does not go into the minute details of using a shell prompt; those will be covered in
Chapter 4 Shell Prompt Basics. This chapter orients you to the system as a whole, and then you can
choose which method of management you prefer.

Note

Due to system security, unless you are root, you are not allowed to gain access to all system-level
files and directories. If you do not have the permission to open, delete, or execute a file, an error
message is displayed showing your access has been denied. This is normal behavior and is used to
prevent non-privileged users from modifying or deleting important system files.

3.1. File System Terms
Below are a few terms to know before we begin our discussion of the file system.

extension

An extension is that part of a filename that is found after the final ".". In the filename foo.txt
".txt" is the file’s extension. Extensions are used to indicate file type.

path

A path is the string of directories and sub-directories you would have to navigate through in order
to reach a given location in the file system.

root access (or root privileges)

To have root access means to be logged in using the root account. This can be done from the
main login screen, a shell prompt, or any application that requires your root password. Root
access means that the user has permission to do anything on the system, so use root access with
care.

root directory

The root directory is the top-most directory of the file system. All other files and directories exist
in this directory or one of its sub-directories. Do not confuse the root directory, /, with root’s
home directory, /root/.

3.2. A Larger Picture of the File System
Every operating system has a method of storing data in files and directories so that it can keep track
of additions, modifications, and other changes. In Red Hat Enterprise Linux, every file is stored in
a directory. Directories can also contain directories: these subdirectories may also contain files and
other subdirectories.
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You might think of the file system as a tree and directories as branches. There would be no tree
without a root, and the same is true for the Red Hat Enterprise Linux file system. No matter how far
away the directories branch, everything is connected to the root directory, which is represented as a
singe forward slash (/).

Tip

Red Hat Enterprise Linux uses the term root in several different ways, which might be confusing to
new users. There is the root account (the superuser, who has permission to do anything), the root
account’s home directory (/root) and the root directory for the entire file system (/). When you are
speaking to someone and using the term root , be sure to know which root is being discussed.

3.2.1. Paths
To continue the tree analogy from Section 3.2 A Larger Picture of the File System, imagine navigating
the file system as climbing around in the branches of the tree. The branches you would climb and
traverse in order to get from one part of the tree to another would be the path from one location to
another. There are two kinds of paths, depending on how you describe them. A relative path describes
the route starting from your current location in the tree. An absolute path describes the route to the
new location starting from the tree trunk (the root directory).

Graphic file browsers like Nautilus use an absolute path to display your location in the file system.
At the top of a Nautilus browser window is a location bar. This bar indicates your current location
starting with a forward slash (/) — this is an absolute path. You can navigate the file system by
entering the absolute path here. Press [Enter] and Nautilus moves immediately to the new location
without navigating through the intervening directories one at a time.

Figure 3-1. The Nautilus location bar

Navigating via the shell prompt utilizes either relative or absolute paths. In some instances, relative
paths are shorter to type than absolute paths. In others, the unambiguous absolute path is easier to
remember.

There are two special characters used with relative paths. These characters are "." and "..". A single
period, ".", is shorthand for "here". It references your current working directory. Two periods, "..",
indicates the directory one level up from your current working directory. If your current working
directory is your home directory, /home/user/, ".." indicates the next directory up, /home/.

Consider moving from the /usr/share/doc/ directory to the /tmp/ directory. The relative path
between the two requires a great deal of typing, and requires knowledge of the absolute path to your
current working directory. The relative path would look like this: ../../../tmp/. The absolute
path is much shorter: /tmp/. The relative path requires you to move up three directories to the
/ directory before moving to the /tmp/ directory. The absolute path, which always starts at the /
directory, is much simpler.

However, the relative path between two closely-related directories may be simpler than
the absolute path. Consider moving from /var/www/html/pics/vacation/ to
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/var/www/html/pics/birthday/. The relative path is: ../birthday/. The absolute path is:
/var/www/html/pics/birthday/. Clearly, the relative path is shorter in this case.

There is no right or wrong choice: both relative and absolute paths point to the same branch of the
tree. Choosing between the two is a matter of preference and convenience. Remember, the Nautilus
location bar does not recognize the ".." symbol — you must use an absolute path.

3.3. Managing Files
If you are new to Linux, file names may look strange to you. Linux file names may include exten-
sions you haven’t seen before, may have multiple extensions, or may not have any at all. File names
may begin with a "." or may have other symbols in their names, including spaces. Below are some
guidelines regarding file names in Linux.

3.3.1. File Types
Below are the most common file types in Red Hat Enterprise Linux.

3.3.1.1. Compressed and Archived Files

• .bz2 — a file compressed with bzip2

• .gz — a file compressed with gzip

• .tar — a file archived with tar (short for tape archive), also known as a tar file

• .tbz or .tar.bz — a tarred and bzipped file

• .tgz or .tar.gz — a tarred and gzipped file

• .zip — a file compressed with ZIP compression, commonly found in MS-DOS applications; most
compressed files for Linux use the gzip compression, so finding a .zip archive for Linux files is
rare

For information on working with bzip2, gzip, and tar files, refer to
Section 3.4 File Compression and Archiving.

3.3.1.2. File Formats

• .au — an audio file

• .gif — a GIF image file (short for Graphics Interchange Format)

• .html or .htm — an HTML file (short for Hyper Text Markup Language)

• .jpg — a JPEG image file (short for Joint Photographic Experts Group)

• .pdf — an electronic image of a document; PDF stands for Portable Document Format

• .png — a PNG image file (short for Portable Network Graphic)

• .ps — a PostScript file; formatted for printing

• .txt — a plain ASCII text file

• .wav — an audio file

• .xpm — an image file (short for X Pixelmap)
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3.3.1.3. System Files

• .conf — a configuration file; configuration files sometimes use the .cfg extension, as well

• .lock — a lock file; determines whether a program or device is in use

• .rpm — a Red Hat Package Manager file used to install software

3.3.1.4. Programming and Scripting Files

• .c — a C program language source code file

• .cpp — a C++ program language source code file

• .h — a C or C++ program language header file

• .o — a program object file

• .pl — a Perl script

• .py — a Python script

• .so — a library file

• .sh — a shell script

• .tcl — a TCL script

3.3.2. Naming Conventions

3.3.2.1. Dot Files
Files whose name begins with a ".", called "dot" files, are hidden files. These files can be viewed in
both graphical file managers like Nautilus and from the shell prompt, but require an extra step to reveal
them. In Nautilus, select View => Show Hidden Files. From a shell prompt, list the files in your home
directory by entering the command ls -al. If you view the hidden files in your home directory, you
may be surprised by the number of files in what you thought was an empty directory. These hidden
files are usually configuration files for applications. They are hidden to prevent accidental changes
and to remove clutter from the user’s home directory.

3.3.2.2. Using Spaces in File Names
While Linux allows file names with spaces in them, manipulating these files from a shell prompt can
be quite cumbersome. The shell prompt expects a space to separate two files or commands, and may
mis-interpret such a filename. To manipulate files with spaces in their names, surround the name with
quotation marks.

3.3.2.3. Using Symbols in File Names
It is possible to use punctuation marks in your file names. However, be aware that these special char-
acters have special meaning to the shell and may cause errors at a shell prompt. It is generally recom-
mended that you avoid using special characters in file names for this reason. If you choose to use file
names with special characters, use quotes around the file names when manipulating them from a shell
prompt.
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There are a few special characters you cannot use in file names. You cannot use a "/" — this indicates
a directory. You cannot name a file "." or "..", for reasons discussed in Section 3.2.1 Paths.

3.3.2.4. Files with Multiple Extensions
Filenames can have multiple extensions. There may be a "." in the middle of a file name, or there may
actually be multiple extensions. These multiple extensions usually arise when processing a file through
multiple programs or commands. The most common file type with multiple extensions is a compressed
archive. Compresed files are discussed in detail in Section 3.4 File Compression and Archiving.

3.3.3. Finding the Correct File Extension
File extensions are not always used, or used consistently. What happens when a file does not have an
extension, or the file does not seem to be what the extension says it is supposed to be? That is when
the file command can be helpful.

For example, you find a file called saturday without an extension. The file command enables
you to see what type of file it is. Enter file saturday at a shell prompt. In this example, the
command responds with ASCII text. Any file that is designated as a text file should be readable
by using the cat, more, or less commands, or by using a text editor such as gedit or vi. Refer
to Section 4.8 Viewing text files from the shell prompt for more information on cat, more, and less.
Refer to Chapter 9 Working with Other Text Applications for more information on gedit and vi.

3.4. File Compression and Archiving
It is useful to store a group of files in one file for easy backup, for transfer to another directory, or
for transfer to another computer. It is also useful to compress large files; compressed files take up less
disk space and download faster via the Internet.

It is important to understand the distinction between an archive file and a compressed file. An archive
file is a collection of files and directories stored in one file. The archive file is not compressed — it
uses the same amount of disk space as all the individual files and directories combined. A compressed
file is a collection of files and directories that are stored in one file and stored in a way that uses less
disk space than all the individual files and directories combined. If disk space is a concern, compress
rarely-used files, or place all such files in a single archive file and compress it.

Note

An archive file is not compressed, but a compressed file can be an archive file.

3.4.1. Using File Roller
Red Hat Enterprise Linux includes a graphical utility called File Roller. File Roller can compress,
decompress, and archive files in common Unix and Linux formats. It has a simple interface and exten-
sive help documentation. To start File Roller, select Archive Manager from the Applications (the
main menu on the panel) => System Tools sub-menu. File Roller is also integrated into the desktop
environment and Nautilus.
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Tip

If you are using a file manager (such as Nautilus), you can double-click the file you wish to unar-
chive or decompress to start File Roller. The File Roller browser window appears with the decom-
pressed/unarchived file in a folder for you to extract or browse.

Figure 3-2. File Roller in Action

3.4.1.1. Decompressing and Unarchiving with File Roller
To unarchive and/or decompress a file, click the Open button on the main toolbar. A file menu pops
up, allowing you to choose the archive you wish to manipulate. For example, if you have a file called
foo.tar.gz located in your home directory, highlight the file and click OK. The file appears in the
main File Roller browser window as a folder, which you can navigate by double-clicking the folder
icon. File Roller preserves all directory and subdirectory structures, which is convenient if you are
looking for a particular file in the archive. You can extract individual files or entire archives by clicking
the Extract button, choosing the directory in which to save the unarchived files, and clicking OK.
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3.4.1.2. Creating Archives with File Roller

Figure 3-3. Creating an Archive with File Roller

File Roller allows you to create archives of your files and directories. To create a new archive, click
New on the toolbar. A file browser pops up, allowing you to specify an archive name and the com-
pression technique. For example, you may choose a Tar Compressed with gzip (.tar.gz) format from
the drop-down menu and type the name of the archive file you want to create. Click OK and your new
archive is ready to be filled with files and directories. To add files to your new archive, click Add,
which opens a browser window that you can navigate to find the file or directory to add to the archive.
Click Add when you are finished, and click Archive => Close to close the archive.

Tip

There is much more you can do with File Roller than is explained here. Refer to the File Roller
manual (available by clicking Help => Manual) for more information.

3.4.2. Compressing Files at the Shell Prompt
Red Hat Enterprise Linux provides the bzip2, gzip, and zip tools for compression from a shell
prompt. The bzip2 compression tool is recommended because it provides the most compression and
is found on most UNIX-like operating systems. The gzip compression tool can also be found on
most UNIX-like operating systems. To transfer files between Linux and other operating system such
as MS Windows, use zip because it is more compatible with the compression utilities available for
Windows.

Compression Tool File Extension Decompression Tool

bzip2 .bz2 bunzip2

gzip .gz gunzip

zip .zip unzip
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Table 3-1. Compression Tools

By convention, files compressed with bzip2 are given the extension .bz2, files compressed with
gzip are given the extension .gz, and files compressed with zip are given the extension .zip.

Files compressed with bzip2 are uncompressed with bunzip2, files compressed with gzip are un-
compressed with gunzip, and files compressed with zip are uncompressed with unzip.

3.4.2.1. Bzip2 and Bunzip2
To use bzip2 to compress a file, enter the following command at a shell prompt:

bzip2 filename

The file is compressed and saved as filename.bz2.

To expand the compressed file, enter the following command:

bunzip2 filename.bz2

The filename.bz2 compressed file is deleted and replaced with filename.

You can use bzip2 to compress multiple files and directories at the same time by listing them with a
space between each one:

bzip2 filename.bz2 file1 file2 file3 /usr/work/school

The above command compresses file1, file2, file3, and the contents of the
/usr/work/school/ directory (assuming this directory exists) and places them in a file named
filename.bz2.

Tip

For more information, enter man bzip2 and man bunzip2 at a shell prompt to read the man pages
for bzip2 and bunzip2.

3.4.2.2. Gzip and Gunzip
To use gzip to compress a file, enter the following command at a shell prompt:

gzip filename

The file is compressed and saved as filename.gz.

To expand the compressed file, enter the following command:

gunzip filename.gz

The filename.gz compressed file is deleted and replaced with filename.

You can use gzip to compress multiple files and directories at the same time by listing them with a
space between each one:

gzip -r filename.gz file1 file2 file3 /usr/work/school
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The above command compresses file1, file2, file3, and the contents of the
/usr/work/school/ directory (assuming this directory exists) and places them in a file named
filename.gz.

Tip

For more information, enter man gzip and man gunzip at a shell prompt to read the man pages for
gzip and gunzip.

3.4.2.3. Zip and Unzip
To compress a file with zip, enter the following command:

zip -r filename.zip filesdir

In this example, filename.zip represents the file you are creating and filesdir represents the
directory you want to put in the new zip file. The -r option specifies that you want to include all files
contained in the filesdir directory recursively.

To extract the contents of a zip file, enter the following command:

unzip filename.zip

You can use zip to compress multiple files and directories at the same time by listing them with a
space between each one:

zip -r filename.zip file1 file2 file3 /usr/work/school

The above command compresses file1, file2, file3, and the contents of the
/usr/work/school/ directory (assuming this directory exists) and places them in a file named
filename.zip.

Tip

For more information, enter man zip and man unzip at a shell prompt to read the man pages for zip
and unzip.

3.4.3. Archiving Files at the Shell Prompt
A tar file is a collection of several files and/or directories in one file. This is a good way to create
backups and archives.

Some of tar’s options include:

• -c — create a new archive

• -f — when used with the -c option, use the filename specified for the creation of the tar file;
when used with the -x option, unarchive the specified file

• -t — show the list of files in the tar file
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• -v — show the progress of the files being archived

• -x — extract files from an archive

• -z — compress the tar file with gzip

• -j — compress the tar file with bzip2

To create a tar file, enter:

tar -cvf filename.tar directory/file

In this example, filename.tar represents the file you are creating and directory/file represents
the directory and file you want to put in the archived file.

You can tar multiple files and directories at the same time by listing them with a space between each
one:

tar -cvf filename.tar /home/mine/work /home/mine/school

The above command places all the files in the work and the school subdirectories of /home/mine
in a new file called filename.tar in the current directory.

To list the contents of a tar file, enter:

tar -tvf filename.tar

To extract the contents of a tar file, enter:

tar -xvf filename.tar

This command does not remove the tar file, but it places copies of its unarchived contents in the
current working directory, preserving any directory structure that the archive file used. For example, if
the tarfile contains a file called bar.txtwithin a directory called foo/, then extracting the archive file
results in the creation of the directory foo/ in your current working directory with the file bar.txt
inside of it.

Remember, the tar command does not compress the files by default. To create a tarred and bzipped
compressed file, use the -j option:

tar -cjvf filename.tbz file

tar files compressed with bzip2 are conventionally given the extension .tbz; however, sometimes
users archive their files using the tar.bz2 extension.

The above command creates an archive file and then compresses it as the file filename.tbz. If you
uncompress the filename.tbz file with the bunzip2 command, the filename.tbz file is removed
and replaced with filename.tar.

You can also expand and unarchive a bzip tar file in one command:

tar -xjvf filename.tbz

To create a tarred and gzipped compressed file, use the -z option:

tar -czvf filename.tgz file
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tar files compressed with gzip are conventionally given the extension .tgz.

This command creates the archive file filename.tar and compresses it as the file filename.tgz.
(The file filename.tar is not saved.) If you uncompress the filename.tgz file with the gunzip
command, the filename.tgz file is removed and replaced with filename.tar.

You can expand a gzip tar file in one command:

tar -xzvf filename.tgz

Tip

Enter the command man tar for more information about the tar command.

3.5. Managing Directories
In many ways, directories are treated like files. They can be created, deleted, moved and copied from
Nautilus or from a shell prompt, using commands similar to those for files.

3.5.1. Creating Directories
You must have write permissions in a directory in order to create a new sub-directory. Most users have
these permissions in their home directory (and its sub-directories) and the /tmp/ directory.

To create a new directory with Nautilus, navigate to the location of your new directory. Right-click
in a blank portion of the window and select Create Folder. A new folder icon appears with the
highlighted text untitled folder. Type a name for your folder and press [Enter].

To create a new directory using a shell prompt, use the command mkdir. Enter: mkdir
<directory-name>, replacing <directory-name> with the intended title of the new
directory.

3.5.2. Deleting Directories
To delete a directory from Nautilus, right click on it and choose Move to Trash, or click and drag the
icon to the Trash on the Desktop.

To delete an empty directory from a shell prompt, enter the command rmdir. To delete a directory that
may not be empty (and consequently everything inside that directory), enter the command rm -rf
<directory>. Refer to Section 4.5.5 Delete files with rm for more information regarding the rm
command.

3.5.3. Dot Directories
Applications create "dot" directories as well as dot files. Dot files are a single hidden configuration
file — a dot directory is a hidden directory of configuration and other files required by the application.
The non-configuration files in these directories are generally user-specific, and will be available only
to the user who installed them.
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Chapter 4.
Shell Prompt Basics

4.1. Why Use a Shell Prompt
Graphical environments for Linux have come a long way in the past few years. You can be perfectly
productive in the X Window System and only have to open a shell prompt to complete a few tasks.

However, many Red Hat Enterprise Linux functions can be completed faster from the shell prompt
than from a graphical user interface (GUI). In less time than it takes to open a file manager, locate a
directory, and then create, delete, or modify files from a GUI, a task can be finished with just a few
commands at a shell prompt.

A shell prompt looks similar to other command line interfaces with which you might be familiar.
Users type commands at a shell prompt, the shell interprets these commands, and then the shell tells
the OS what to do. Experienced users can write shell scripts to expand their capabilities even further.

Figure 4-1. A Shell Prompt

This chapter explains how to navigate the file system, manipulate files, perform simple administration
tasks, and other shell prompt basics.

4.2. The History of the Shell
When AT&T software engineers Dennis Ritchie and Ken Thompson were designing UNIX™, they
wanted to create a way for people to interact with their new system.

Operating systems at that time came with command interpreters, which could take commands from
the user and interpret them into something computers could use.

But Ritchie and Thompson wanted something more, something that offered better features than the
command interpreters available at that time. This led to the development of the Bourne shell (known as
sh), created by S.R. Bourne. Since the creation of the Bourne shell, other shells have been developed,
such as the C shell (csh) and the Korn shell (ksh).
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When the Free Software Foundation sought a royalty-free shell, developers began to work on the
language behind the Bourne shell as well as some of the popular features from other shells available
at the time.

The result was the Bourne Again Shell, or bash. Although your Red Hat Enterprise Linux system
includes several different shells, bash is the default shell for interactive users. You can learn more
about bash by reading the bash man page (type man bash at a shell prompt).

4.3. Basics
This chapter starts by introducing some general information about working with the command line.
From there, it explains how to: locate yourself in the file system, move and manipulate files, browse to
other directories, and view their contents. Finally, it moves on to more complicated issues including
re-direction and permissions.

4.3.1. Shell Prompt Terms
Below are a few terms to know before beginning the discussion of the shell prompt.

command line

The command line is where options to a command are placed. The following is an example of a
command line:

command -options <filename>

shell prompt

The shell prompt is the marker on the screen that shows where the command line should be
placed. The following is an example of a shell prompt:

[username@localhost.localdomain username]$

shell

The shell is the program that interprets commands so that the operating system can understand
them.

terminal window

The terminal window is the window that contains the shell prompt, command line, and output
from the shell.

4.3.2. Opening and using a Shell Prompt
Recall from Section 1.5 Opening a Shell Prompt that a terminal window is opened from the Applica-
tions (the main menu on the panel), or by right-clicking on the desktop and selecting Open Terminal.
Entering or running a command refers to typing a given command and pressing [Enter]. To close a
terminal window, either click on the [X] in the upper right corner of the screen or enter the exit
command at the shell prompt.

The shell prompt within a terminal window looks something like this:

[username@localhost.localdomain username]$

There are any number of symbols that can be used to indicate the end of the shell prompt, and you can
customize what your prompt looks like. However, there are two symbols that you will see more often
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than any others, "$" and "#". The first symbol, "$", is the last character in the prompt when you are
logged in as a normal user. The shell prompt for a normal user looks something like this:

[username@localhost.localdomain username]$

The second symbol, "#", is the last character in the prompt when you are logged in as root. This is
true whether you logged in as root from the initial screen or if you executed the su - command to
become root. The shell prompt for root looks something like this:

[root@localhost.localdomain root]#

This slight difference can help remind you what privileges you currently have.

4.3.3. Structure of shell prompt commands
In general, a command run from the shell prompt will have the following format:

command -options <filename>.

Both -options and <filename> are optional: the command may not require either one, or it
may require multiple options and files. When specifying multiple options, list them as a group. For
example, to see a long listing of information (-l) about all files (-a) in a directory, you would run the
command:

ls -la

There are many variations in required information types for individual commands. If you aren’t sure
about a command and how it is used, you can do one of three things:

• Enter the command alone at a shell prompt and press [Enter]. For example, entering cp alone
returns a brief description of the command and its usage. Other commands, such as cat, require no
arguments or files to run as normal. To quit such a command, press [Ctrl]-[D]. If that does not work,
press [Ctrl]-[C].

• Enter man command at a shell prompt. This opens the manual page for that command. A man
page is a manual written by the command’s developer explaining how it is used and what each
option means. You can also enter man man at a shell prompt for more information on man pages.
Navigate through the man page using the directional keys on your keyboard. The [Space] bar moves
you down a page, [B] moves you up a page. To quit, press [Q]. If the man page for a command is
either unavailable or does not provide enough information, the info system may provide additional
information.

• Enter info command at a shell prompt. Some info pages have the same information as man
pages, but navigation is slightly different. For more information, enter info info at a shell
prompt.

4.3.4. Useful tips for the bash shell
Below are a few useful features of the bash shell that reduce the amount of typing required at a shell
prompt. The first of these is tab completion, the second is command history, and the third is useful
keystrokes.
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4.3.4.1. Tab Completion
Tab completion is one of the most useful shortcuts available at the command line. Red Hat Enterprise
Linux has the ability to "guess" what command, directory, or filename you are entering at the shell
prompt. Press the [Tab] key, and the shell offers possible completions for partial words. The more
letters typed before pressing [Tab], the closer the shell comes to the intended command.

If there are multiple solutions to the partial text on the command line, the shell presents them as a list.
If the list is very long, the shell will first ask if you would like to display all matches. Navigate long
lists of potential matches by pressing the [Space] bar to go down one page, the [B] key to go back one
page, the directional (or "arrow") keys to move one line at a time, and [Q] to quit.

The shell assumes that the first word entered at the prompt is a command. The possible completions it
offers are the names of commands or applications. This can be helpful if you are not sure of the exact
spelling of a command or if you are searching for a certain command. It can also serve to help a new
user become familiar with the available commands.

For example:

1. Type the letter g at a prompt and press [Tab] twice.

2. The shell asks if you want to see all 379 possibilities. This means that there are 379 commands
that start with the letter "g". Searching through this list would take too much time.

3. Press [N] for no.

4. Entering more of the command name will produce a shorter list of possible matches. For this
example, type gnome and press [Tab] twice. A list of every command that starts with "gnome"
appears. This is a much shorter list, and can be scrolled through using the same keys as man
pages. Scroll to the end of the list to return to the shell prompt. The letters "gnome" are still
entered.

5. To finish entering a command with tab completion, enter just a few more characters, "-ca", and
press [Tab] twice. The shell returns a match of gnome-calculator, and if you then press [Enter],
the GNOME Calculator application starts.

Tab completion also works on filenames and directories. The shell prompt assumes that the second
word on the command line is a filename or directory. Typing a partial word and pressing [Tab] twice
will generate possible completions according to the files and sub-directories in your current working
directory. The command line "knows" your directory structure. You can use tab completion to enter
a long string of sub-directories by typing the first few letters of each directory and pressing [Tab]
instead of navigating to one subdirectory at a time.

For example, reaching the sub-directory

example/sub-dir1/sub-dir2/sub-dir3/

would take a great deal of repetitive typing. However, with tab completion, a user would only have to
enter a few keystrokes:

$ cd ex[Tab]su[Tab]su[Tab]su[Tab]

4.3.4.2. Command History
It is unnecessary to type the same command over and over. The bash shell remembers your past
commands. These commands are stored in the .bash_history file in each user’s home directory.
To use the history, press the up arrow to scroll backward through the commands you have already
entered. The [Ctrl]-[R] shortcut searches through your previous commands. Press [Ctrl]-[R] and type
the beginning of the command you previously issued. The command history stops at the most recent
version of that command.
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Commands that you only typed partially and did not follow with [Enter] are not saved into your
command history file. To clear your command history, type history -c.

By default, Red Hat Enterprise Linux stores 1000 commands. Each terminal window or shell prompt
stores a separate set of commands. If you gain root privileges by using the command su -, the history
file (and thus the commands) you access are root’s, not the user’s.

4.3.4.3. [Ctrl]-[Z] and running processes in the background
Applications and processes can be started from the command line. When an application starts from
the command line, that particular shell is taken up with standard output for that application until the
application closes. The screen fills with gibberish or messages that can be ignored. To continue to
use the current shell while running an application from the same shell, add the ampersand, "&", to
the end of the command line. For example, oowriter & starts OpenOffice.org Writer and allows
you to continue entering commands on the command line. This is known as running a process in the
background.

If you have started an application or process and forgotten to add the &, first press [Ctrl]-[Z] — this
suspends the application. To allow it to continue running without displaying standard output, type bg
and press [Enter]. This is referred to as running the application in the background.

4.3.4.4. Wildcards
Wildcards are place holders used to allow users to search for or use multiple files with similar names.
The subject of wildcards is part of the larger subject of regular expressions. Two of the most common
wildcards are "*" and "?".

The asterisk, "*", represents any character or string of characters. The entry a*.txt could refer to
ab.txt as well as aardvark.txt.

The question mark represents a single character. The entry a?.txt could refer to ab.txt and
a1.txt, but not aardvark.txt.

What if you forget the name of the file you are looking for? Using wildcards or regular expressions,
you can perform actions on a file or files without knowing the complete file name. Type out what you
know, substituting a wildcard for the remainder.

Tip

To read more about wildcards and regular expressions, take a look at the bash man page (man bash).
You can save the file to a text file by typing man bash | col -b > bash.txt. Then, you can open
and read the file with less or with an editor such as vi (vi bash.txt). If you want to print the file,
be aware that it is quite long.

For example, to find a file called "sneaksomething.txt," enter:

ls sneak*.txt

The shell lists every file that matches that pattern:

sneakers.txt

Regular expressions are more complex than the straightforward asterisk or question mark.

When an asterisk, for example, just happens to be part of a file name, as might be the case if the file
sneakers.txt was called sneak*.txt, that is when regular expressions can be useful.
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Using the backslash (\), you can specify that you do not want to search out everything by using the
asterisk, but you are instead looking for a file with an asterisk in the name.

If the file is called sneak*.txt, type:

sneak\*.txt

Here is a brief list of wildcards and regular expressions:

• * — Matches all characters

• ? — Matches one character

• \* — Matches the * character

• \? — Matches the ? character

• \) — Matches the ) character

4.3.4.5. Useful Keystrokes
While working from the command line, there are a few useful keystrokes that can help you with your
session.

The following keystrokes are useful shortcuts at a shell prompt.

Keystroke Action

[Ctrl]-[K] While editing a command on the command line, this key combination
deletes everything that has been typed in from the cursor’s current
position forward.

[Ctrl]-[D] Pressing this key combination once ends the current application or
process. Pressing it twice exits the shell.

[Ctrl]-[R] At the command line, [Ctrl]-[R] searches through the command history to
find the entry that starts with the letters you type.

[Ctrl]-[Z] Suspends the current application. Entering bg after [Ctrl]-[Z] causes a
program to run in the background.

[Ctrl]-[C] "Kills" a program. This should be a last resort. Try stopping a program
with other methods first.

[Ctrl]-[L] Clears the terminal window.

Table 4-1. Useful shell prompt keystrokes

4.3.4.6. Clearing and Resetting the Terminal
The terminal window begins to look crowded very quickly. You can always exit from the terminal
window and open a new one, but there is a quicker and easier way to remove the contents displayed
in the terminal.

To clear the terminal, enter the command clear at the shell prompt. The clear command clears the
terminal, leaving only a new shell prompt at the top of the window.

You can also clear the screen using the keystroke [Ctrl]-[L].
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Sometimes, you may accidentally open a program file or some other non-text file in a terminal window.
When you close the file, you could find that the text you are typing does not match the output on the
monitor.

In such cases, enter reset to return the terminal window to its default values.

4.4. Determining Your Current Directory with pwd
As you browse directories, it is easy to get lost or forget the name of your current directory. By default,
the Bash prompt in Red Hat Enterprise Linux shows only your current directory, not the entire path.
For example, the path to the application gedit is /usr/bin/gedit. The path to user someone’s home
directory is /home/someone/. Refer to Section 3.2.1 Paths for more information on paths.

Figure 4-2. The Command pwd Displays Your Location

To display the location of your current working directory, enter the command pwd.

The output should look similar to:

/home/user

4.5. Manipulating Files in Your Current Working Directory
Below is a summary of basic shell commands:

Action Command Format Details

Copy a file cp cp filename destination Copies the file filename to the
location destination.

List Directory
Contents

ls ls The ls command lists files in
the current working directory.
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Action Command Format Details

Move a file mv mv which_file
destination

To move a file from one
directory to another, use mv.

Rename a file mv mv oldname newname The use of the mv command
changes the name of the file
from oldname to newname.

Table 4-2. Commands for Manipulating Files

Each of the commands listed above have options that may be specified on the command line. More
information about each is provided below.

4.5.1. Viewing Directory Contents with ls
To see what is in your current working directory, use the ls command.

Many options are available with the ls command. The ls command, by itself, does not show all of
the files in the directory. Some files are hidden files (also called dot files) and can only be seen with
an additional option specified to the ls command.

Tip

To view all ls command options, read the man page by entering man ls at a shell prompt. To print
the man page, enter man ls | col -b | lpr at the prompt.

Enter the command ls -a. Now you an view the hidden "dot" files.

Viewing all the files using the ls -a command can give you plenty of detail, but you can view still
more information by using multiple options.

To see the size of a file or directory, when it was created, and so on, add the long option (-l) to the ls
-a command. This command shows the file creation date, its size, ownership, permissions, and more.

You do not have to be in the directory whose contents you want to view to use the ls command. For
example, to see what is in the /etc/ directory from your home directory, type:

ls -al /etc
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Figure 4-3. Sample ls Output for the /etc Directory

The following is a brief list of options commonly used with ls. Remember, you can view the full list
by reading the ls man page (man ls).

• -a (all) — Lists all files in the directory, including hidden files (.filename). The .. and . at the
top of your list refer to the parent directory and the current directory, respectively.

• -l (long) — Lists details about contents, including permissions (modes), owner, group, size, cre-
ation date, whether the file is a link to somewhere else on the system and where its link points.

• -F (file type) — Adds a symbol to the end of each listing. These symbols include /, to indicate a
directory; @, to indicate a symbolic link to another file; and *, to indicate an executable file.

• -r (reverse) — Lists the contents of the directory in reverse sort order.

• -R (recursive) — Lists the contents of all directories below the current directory recursively.

• -S (size) — Sorts files by their sizes.

The ls command can also be used with wildcards to display information on files or directories that
match a certain pattern. To list all files and directories that begin with the letter "a", enter the following
command.

ls -al a*

Remember that Linux is case-sensitive. The above command will not display information on files that
start with "A".

4.5.2. Copying files with cp
To create a copy of an existing file, use the cp command.

While cp does have options, they are not used as often as those of other commands. To view these
options, read the man page by entering man cp at a shellprompt.

To copy a file within the current directorym specify the new name as the third wod on the command
line.

cp original_file new_file

This command creates a new file, named new_file, with the same content as the original file.
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To copy a file to a different direcoty, specify a path as the third word on the command line:

cp original_file /dir1/dir2/

This command creates a copy of original_file in dir2/. If the last part of the path is a filename
instead of a directory, the copy has that new name.

cp original_file /dir1/dir2/new_file

This creates a new file named new_file with the contents of original_file in dir2/.

Alternatively, if you know where the file is and would like to place a copy of it in your current
directory, enter the path as word two and "." as the third word.

cp /dir1/dir2/filename .

The above command places a copy of filename in your current working directory.

4.5.3. Moving files with mv
To move a file or directory from one location to another, use the command mv.

Common useful options for mv include:

• -i (interactive) — Prompts you if the file you have selected overwrites an existing file in the
destination directory.

• -f (force) — Overrides the interactive mode and moves without prompting. Be very careful about
using this option.

• -v (verbose) — Shows the progress of the files as they are being moved.

To move a file from the current directory to another location, enter a path as the third word on the
command line.

mv filename /dir1/

This command would remove filename from the current working directory and place it in /dir1/.

Alternatively, a path to the location of the file may be entered as the second word and "." as the thrid
word. This moves the file from the location specified in word two into your current working directory.

mv /tmp/filename .

The above command moves the file filename from the /tmp/ directory into your current working
directory.

Finally, both words two and three may be paths.

mv ../../filename /tmp/new_name

The command above moves the file filename from a directory two levels up to the /tmp/ directory
while renaming the file new_name.
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Note

You can only move files to a directory that already exists: Linux will not create a new directory with
the mv command.

4.5.4. Renaming files with mv
To rename a file or directory, use the mv command.

To rename a file with mv, the third word on the command line must end in the new filename.

mv original_name new_name

The above command renames the file original_name to new_name.

mv ../original_name new_name

The above command moves the file original_name from one directory up to the current directory
and renames it new_name.

mv original_name /dir1/dir2/dir3/new_name

The above command moves the file original_name from the current working directory to directory
dir3/ and renames it new_name.

4.5.5. Delete files with rm

Caution

Deleting a file with rmis permanent — you cannot un-delete it.

To delete a file using rm enter the following at a shell prompt:

rm filename

The second word can also be a path, but must end in a file.

rm ../../filename

There are many options to rm. To view them all, enter man rm at the shell prompt.

• -i (interactive) — Prompts you to confirm the deletion. This option can stop you from deleting a
file by mistake.

• -f (force) — Overrides interactive mode and removes the file(s) without prompting. This might not
be a good idea, unless you know exactly what you are doing.

• -v (verbose) — Shows the progress of the files as they are being removed.

• -r (recursive) — Deletes a directory and all files and subdirectories it contains.
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Tip

The interactive, or -i, option for rm causes it to ask if you are sure before permanently deleting a file
or directory. You can make this the default behavior for rm by editing the .bashrc file. This file is
located in your home directory. You can edit the file with any text editor.

gedit /home/user/.bashrc

Add the following line somewhere in the file. The end of the file is a good location.

alias rm=’rm -i’

Save the file. At the command line, enter the following command.

source .baschrc

Now you will be asked to enter [Y] before deleting a file or directory with rm

4.5.6. Deleting directories
There are two commands that can be used to delete directories. The first is rmdir and the second is
rm.

The rmdir command will only delete directories that are empty. If you are concerned about acciden-
tally deleting a directory that is not empty, use this command.

rmdir directory/

The above command permanently deletes directory/ if it is empty.

If you want to delete a directory and all of its contents, use the command rm -rf. Note that if you
enter rm -rf, the shell will not ask if you are sure before permanently deleting the directory.

rm -rf /dir1/

The above command deletes /dir1/ and every file and sub-directory that exists inside.

4.6. Leaving your Current Working Directory
To change directories from your current working directory, use the command cd.

cd /tmp/

The above command changes directories to the /tmp/ directory. The second word on the command
line must be a path. It can either be relative or absolute, and can move one directory or many. If
the cd command is entered at the shell prompt with no options or path specified, the default action
is to move the user into their home directory. For example, user someone would be moved to the
/home/someone/ directory.

The cd has many useful options. You can see all of these options by entering man cd at the shell
prompt. The most commonly used options are listed below.

• cd — Returns you to your login directory

• cd - — Returns you to your previous working directory
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• cd ~ — Also returns you to your login directory

• cd / — Takes you to the entire system’s root directory.

• cd /root — Takes you to the home directory of the root user. You must be the root user to access
this directory.

• cd /home — Takes you to the home directory, where user login directories are usually stored

• cd .. — Takes you to the directory one level up.

• cd ~otheruser — Takes you to otheruser’s home directory, if otheruser has granted you
permission.

Below are a few examples of the use of cd.

• cd /dir1/dir2/ — Regardless of which directory you are in, this absolute path takes you directly to
dir2, a subdirectory of /dir1/.

• cd ../../dir2/dir3/ — This relative path takes you up two directories, then to dir2/, and finally into
its subdirectory dir3/.

If you attempt to cd into a directory you do not have permission to access, you are denied permission
to access that directory.

Denying access to the root and other users’ accounts (or home directories) is one way your
Red Hat Enterprise Linux system prevents accidental or malicious tampering. Refer to
Section 4.11 Ownership and Permissions for more information.

4.7. Locating Files and Directories
There may be times when you know a file or directory exists but you do not know where to find it.
There are several commands you can use to search for it, including find, locate, and which.

4.7.1. Find
The format of the find command is:

find path pattern

If you do not specify a path, find starts in the current working directory and looks through all subdi-
rectories for the specified pattern.

The find command has many options that you can review by entering man find at a shell prompt.
The most common option is -name, which tells find to search for all files and directories with a certain
string of letters in their name.

find . -name foo

The above command searches through the current working directory for all files with "foo" in their
name.

4.7.2. Locate
The format of the locate command is:

locate pattern
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With locate, you can see every file or directory whose name contains the search criterion. For ex-
ample, to search for all files with the word finger in the name, type:

locate finger

The locate command uses a database to locate files and directories that have the word finger in
the file or directory name. The search results could include a file called finger.txt, a file called
pointerfinger.txt, a directory named /fingerthumbnails/, and so on. To learn more about
locate, read the locate man page (type man locate at a shell prompt).

The locate command works very quickly, as long as the database is up to date. That database is
automatically updated on a nightly basis through a cron job. cron is a small program that runs in the
background, performing various tasks (such as updating the locate database) at regularly scheduled
intervals. Refer to the Red Hat Enterprise Linux System Administration Guide for more information
on cron.

To update the database manually, log in as root (type su - at a shell prompt and then your root
password) and type the command updatedb.

After a few minutes, the slocate database that is used by the locate command is updated.

When you are done working as root, type exit at the prompt; you are returned to your user account.

4.7.3. Which, whereis, whatis

which

The format of the which command is:
which command

which returns the location of binary, or executable, shell commands. The
information provided by whichis useful for creating application launchers. Refer to
Section 2.2.1 Adding Application Launchers for more information.
which gedit

The above command returns the information /usr/bin/gedit.

whereis

The format of the whereis command is:
whereis command

The following command returns the locations of: the binary of find, the location of the source
code, and the location of the find man page.
whereis find
/usr/bin/find /usr/share/man/man1p/find.1p.gz /usr/share/man/man1/find.1.gz

whatis

The format of the whatis is:
whatis command

This command returnsinformation about the command from each of its man pages.
whatis lp

The above command returns:
lp (4) - line printer devices
lp(lp-cups) (1) - print files
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Tip

Checking the usage of a command using whatis before reading the man page can save you some
time.

4.8. Viewing text files from the shell prompt
Red Hat Enterprise Linux has several applications that allow you to view and manipulate text files
at the shell prompt. These applications are fast and best suited to manipulating the plain text files of
configuration files.

4.8.1. The head Command
The head command displays the beginning of a file. The format of the head command is:

head <filename>

By default, you can only read the first ten lines of a file. You can change the number of lines displayed
by specifying a number option.

head -20 <filename>

The above command would display the first 20 lines of a file named <filename>.

4.8.2. The tail Command
The reverse of head is tail. Using tail, you can view the last ten lines of a file. This can be useful
for viewing the last ten lines of a log file for important system messages. You can also use tail to
watch log files as they are updated. Using the -f option, tail automatically prints new messages
from an open file to the screen in real-time. For example, to actively watch /var/log/messages,
enter the folowing at a shell prompt (as the root user):

tail -f /var/log/messages

Press [Ctrl]-[C] when you are finished.

4.8.3. The more Command
The more command is a "pager" utility used to view text in the terminal window one page or screen
at a time. The [Space] bar moves forward one page and [Q] quits.

4.8.4. Viewing Files with less
The format of the less command is:

less <filename>
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The main difference between more and less is that less allows backward and single-line movement
using the same navigation as man pages: press the [Space] bar to go down one page, the [B] to go
back one page, the directional (or "arrow") keys to move one line at a time, and [Q] to quit.

To search the output of a text file using less, press [/] and enter the keyword to search for within the
file.

/stuff

The above command would search through the file for all instances of "stuff" and highlight them in
the text.

4.8.5. Viewing and creating files with cat
The cat command is a versatile utility. It can be used to view text, to create text files, and to join files.
Its name is short for concatenate, which means to combine files.

Using cat alone echoes on the screen any text you enter. It will continue to do so until you exit with
the [Ctrl]-[D] keystroke.

Entering the cat command followed by a file name displays the entire contents of the file on the
screen. If the file is long, the contents scroll off the screen. You can control this by using the redirection
techiniques that are discussed in Section 4.9 Manipulating Information from the Shell.

4.8.6. The grep Command
The grep command is useful for finding specific character strings in a file. For example, to find every
reference made to "pattern" in the file <filename>, enter:

grep pattern <filename>

Each line in the file that includes the pattern "pattern" is located and displayed on the screen/

4.9. Manipulating Information from the Shell
From the shell’s point of view, there are three kinds of information: standard input, standard out-
put, and standard error. In simple terms, standard input is the information that a user enters from
the keyboard for the shell to use, such as commands and filenames. Standard output is essentially the
information the shell prints on the screen after evaluating a user’s commands. Standard error is the in-
formation that indicates that something has gone wrong. Collectively, these three types of information
are referred to as standard I/O (input/output).

The ability to manipulate and use information from the shell is one of the strengths of Red Hat Enter-
prise Linux. This section discusses the simpler aspects of standard I/O manipulation.

4.9.1. Pipes and Pagers
In Section 4.8.5 Viewing and creating files with cat, we saw that using cat to view a large file causes
the contents to scroll off the screen. Using a pipe, we can control that behavior. A pipe is the ( | )
symbol. It is used to connect the standard output of one command to the standard input of another
command. Essentially, it allows a user to string commands together. Pagers are commands (such as
less) that display text in the terminal window.
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Using cat, the pipe (|), and less together displays the file one page at a time. You can then use the
up and down arrow keys to move backward and forward through the pages.

cat <filename> | less

The above command opens the file named <filename> using the cat command, but does not
allow it to scroll off the screen.

Using the pipe with a pager is also useful when examining large directories with ls. For example,
view the /etc/ directory with the ls command.

ls -al /etc/

Notice that the contents scroll past too quickly to view. To get a closer look at the output of the ls
command, pipe it through less.

ls -al /etc/ | less

Now you can view the contents of /etc/ one screen at a time. Remember that you can navigate
forward and backward through the screens and even search for specific text using the [/] key.

You can combine redirection with wildcards.

ls -al /etc/ a* | less

The above displays all files and directories in /etc/ that start with the letter "a" one screen at a time.

4.9.2. Using Redirection
Redirection means changing where standard input comes from or where the standard output goes.

To redirect standard output, use the > symbol. Placing > after the cat command (or after any utility
that writes to standard output) redirects its output to the file name following the symbol.

Remember that the cat command echoes the text you enter on the screen. Those echoes are the stan-
dard output of the command. To redirect this output to a file, type the following at a shell prompt and
press Enter: cat > foo.txt. Enter a few more lines of text, and use the [Ctrl]-[D] key combination
to quit cat.

The following screen is an example, redirecting three lines of text into the file foo.txt.

Figure 4-4. Redirecting Output to a File
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The following screen is another example, redirecting three more lines of text to create the file
bar.txt.

Figure 4-5. Redirecting Output to a Second File

The following screen demonstrates cat’s concatenate function, adding the contents of bar.txt to
the end of foo.txt. Without redirection to the file example1.txt, cat displays the concatenated
contents of foo.txt and bar.txt on the screen.

Figure 4-6. Concatenating Two Files

The following screen displays the contents of example1.txt, so that the user can see how the files
were added together.
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Figure 4-7. Contents of example1.txt

Caution

Be careful when you redirect the output to a file, because you can easily overwrite an existing file!
Make sure the name of the file you are creating does not match the name of a pre-existing file, unless
you want to replace it.

4.9.3. Appending Standard Output
The symbol >> appends standard output. This means it adds the standard output to the end of a file,
rather than over-writing the file.

The following screen shows the command to append bar.txt to foo.txt. The contents of bar.txt
are now permanently added to the end of foo.txt. The cat command is called a second time to
display the contents of foo.txt.

Figure 4-8. Appending bar.txt to foo.txt

To compare example1.txt and the modified foo.txt, use the diff command. diff compares
text files line-by-line and reports the differences to standard output. The following screen shows the
comparison between example1.txt and foo.txt. Because there are no differences, diff returns
no information.
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Figure 4-9. diff Comparison of example1.txt and foo.txt

4.9.4. Redirecting Standard Input
You can also perform the same type of redirection with standard input.

When you use the redirect standard input symbol <, you are telling the shell that you want a file to be
read as input for a command.

The following screen shows foo.txt being redirected as input for cat:

Figure 4-10. Redirecting Standard Input

4.10. Using Multiple Commands
Linux allows you to enter multiple commands at one time. The only requirement is that you separate
the commands with a semicolon.

Suppose you have downloaded a new file called foobar-1.3-2.i386.rpm and you want to put it in
a new subdirectory within your home directory called rpms/, but the subdirectory has not been cre-
ated. You can combine both the creation of the rpms/ directory and the moving of your downloaded
file into the directory by typing the following at a shell prompt:

mkdir rpms/; mv foobar-1.3-2.i386.rpm rpms/

Running the combination of commands creates the directory and moves the file in one line.
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4.11. Ownership and Permissions
As a regular user, try to enter root’s home directory by entering the command cd /root/. Note the
error message:

-bash: cd: /root/: Permission denied

That was one demonstration of Linux’s security features. Linux, like UNIX, is a multi-user system
and file permissions are one way the system protects against malicious tampering.

One way to gain entry when you are denied permission is to enter the command su -. This is because
whoever knows the root password has complete access.

However, switching to the superuser is not always convenient or recommended, since it is easy to
make mistakes and alter important configuration files as the superuser.

All files and directories are "owned" by the person who created them. You created the file foo.txt
(refer to Section 4.9.2 Using Redirection) in your login directory, so foo.txt belongs to you.

That means you can specify who is allowed to read the file, write to the file, or (if it is an application
instead of a text file) who can execute the file.

Reading, writing, and executing are the three main settings in permissions. Since users are placed into
a group when their accounts are created, you can also specify whether certain groups can read, write
to, or execute a file.

Take a closer look at foo.txt with the ls command using the -l option (refer to Figure 4-11).

A lot of detail is provided here. You can see who can read (r) and write to (w) the file, as well as who
created the file (user), and to which group the owner belongs (user). (By default, the name of your
group is the same as your login name.)

Figure 4-11. Permissions for foo.txt

Other information to the right of the group includes file size, date and time of file creation, and file
name.

The first column shows current permissions; it has ten slots. The first slot represents the type of file.
The remaining nine slots are actually three sets of permissions for three different categories of users.

For example:

-rw-rw-r--

Those three sets are the owner of the file, the group in which the file belongs, and "others," meaning
other users on the system.

- (rw-) (rw-) (r--) 1 user user

The first item, which specifies the file type, will probably be one of the following:
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• d — a directory

• - (dash) — a regular file (rather than directory or link)

• l — a symbolic link to another program or file elsewhere on the system

Others are possible, but are beyond the scope of this manual. Refer to the Red Hat Enterprise Linux
System Administration Guide for more information.

Beyond the first item, in each of the following three sets, you may see one of the following:

• r — file can be read

• w — file can be written to

• x — file can be executed (if it is a program)

• - (dash) — specific permission has not been assigned

When you see a dash in owner, group, or others, it means that particular permission has not been
granted. Look again at the first column of foo.txt and identify its permissions.

ls -l foo.txt
-rw-rw-r-- 1 user user 150 Mar 19 08:08 foo.txt

The file’s owner (in this case, user) has permission to read and write to the file. The group, user, has
permission to read and write to foo.txt, as well. It is not a program, so neither the owner or the
group has permission to execute it.

4.11.1. The chmod Command
Use the chmod command to change permissions. This example shows how to change the permissions
on foo.txt with the chmod command.

The original file looks like this, with its initial permissions settings:

-rw-rw-r-- 1 user user 150 Mar 19 08:08 foo.txt

If you are the owner of the file or are logged into the root account, you can change any permissions
for the owner, group, and others.

Right now, the owner and group can read and write to the file. Anyone outside of the group can only
read the file (r--).

Caution

Remember that file permissions are a security feature. Whenever you allow anyone else to read, write
to, and execute files, you are increasing the risk of files being tampered with, altered, or deleted. As
a rule, you should only grant read and write permissions to those who truly need them.

In the following example, you want to allow everyone to write to the file, so they can read it, write
notes in it, and save it. That means you must change the "others" section of the file permissions.

Take a look at the file first. At the shell prompt, type:

ls -l foo.txt

The previous command displays this file information:

-rw-rw-r-- 1 user user 150 Mar 19 08:08 foo.txt
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Now, type the following:

chmod o+w foo.txt

The o+w command tells the system you want to give others write permission to the file foo.txt. To
check the results, list the file’s details again. Now, the file looks like this:

-rw-rw-rw- 1 user user 150 Mar 19 08:08 foo.txt

Now, everyone can read and write to the file.

To remove read and write permissions from foo.txt use the chmod command to take away both the
read and write permissions.

chmod go-rw foo.txt

By typing go-rw, you are telling the system to remove read and write permissions for the group and
for others from the file foo.txt.

The result looks like this:

-rw------- 1 user user 150 Mar 19 08:08 foo.txt

Think of these settings as a kind of shorthand when you want to change permissions with chmod,
because all you really have to do is remember a few symbols and letters with the chmod command.

Here is a list of what the shorthand represents:

Identities

u — the user who owns the file (that is, the owner)

g — the group to which the user belongs

o — others (not the owner or the owner’s group)

a — everyone or all (u, g, and o)

Permissions

r — read access

w — write access

x — execute access

Actions

+ — adds the permission

- — removes the permission

= — makes it the only permission

Want to test your permissions skills? Remove all permissions from foo.txt — for everyone.

chmod a-rwx foo.txt

Now, see if you can read the file with the command cat foo.txt, which should return the following:

cat: foo.txt: Permission denied

Removing all permissions, including your own, successfully locked the file. But since the file belongs
to you, you can always change its permissions back with the following command:
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chmod u+rw foo.txt

Use the command cat foo.txt to verify that you, the file owner, can read the file again.

Here are some common examples of settings that can be used with chmod:

• g+w — adds write access for the group

• o-rwx — removes all permissions for others

• u+x — allows the file owner to execute the file

• a+rw — allows everyone to read and write to the file

• ug+r — allows the owner and group to read the file

• g=rx — allows only the group to read and execute (not write)

By adding the -R option, you can change permissions for entire directory trees.

Because you can not really "execute" a directory as you would an application, when you add (or
remove) the execute permission for a directory, you are really allowing (or denying) permission to
search through that directory.

Examine the dir1/ directory you created in section FIXME by listing all of the files in your home
directory.

ls -l /home/>user</

The permissions on this directory are:

drwxrwxr-x 2 mgoldin mgoldin 4096 Jan 6 15:05 dir1

If you do not allow others to have execute permission on the dir1/ directory, it does not matter who
has read or write access. No one can access the directory unless they know the exact file name.

For example, type

chmod a-x dir1/

to remove everyone’s execute permissions.

Here is what happens when you try to change directories using the cd dir1/ command after remov-
ing everyone’s execute permissions:

bash: dir1/: Permission denied

Next, restore your own and your group’s access:

chmod ug+x dir1/

If you check your work with ls -l, you can see that only others are denied access to the /dir1/
directory.

4.11.2. Changing Permissions With Numbers
Another way to change permissions uses numeric representations.

Go back to the original permissions for foo.txt:

-rw-rw-r-- 1 user user 150 Mar 19 08:08 foo.txt
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Each permission setting can be represented by a numerical value:

• r = 4

• w = 2

• x = 1

• - = 0

When these values are added together, the total is used to set specific permissions. For example, if you
want read and write permissions, you would have a value of 6; 4 (read) + 2 (write) = 6.

For foo.txt, here are the numerical permissions settings:

- (rw-) (rw-) (r--)

The total for the user is six(4+2+0), the total for the group is six(4+2+0), and the total for others is
four(4+0+0). The permissions setting is read as 664.

If you want to change foo.txt so those in your group do not have write access, but can still read the
file, remove the access by subtracting two (2) from that set of numbers.

The numerical values then become six, four, and four (644).

To implement these new settings, type:

chmod 644 foo.txt

Now verify the changes by listing the file. Type:

ls -l foo.txt

The output should be:

-rw-r--r-- 1 user user 150 Mar 19 08:08 foo.txt

Now, neither the group nor others have write permission to foo.txt. To return the group’s write
access for the file, add the value of w (2) to the second set of permissions.

chmod 664 foo.txt

Warning

Setting permissions to 666 allows everyone to read and write to a file or directory. Setting permis-
sions to 777 allows everyone read, write, and execute permission. These permissions could allow
tampering with sensitive files, so in general, it is not a good idea to use these settings.

Here is a list of some common settings, numerical values and their meanings:

Setting Numerical Meaning

-rw------- (600) Only the owner has read and write permissions.

-rw-r--r-- (644) Only the owner has read and write permissions; the group
and others have read only.
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Setting Numerical Meaning

-rwx------ (700) Only the owner has read, write, and execute permissions.

-rwxr-xr-x (755) The owner has read, write, and execute permissions; the
group and others have only read and execute.

-rwx--x--x (711) The owner has read, write, and execute permissions; the
group and others have only execute.

-rw-rw-rw- (666) Everyone can read and write to the file. (Be careful with
these permissions.)

-rwxrwxrwx (777) Everyone can read, write, and execute. (Again, this
permissions setting can be hazardous.)

Table 4-3. File permissions settings, numerical values, and their meanings

Here are some common settings for directories:

Setting Numerical Meaning

drwx------ (700) Only the user can read, write in this directory.

drwxr-xr-x (755) Everyone can read the directory; users and groups have
read and execute permissions.

Table 4-4. Directory permissions settings, numerical values, and their meanings



II. Using Your System

Now that you have begun exploring your Red Hat Enterprise Linux system, you can start using some
of the many applications that are included with it. From Internet surfing and personal productivity, to
games and beyond, this part details some popular software programs that help you become more pro-
ductive with your computer, and tap the power of the Internet for your research and communications.
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Chapter 5.
Connecting to the Internet

Perhaps the most important change in communication since the telephone, the Internet is a large part
of our world today. Red Hat Enterprise Linux has the tools necessary to allow you to connect to that
world.

There are many types of Internet connections, including:

ISDN Connection

An ISDN (Integrated Services Digital Network) connection uses high-speed, high-quality digital
telecommunication lines as opposed to an analog modem connection. This special phone line
must be installed by a phone company.

Modem Connection

A modem connection uses a normal phone line to establish a connection to the Internet. Digital
data is modulated into analog signals and sent over phone lines.

Wireless Connection

A wireless connection uses a wireless access point (WAP) or peer-to-peer network with a wireless
network card.

xDSL Connection

An xDSL (Digital Subscriber Line) connection uses high-speed transmissions through telephone
lines. There are different types of DSL such as ADSL, IDSL, and SDSL. Internet Configuration
Wizard uses the term xDSL to mean all types of DSL connections.

Ethernet Connections

Some xDSL and cable modem connections require users to set up their connections via Ethernet.
The ethernet card in your Red Hat Enterprise Linux system communicates with the xDSL or
cable modem, which communicates in turn with your ISP.

This chapter discusses setting up a modem (or dial-up) connection in detail. The procedures for cre-
ating connections of the remaining types is similar, but may require additional steps or information
from your Internet Service Provider (ISP).

Your own ISP may have specific connection requirements for their service which differ from the
instructions in this chapter. Before connecting, check with your ISP for any specific instructions that
they provide, including the following information:

• The phone number that your modem must dial to connect to your ISP if you are using a modem.

• Your login name and password for your account if you are using an xDSL or modem connection.

• A gateway address. Some ISPs may require you to configure a master address (called the gateway)
that authenticates your computer and allows it to connect to the Internet.

• DNS entries: DNS means Domain Name System. DNS servers act as a road map for the Internet.
When you use the Internet, the DNS tells your machine where to send its traffic. DNS tracks IP
(Internet Protocol) addresses; each computer connected to the Internet must have an IP address,
which is a unique set of numbers like 2xx.2xx.2x.2. You may receive one or more DNS entries
from your Internet provider when you sign up.
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5.1. The Internet Configuration Wizard

Figure 5-1. Internet Configuration Wizard

Red Hat Enterprise Linux includes the Internet Configuration Wizard. The Internet Configuration
Wizard is available from the Applications (the main menu on the panel) => System Tools sub-menu,
or from a shell prompt via the command internet-druid. This tool guides you step-by-step through
the process of establishing a new Internet connection.

When you first start the Internet Configuration Wizard, you are required to enter your root pass-
word.

Each of the types of connections are listed in the left pane of the window. Select the type of connection
to establish, then follow the steps of the wizard.

The next section of this chapter goes through the details of creating a dial-up connection as an exam-
ple.

5.2. Creating a Dial-Up Connection
A dial-up connection requires your computer’s modem to dial a phone number that connects to your
Internet Service Provider (ISP). Your computer may have a modem built in, or you may have to use a
modem card if your system is a laptop.

Note

If your computer has a software-based modem such as WinModem, you may not be able to use it in
Linux.

To create a new modem connection:

1. From the Applications (the main menu on the panel) menu, choose System Tools => Internet
Configuration Wizard.

2. A window opens requesting your root password. Enter it and click OK.

3. The Add new Device Type window opens.
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4. The left pane lists each of the possible connections. Choose Modem connection and click the
Forward button.

5. Red Hat Enterprise Linux probes for a working modem installed on your computer. If it does
not find one, make sure that you have a hardware modem, and that it is installed correctly.

6. The next screen contains three drop-down boxes.

• Modem Device — This menu lists all modems installed on your system. Select the correct
modem for this connection.

• Baud Rate — Select the speed of your modem. This list is in bytes: a 56.6K modem is listed
as 56700.

• Flow Control — Select Hardware if your modem is a hardware device installed on your
system.

When finished making your selections, click the Forward button.

7. The next screen requires information about your ISP. For users in the United States, type the
correct information in each field:

• Prefix — Enter any prefix necessary to reach your access number. This might be "1" if the
call is long distance, or "9" to reach an outside line.

• Area Code — Enter the area code of your access number, if necessary.

• Phone Number — Enter the access number for your ISP. Do not enter "dashes" in the num-
ber.

• Provider Name — Enter the name of your ISP.

• Login Name — Enter the login your ISP has given you.

• Password — Enter the password for your account.

Finally, click the Forward button.

8. On the next screen, select whether your system must automatically obtain your IP address set-
tings or whether your system must use the same IP address every time you connect. To use the
same address every time, enter the address your ISP gave you into the Manual IP Address
Settings fields. Click the Forward button to continue.

9. The final screen is a summary of the values you have entered. Review them to be sure that all
settings are correct. Click the Apply button to create your new connection.

10. The Network Configuration screen appears, showing your new connection along with a list of
all other connections on your machine.

11. Test your new connection by clicking the Activate button. If your connection works, go to
File => Save from the Network Configuration main toolbar, then exit the application. If your
connection does not work, click the Edit button to change the settings.

To access your connection later, select Applications (the main menu on the panel) => System Settings
=> Network. The Network Configuration window opens. Select the appropriate connection and
click Activate.

5.3. Creating a High Speed Connection
Creating a high-speed connection is similar to connecting a modem. There are, however, a few ad-
ditional complications. Ask your ISP which of the following configurations is appropriate for your
connection.
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DHCP

You may be required to configure your sytem to obtain an IP address through DHCP. To configure
this type of connection, start the Internet Configuration Wizard, select Ethernet Connection,
and select DHCP from the Configure Network Settings screen. Some DSL providers and most
cable modem providers use this configuration.

PPPoE

Alternatively, some DSL providers require your system to use a PPPoE (Point-to-Point Protocol
over Ethernet) connection. To configure this type of connection, start the Internet Configuration
Wizard, select xDSL Connection, and follow the steps in the wizard. If you must supply a
username and password to connect, you are probably using PPPoE.

Tip

For advanced configuration of client DHCP options such as protocol timing, lease requirements and
requests, dynamic DNS support, aliases, as well as a wide variety of values to override, prepend, or
append, refer to the dhclient and dhclient.conf man pages. You may also refer to the Red Hat
Enterprise Linux System Administration Guide for more information.

5.4. Creating a Wireless Connection
If you are connecting your Red Hat Enterprise Linux system to a wireless access point (WAP) or a
peer-to-peer (also called ad-hoc) network with a wireless (802.11.x) network card, you must configure
your wireless device.

Start the Internet Configuration Wizard, select Wireless Connection, and follow the prompts. You
can then configure the device for DHCP or fixed IP addresses.

5.5. Additional Resources
Speak to your ISP to see if they support setting up your connection with Linux. There are also several
web sites available that will help you in setting up your connection.

• http://linuxnewbies.editthispage.com/tips/20020219

• http://en.tldp.org/HOWTO/HOWTO-INDEX/networking.html#NETPROTOCOLS

• http://oob.freeshell.org/nzwireless/LWAP-HOWTO.html
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Web Browsing

Once you have configured your Internet connection (refer to Chapter 5 Connecting to the Internet),
you are ready to browse the Internet. Red Hat Enterprise Linux comes with several Web
browsers, graphical applications that use your Internet connection to access the World Wide
Web: news, research, shopping, banking, and more. This chapter briefly explains how to surf
the Web using Firefox. For information about using the Konqueror Web browser, refer to
Section A.6 Browsing the Web with Konqueror.

6.1. Firefox

Figure 6-1. Mozilla Firefox

Firefox is part of the mozilla.org organization’s wide range of Open Source Internet application de-
velopments. Firefox is powerful, integrated, and standards-compliant. It features tabbed browsing, the
use of plug-ins, and available extensions and themes for the browser. This section shows you how to
use the Firefox web browser to explore the Internet.

Mozilla.org provides excellent documentation and help at:

• http://www.mozilla.org/support/firefox.

• http://www.mozilla.org/community.

6.1.1. Using Firefox
Firefox functions like any Web browser you may have used before. it has the standard navigational
toolbars, buttons, and menus.

The Navigation toolbar contains navigation icons, the address bar, and a search field.
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Figure 6-2. Navigation Toolbar

Enter a Uniform Resource Locator (URL) — the name or address of a web site — into the address
field. Firefox moves immediately to the web site.

The Search field uses the most popular search engines to look for sites related to the keywords you
enter. Select the search engine Firefox should use by clicking on the icon at the left of the field. Enter
the keywords and press [Enter] to perform the search.

Figure 6-3. Search field

Firefox has a sidebar to aid in navigation. Select View => Sidebar form the main Firefox toolbar,
then choose the detail to display. You can choose from your bookmarks or the history of websites you
have visited.

Finally, the Personal Toolbar can be customized with the web sites that you visit most often. Web
sites added to this toolbar become buttons — one click, and Firefox moves to that web site. To add a
site to the Personal Toolbar, drag the site’s icon from the address field to the Toolbar.

Figure 6-4. Personal Toolbar

6.1.2. Tabbed Browsing
Firefox offers tabbed browsing. Tabbed browsing allows a user to flip quickly between web pages
without opening another instance of Firefox. Right-click a link and choose Open Link in New Tab
to use this feature. Open a new tab by selecting File => New Tab or by pressing [Ctrl]-[T].
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Figure 6-5. Open Tabs

6.1.3. Plug-ins
Plug-ins, applications that expand the abilities of Firefox, are available for download. A full list of
plugins can be found at :

http://channels.netscape.com/ns/browsers/plugins.jsp.

6.1.4. Extensions and Themes
There are many extensions and themes available for Firefox. Extensions are small applets (smaller
than plug-ins) that provide additional functionality to Firefox. For example, there is an extension
called ForecastFox that adds a small toolbar at the bottom of Firefox that includes the local weather
forecast. This and other extensions are available by going to the Tools menu and selecting Extensions.
To add new extensions to your Firefox browser, click the Get More Extensions link in the bottom
right of the window.

Themes allow you to change the way your browser looks. They change the color of the browser
window and the icons on your toolbars. To download and install new themes, open the Themes tool
by selecting Tools => Themes from the main toolbar. Click the Get More Themes link in the bottom
right of the window.
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Chapter 7.
Email Applications

Email is a very popular way of communicating with others over the Internet. An application that allows
users to send, receive, and read email is called an email client. Red Hat Enterprise Linux includes
several email applications, including graphical email clients like Evolution and Thunderbird, and
text-based clients like mutt. Each of the email client applications is designed to suit specific types of
users; so, you can choose one with the features that best suits your particular needs.

The purpose of this chapter is to demonstrate how to use some of the popular email applications
included in Red Hat Enterprise Linux. Since all email clients perform the same basic tasks (send and
receive email), you should choose one that is convenient and easy to use.

This chapter briefly discusses the following email clients:

• Evolution
• Thunderbird
• Mutt, a text-based email client

Before you launch an email client, you need information from your Internet Service Provider (ISP) to
configure the client properly. The following is a list of important configuration information:

Your email address

The email address you use to send and receive mail. This is usually in the form of
<yourname>@<example.com>. In this example, <yourname> is your user name and
<example.com> is the domain name for your ISP.

Server type for receiving email

In order to receive mail, you must know what type of server the ISP is using, POP or IMAP.

POP, short for Post Office Protocol, is used to send email from a mail server to your email client’s
inbox, the place where incoming email is stored. Most ISP email servers use the POP protocol,
although some use the newer IMAP protocol. POP mail is downloaded to your email client
directly and does not stay on the server by default (although most email clients can be configured
to leave email on the server as well).

IMAP, short for Internet Message Access Protocol, is a protocol for retrieving email messages
from your ISP’s email server. IMAP differs from POP in that email from IMAP servers are stored
on the server and not downloaded to the mail client.

Address for receiving email

In order to receive mail, you must obtain the address of the POP or IMAP server from your ISP.
This address is usually in the form of mail.example.com.

Server type for sending email (SMTP)

The Simple Mail Transfer Protocol (SMTP) is a protocol for sending email messages between
mail servers. Most email systems use SMTP to send messages over the Internet; the messages
can then be retrieved with an email client using either POP or IMAP. SMTP is also used to send
messages from a mail client to a mail server. This is why you need to specify both the POP or
IMAP server and the SMTP server when configuring an email application.
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If you have any questions regarding what information you need, contact your ISP or network admin-
istrator. Unless properly configured, you cannot make full use of the email clients discussed in this
chapter.

7.1. Evolution
Evolution is more than just an email client. It provides all of the standard email client features,
including powerful mailbox management, user-defined filters, and quick searches. Additionally, it
features a flexible calendar/scheduler which allows users to create and confirm group meetings and
special events online. Evolution is a full-featured personal and work group information management
tool for Linux and UNIX-based systems, and is the default email client for Red Hat Enterprise Linux.

To launch Evolution from the desktop panel, go to Applications => Internet => Email, or click on
the Email icon on your Panel.

Figure 7-1. Evolution Welcome Screen

The first time you start Evolution you are presented with the Welcome Screen (Figure 7-1), which
allows you to configure your email connection. Follow the on-screen instructions and fill in the infor-
mation you collected from your ISP or administrator in the text boxes provided. When you are done,
click Finish. Evolution proceeds to the Main Screen as shown in Figure 7-2.
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Figure 7-2. Evolution Main Screen

To view what is in your inbox or to send an email, click on the Mail button in the left toolbar, then
select the Inbox icon from the list of folders.

Figure 7-3. Evolution Inbox Screen

To compose a new message, click on the down arrow beside the New icon. Select Mail Message from
the drop-down list. You can also press [Shift]-[Ctrl]-[M]. Enter the address of the recipient in the To
field, the subject of the email in the Subject field, and the text of your message in the large pane
below. You can spell check your email before sending by going to Edit => Spell Check Document or
by pressing [Shift]-[Ctrl]-[L]. You can attach documents by clicking on the Attach icon. A window
opens that allows you to navigate to the file you would like to attach. Click on the name of the file to
highlight it, then click on the Open button. Finally, when you are finished, click the Send button to
send.
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Figure 7-4. Evolution New Email Message Screen

While Evolution does much more than read and send email, this chapter focuses exclusively on its
email capabilities. To learn more about Evolution’s other features, refer to the Help text.

7.2. Thunderbird
This section briefly covers the basic steps for sending and receiving email with Thunderbird. For
more information about using Thunderbird, the Help contents are located under Help on the main
menu.

To start Thunderbird, select Applications => Internet => Thunderbird Mail.
You are presented with a New Account Setup screen. You are first asked whether you would like to
import information from other email programs. Make your selection and click on the Next >> button.
On the next screen, select Email account, which allows you to configure your email connection. Fol-
low the on-screen instructions and fill in the information you collected from your ISP or administrator
in the text boxes provided.
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Figure 7-5. Account Setup

Figure 7-6. Thunderbird Mail

To create a new email message, click the Write button. A blank message will open in a new window.
Enter the address(es) of the recipient(s) of your email in the To field(s). Enter the subject of your email
in the Subject field. In the large bottom pane, enter the text of your email. You can spell check your
email by clicking on the Spell icon or by pressing [Ctrl]-[Shift]-[K]. You can attach files by clicking
on the Attach icon, or by going to File => Attach => File(s). Finally, when you are finihsed with
your email, click the Send icon. The email window closes and returns you to the main screen.
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Figure 7-7. Thunderbird Mail New Email Message Screen

To read email, click on the Get Mail icon to check for new mail. Click on the folders in the left sidebar
to open them. If there are any messsages in that folder, they appear as a list in the top-right pane of the
window. As you click on each email in the list, a preview of its contents appears in the pane directly
below. If there are any attachments to your email, a field labelled Attachments lists the names of the
files. Double-click the file name to open or save the file.

Once you read a message, you can delete it, save it to a separate folder, and more.

7.2.1. Thunderbird and Newsgroups
Newsgroups are Internet discussion groups with specific topics. The discussions are in threaded format
(which means all topics and responses to the topic are sorted and organized for convenient reading)
and subscribing to a group is easy. You are not required to post messages; instead, you can just lurk,
which is a Newsgroup term for reading without posting messages. There are a great many newsgroups
on the Web with topics ranging from politics to computer games to random strange thoughts. You can
even post and download pictures and files to Newsgroups (although your ISP may restrict Newsgroups
to text-based postings only).

To join a newsgroup, you first need to set up a newsgroup account. Click on your mail account name
in the sidebar and select Create a new account from the options that appear on the right of the screen.
The New Account Setup screen appears again. Select Newsgroup account and then click Next.
Enter your name and email address in the blank fields and click Next. On the following screen, enter
the name of your news server (if you do not know the name of your news server, contact your Internet
service provider or network administrator for this information). On the last few screens, you can
determine the name of this account and review your settings.

The newsgroup account you created appears in the sidebar of the Thunderbird mail screen. Right-
click on this account name and select Subscribe. A dialog box appears, listing all the newsgroups
available. Select the groups you are interested in reading and click Subscribe. When you are done,
click on OK.

Double-click on the newsgroup account name and the list of groups you are subscribed to appears
beneath. Select the newsgroup you want to access and a dialog box appears with information about
downloading and reading existing messages. Posting to a newsgroup is just like writing an email,
except that the newsgroup name appears in the To field rather than an email address. To unsubscribe
from a newsgroup, right-click on the group name and select Unsubscribe.
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7.3. Plain Text Email Clients
Most modern email clients allow the user to select whether they want to send their emails in plain
text or in HTML. HTML formatted email can contain formated text, graphics, and interactive links to
Web sites. The particular font can be specified, the layout is very controllable, textures, and pictures
or backgrounds can be added; all this makes for a visually appealing message when it gets to the
recipient.

On the other hand, plain text email is just that — plain text. There is nothing fancy, there are no
pictures embedded in the email, and there are no special fonts.

The term plain text refers to textual data in ASCII format. Plain text (also called clear text) is the
most portable format because it is supported by nearly every email application on various types of
machines.

This chapter discusses the mutt plain text email client.

7.3.1. Using Mutt
Mutt is a small but very powerful text-based mail client for UNIX operating systems.

The configuration file for Mutt, ~/.muttrc, is highly configurable. Because a user can control nearly
all of the functions within Mutt, new users sometimes run into problems with initial configuration.

Most of the options for Mutt are invoked using the set or unset commands, with either boolean or
string values, e.g. set folder = ~/Mail.

All configuration options can be changed at any time by typing a [:] followed by the relevant com-
mand. For example :unset help turns off the keyboard command hints at the top of the screen. To
turn those hints back on, type :set help.

If you cannot remember the command, there is always tab-completion to help.

You do not have to type all your preferred configuration commands each time you run mutt, you can
save them in a file which is loaded every time the program starts up. This configuration file must exist
in your home directory, and it must be named either ~/.muttrc or ~/.mutt/muttrc.

When you launch mutt (by typing mutt at a shell prompt), a screen appears with a list of email
messages. This initial menu is called the index.

Figure 7-8. mutt Main Screen
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These messages are in a default mail folder, called the inbox or mailspool. Use the [K] and [J] keys
on your keyboard to move the highlighted cursor up and down the list of messages.

In the index or pager views, use the [R] key to reply to a message or the [M] key to create a new one.
Mutt prompts for the To: address and the Subject: line. A text editor (defined by your $EDITOR en-
vironmental variable in the configuration file) then launches, allowing you to compose your message.
Type your message, save your file and exit the editor.

After editing the email, Mutt displays the compose menu, which allows you to customize your mes-
sage headers, change the encoding, add file attachments or press the [Y] key to send your email on its
way.

To learn more about mutt, refer to the man pages for muttrc and mutt (type man muttrc or man
mutt at the shell prompt). You may also find the mutt manual to be very helpful. The mutt manual
is installed in /usr/share/doc/mutt-1.2.x/, where x is the version number of mutt installed on
your system.



Chapter 8.
Working with OpenOffice.org

8.1. Feature overview of OpenOffice.org
OpenOffice.org is a powerful office suite that includes word processing, spreadsheets, and slides. It
has all of the functionality of the best-known office suites, and uses some powerful additional tools to
help you easily create professional-looking documents.

One of the benefits of using an open source office suite is the vibrant community of OpenOffice.org
users who share their templates, tutorials, and other information on the web. Extensive documentation
for the OpenOffice.org suite is available online, both at their website and on various user sites.

This chapter takes a quick look at features that apply to the suite as a whole, and then goes more
in-depth to each of the applications within the suite. For more information, you can always take a look
at the help menus in OpenOffice.org, which include handbooks and extensive information.

8.1.1. Compatibility with other formats
OpenOffice.org is compatible with most common document formats, including:

• MS Office, from 6.0 through the present version

• RTF (Rich Text Format)

• StarWriter

• HTML (Hyper Text Markup Language)

• PDF (Portable Document Format)

Currently, OpenOffice.org is not compatible with a few formats, including:

• MS Works

• WordPerfect

In the case of WordPerfect, a filter can be installed that will allow you to work with WordPerfect
documents. It is called WriterPerfect and is available at SourceForge: http://libwpd.sourceforge.net/.

8.1.2. Styles
The use of styles is one of the most powerful aspects of OpenOffice. A style is a set of formating
instructions that are used throughout a document.

Many users format their documents manually, highlighting each block of text individually and select-
ing formatting options each time a change is made. This practice is reasonable for short documents,
but is time-consuming and inconsistent for longer documents.

When consistency in appearance is important, formatting with styles is more efficient. Creating a
style that fits your specific needs requires an initial investment of time — but once the style has
been created, it saves effort in two ways. First, a style can be applied to any document created in
OpenOffice.org, immediately creating identical documents. Second, making a single change in the
style creates changes across the entire document.
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Use the Stylist to apply styles to text. It can be reached by clicking on the yellow diamond icon on
your toolbar, by going to Format => Styles, or by pressing [F11]. To apply a style, highlight a block
of text, then double-click on the appropriate style in the Stylist, such as Heading1 or Text body.

To change a style throughout a document:

1. Highlight a representative block of text, such as a Heading1 block of text.

2. Make formatting changes — color, font, etc.

3. With the text still highlighted, press the Update Style button on the Stylist.

4. All text that has the same style applied will now have the formatting that you just applied.

For more information, refer to the documentation available at the OpenOffice.org web site:
http://documentation.openoffice.org/manuals/oooauthors/IntroStyles.sxw.

8.1.3. Templates
A template is essentially a blank form that a user fills with content. A common example of a template
is letterhead, which has the sender’s postal information at the top and a blank body for the letter text.
In OpenOffice.org, templates can contain text, images, and formatting.If you find yourself frequently
re-creating a relatively simple document, creating a template can save you time.

To create a template:

1. Create a normal file containing the text and formatting you would like to use for your template
using one of the OpenOffice.org applications.

2. Save the file as a template by choosing File => Templates => Save.

3. Enter a name for your new template and click the OK button.

To use a template:

1. Start OpenOffice.org.

2. Go to File => New => Templates and Documents
3. A window will open with three template folders. Your template will most likely be in the folder

marked Default.
4. Open the folder and select the template you wish to use.

5. Edit the file and add whatever content you choose.

6. Save normally. You will create a new file instead of over-writing your template.

For more information, refer to OpenOffice.org’s documents at:
http://documentation.openoffice.org/HOW_TO/word_processing/HowTo_Work_with_Templates.sxw.

8.1.4. Special Tools of OpenOffice.org

Spell Check

OpenOffice.org Writer includes an extensive, customizable dictionary for spell-checking. Also
included is the ability to AutoSpellcheck - check spelling as you type. With AutoSpellcheck,
a potentially misspelled word will be underlined in red. If you right-click on the word, the best
matches for that word are provided. Select the correct word from the list. To spell check an entire
document, go to Tools => Spellcheck => Check. To turn off the auto spell checker, go to Tools
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=> Spellcheck => AutoSpellcheck and remove the checkmark there by clicking on it once. To
turn it back on, click on it again.

Thesaurus

OpenOffice.org also includes a thesaurus. Click on the word to replace or double-click it to
highlight the word. Go to Tools => Thesaurus. You will see a list of synonyms in the right pane.
Scroll through the list of synonyms. When you find the one you are looking for, either double-
click on it or click once to select and then click the OK button to insert it into your text. If the
list of words does not include the word you want, you can select a word from the list by clicking
once and then clicking the Search button. A new list of related words will be provided.

AutoCorrect / AutoFormat

The AutoCorrect / AutoFormat feature is one that automatically corrects common typing mis-
takes and applies formatting to certain types of text. Users can determine to what extent this
feature assists them by going to Tools => AutoCorrect / AutoFormat. This opens a dialog with
tabs that allow you to customize this feature’s behavior. The Options tab allows users to select
whether certain standard substitutions are made. The Word Completion tab allows users to turn
this feature on and off, and to specify additional options. If at any time you make changes to
AutoCorrect / AutoFormat and don’t feel it has been applied to your text, highlight the area of
text and select Format => AutoFormat => Apply.

8.1.5. More Help and Documentation
OpenOffice.org has excellent documentation, including tutorials, FAQs, and setup guides. Try the
following helpful links:

• http://documentation.openoffice.org/HOW_TO/word_processing/Word-to-OOo.html has informa-
tion especially helpful to those users who are accustomed to Microsoft Office.

• http://documentation.openoffice.org/ has a list of the various documentation projects being main-
tained. This is where you will find FAQs, tutorials, and more.

• Be sure to check out the extensive Help menu. Go to Help => Contents, and choose the Find tab.
This allows you to search through the help files for a keyword or phrase. Selecting the Contents
tab allows you to search for your topic by browsing through subjects.

• Search for a keyword or phrase plus "OpenOffice.org" with your favorite search engine.

8.2. OpenOffice.org Writer
A word processor is like a text editor but has several additional features that allow you to format,
design, and print your documents without the need to memorize complex formatting tags or codes.
OpenOffice.org Writer is a powerful word processor that features WYSIWYG formatting - what you
see in the OpenOffice.org Writer window is what you get if you print or share the document.

8.2.1. Overview of OpenOffice.org Writer
Writing documents using OpenOffice.org is similar to other word processing applications you may
have used before. To start OpenOffice.org Writer, you can either start it from the Applications
by selecting Applications => Office => OpenOffice.org Writer, or start it from a shell prompt by
entering oowriter.
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When OpenOffice.org Writer opens, you are presented with a blank document. The margins of the
document are represented by the gray box drawn on the main screen. You can start entering text
immediately.

Tip

You may notice as you type that OpenOffice.org Writer fills in the rest of a word you are typing.
OpenOffice.org Writer guesses the word you are typing based on longer words used earlier in
the document. This auto-complete text is highlighted. To accept the suggested word ending, press
the [Enter] key. If, however, this is not the word you wish to type, keep tying as normal. To turn off
this feature, go to Tools => Autocorrect / AutoFormat. This opens a dialog box. Click the Word
Completion tab and un-check the Enable Word Completion box.

To create a new file in OpenOffice.org Writer

1. Go to File => New => Text Document or click on the New document icon in the upper left.
(The small arrow in the upper right of the icon allows you to select the type of document to
create.)

2. Begin entering text.

To open an existing file:

1. Go to File => Open, click on the folder icon, or press [Ctrl]-[O].

2. A file browser window opens.

3. Use the navigation icons in the upper right or click through the folders in the window pane to
find the file you wish to open.

4. Either double-click on the file or click once to highlight it and then click on the Open button to
open the file.

To save a file:

1. Click on the floppy disk icon, go to File => Save, or go to File => Save As.

2. A window opens that shows your file system. If you have already saved this file before, you will
not have to do anything else.

3. Navigate to the location where you would like to save your file.

4. Enter a name for your file in the File name field.

5. Select the format for your file from the File type drop down menu.

6. Click on the Save button.

Note

To save a document in a format other than OpenOffice.org Writer’s native format (.sxw), you must
select the file type from the File type drop down list. If you also check the Automatic file name
extension box, OpenOffice.org Writer will automatically add the correct extension (such as .doc or
.txt) to the end of your file name. If you do not choose a file type from the drop down list, OpenOf-
fice.org Writer will save in it’s native format, even if you type in the extension you would like for your
file.
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To save your document as a .pdf file, go to File => Export as pdf. While OpenOffice.org Writer can
save as a .pdf, it cannot read or edit them. To view a .pdf file, see FIXME.

To print a document:

1. Click on the printer icon or go to File => Print or press [Ctrl]-[P]

2. A window opens with print configuration options.

3. Select the options you would like.

4. Click on the OK button.

To preview a file before printing:

1. Go to File => Page Preview.

2. A new window opens, displaying your file.

3. Examine your document: zoom in and out with the magnifying glass icons or scroll through the
pages with the page icons near the upper left.

4. You may print from this screen the same way as from the main screen.

5. When you are finished examining your document, click the Close Preview button to return to
the main screen.

To change text formatting:

1. Highlight the text you would like to format.

2. Either apply a style to the text with the Stylist (refer to FIXME) or

3. Choose formatting options from the toolbar, such as bold, alignment, line spacing, font color,
etc.

To add lists to your text:

1. Either highlight existing text you would like to make into a list or move your cursor to the blank
line where you would like to start the list.

2. Click either the Numbering icon or the Bullets icon.

3. For existing text, your list will automatically be created and formatted. For new text, enter each
list item and press [Enter].

4. To exit the list, press [Enter] twice.

To format a page:

1. Go to Format => Page.

2. A window opens with several tabs of page options. The Page tab allows you to change your
margins.

3. Select the formatting options you would like to change for your page.

4. Click on the OK button to apply the changes.

To undo changes:

1. Click on the Undo icon, go to Edit => Undo, or press [Ctrl]-[Z].

2. If you click on the blue arrow at the top right of the Undo icon, a list of the previous actions
apprears. Choosing one of these items undoes all actions back to that point.
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8.3. OpenOffice.org Calc

8.3.1. Overview of OpenOffice.org Calc
OpenOffice.org Calc functions similarly to other spreadsheet applications. It is useful for creating
forms as well as calculations.

To create a new spreadsheet:

1. Start OpenOffice.org Calc from the Applications menu bu going to Application => Office =>
OpenOffice.org Calc or enter oocalc at a shell prompt.

2. Enter text, numbers, or functions.

To open an existing spreadsheet:

1. With OpenOffice.org Calc open, go to File => Open, click on the Folder icon, or press [Ctrl]-
[O].

2. Navigate to the location of the spreadsheet.

3. Double-click on the spreadsheet name or click once to highlight it and then click the OK button.

To save a spreadsheet:

1. Click on the floppy disk icon, go to File => Save, or go to File => Save As.

2. A window opens that shows your file system. If you have already saved this file before, you
won’t have to do anything else.

3. Navigate to the lcoation you would like to save your file in.

4. Enter a name for your file in the File name field.

5. Select the format for your file from the File type drop down menu.

6. Click on the Save button.

To print a spreadsheet:

1. Click on the printer icon or go to File => Print or press [Ctrl]-[P].

2. A window opens with print configuration options.

3. Select the options you would like.

4. Click on the OK button.

To manually enter a function:

1. Select the cell where the function should be placed.

2. Enter the function: start with an "=" sign and enter the name of the function.

3. To use cells in the argument of the function (the part of the function that is operated on), enter
an open parenthesis, "(", and then highlight the cells with your mouse. You can also type in the
cell names after the open parenthesis.

4. Press [Enter] to enter the function and calculate the result.

To enter a function using the Function AutoPilot:

1. Select the cell where the function should go.

2. Go to Insert => Function or press [Ctrl]-[F2].
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3. The AutoPilot window opens.

4. Select the function you would like to use from the pane on the left. You select by double-clicking
on the name of the function.

5. In the right pane, information about the selected function is displayed. Fields for the data are
just below the function information. Lastly, a box displays the result of your calculation.

6. To select cells to use in your function, click on the Shrink icon next to the field these cells will
be entered.

7. Highlight the cells with your mouse. Press [Enter] to return to AutoPilot
8. When finished, click the OK button.

To use conditional formatting:

1. Go to Format => Conditional Formatting...
2. A window opens with formatting options.

3. Select whether the condition applies to a cell or a function in the far left.

4. Select the condition of the relationship in the next drop-down box.

5. In the next field, either enter a value or select cells.

6. In the Cell Style drop-down menu, select what the resulting style should be.

To change cell format:

1. Select the cells to outline by highlighting them with the mouse.

2. Go to Format => Cells and select the Borders tab, or click the Borders icon on the Object
Bar toolbar.

3. On the Borders tab, choose the color, position, weight, and line type of your borders. Click the
OK button to apply these borders.

4. The small blue arrow in the upper right of the Borders icon opens a drop-down menu. Double-
click the image that represents the borders to apply to your selection.

To create a chart:

1. Select the data to use for the chart by highlighting with the mouse.

2. Go to Insert => Chart.
3. The AutoFormat Chart window opens.

4. Select where you want your chart displayed and click Next >>.

5. Choose a chart type and click Next >>.

6. Choose a variant and click Next >>.

7. Enter titles for your chart and click Create.

8.4. OpenOffice.org Impress
OpenOffice.org Impress is a presentation application. It allows users to create what are commonly
referred to as slides — text and graphics used to illustrate key points in a presentation. Impress can
be used for print slides, or in conjunction with projectors to reach a large crowd. Impress has the
functions you have come to expect from other presentation applications.
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To start Impress, go to Applications => Office => OpenOffice.org Impress. When the application
first starts, the AutoPilot guides you through the initial set up of your slide show. Make your selections
and click Create. A blank slide opens and you can edit your presentation.

1. Download or create a new template for OpenOffice.org Impress.

2. Open the file in OpenOffice.org Impress.

3. Go to File => Templates => Save.

4. A window opens. Enter the name of the new template, and click the OK button.

To use a new Template:

1. Go to File => New => Templates and Documents.

2. A window opens with panes showing the template directories on the left and the templates inside
those directories on the right. Look inside the Default folder for templates that you have saved.

3. Press the OK button.

To Display your Presentation:

1. Go to Slide Show. Inside this menu are various options for customizing your presentation,
including the type of display, the transitions, and other effects. Browse through the various tools
available from the menu.

2. Once your transition and other selections have been made, either go to Slide Show => Slide
Show or press [F9].

3. To move through the slides of your presentation, click with the mouse or use the directional
keys on your keyboard.

8.5. OpenOffice.org Draw and Math

8.5.1. OpenOffice.Org Draw
OpenOffice.org includes a drawing program for the creation of vector graphics. It can be accessed
from inside other applications in the OpenOffice.org suite or as a separate application.

To open OpenOffice.org Draw from another application:

1. Go to File => Object => OLE Object.
2. When the Insert OLE Object window opens, select the Create new from file radio button,

highlight OpenOffice.org Draw, and click OK.

3. OpenOffice.org Draw opens as a frame inside your document.

4. Create your drawing using the tools along the left-most toolbar.

5. When finished, click on your document outside of the drawing frame. The drawing is finished
and inserted in your document.

To create a drawing with OpenOffice.org Draw:

1. Start the application by going to Applications => Office => OpenOffice.org Draw, entering
oodraw from a shell prompt, or inserting a drawing from another application as described
above.

2. Select a tool from the Main Toolbar by clicking on it once.
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3. Select a variant of the tool from the list by clicking on it once.

4. Move your mouse pointer to the blank page and use the drawing tool.

8.5.2. OpenOffice.org Math
OpenOffice.org Math is a useful tool for creating properly formatted functions to import for display
in any of the OpenOffice.org applications. Note that these functions cannot be imported to OpenOf-
fice.org Calc for evaluation.

To create a function:

1. Open OpenOffice.org Math by going to Applications => Office => OpenOffice.org Math,
entering oomath from a shell prompt, or inserting it as an OLE Object as described for
OpenOffice.org Draw.

2. Select a type of function from the top half of the Selection window.

3. Select one of the functions from the bottom half of the Selection window.

4. The bottom pane of the main window contains the code for your selection. The variables of the
function are represented by the symbols ?>.

5. Replace the boxes with variables by deleting the ?> symbols and replacing them with text.

6. Update the display screen by clicking inside it.

7. To nest selections, use parentheses. OpenOffice.org Draw uses the same order of operations as
algebra.



98 Chapter 8. Working with OpenOffice.org



Chapter 9.
Working with Other Text Applications

Text editors fall somewhere between word processors like OpenOffice.org Writer and pager appli-
cations like less. These programs are useful for tasks like writing HTML, C, or SGML; they are best
suited for any task that is text-oriented, and is not necessarily intended for print.

Programs that allow you to view PDF and PS files are referred to as text viewers. They do not allow a
user to edit the text directly, but do allow the user to view the pre-formatted text.

9.1. Working with Text Editors
Red Hat Enterprise Linux comes with several applications that can be used to write and edit program
code. These programs are text editors, programs that provide the user with helpful highlighting and
formatting options without making changes or additions to the text. The most common of these text
editors are vi and Emacs. Two additional useful editors are gedit and kate.

9.1.1. vi
vi is a shell prompt text editor. This means that like less, opening an instance of vi does not open
a GUI window. Instead, the contents of the file being edited appear in the current terminal window.
Because vi works without a GUI, it can be used to edit text files even when X is not working.

vi operates via keystrokes — listed below is a small set of the keystrokes necessary to work with text
in vi.

Key Action

[i] With a file open, press [i] to enter Insert mode. This mode allows you to
move the cursor and to delete and add text anywhere in the file.

[Esc] Pressing the [Esc] key at any time takes you out of Insert mode and into
Normal mode.

[w] [w] writes your changes to the file. Enter Normal mode, press [Shift]-[:],
[w], and finally press [Enter].

[q] [q] quits vi. Enter Normal mode, press [Shift]-[:], [q], and finally press
[Enter]. To save your changes before exiting, enter :wq. To quit without
saving your changes, enter :q!.

[!] [!] forces vi to execute the commands that precede it.

Table 9-1. Useful keys in vi

vi uses many more keystrokes. To learn more about vi, view the manual page by entering man vi
at a shell prompt. You can also access the vim tutorial but entering vimtutor command at a shell
prompt.

9.1.2. Emacs
Emacs is a text editor that includes a GUI component. Like vi, Emacs also makes use of keyboard
shortcuts to manipulate text. Users can choose between working with the mouse or the keyboard; all
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commands are available via either method.

Emacs can be customized extensively. Programs that customize syntax highlighting or add other
functionality can be written and installed. Emacs even contains several games available from the
Tools => Games menu, and a "psychiatrist" availabel from the Help menu.

An Emacs tutorial is available by selecting Help => Emacs Tutorial from the main toolbar.

9.1.3. gedit
gedit is the GNOME text editor. It has highlight modes for HTML, Perl, C, PHP, and many other
languages. gedit features print preview, the ability to undo your changes, and tabbed editing. gedit is
fully integrated with Nautilus.

9.1.4. kate
kate is the KDE text editor. It also has highlight modes for multiple programming languages. kate
uses split screens to display multiple files. kate also has the ability to open a terminal window within
the application. kate is fully integrated wtih Konqueror.

9.2. Viewing PDF and PS files
Red Hat Enterprise Linux provides applications that allow you to view both PDF and PS files. To view
PDF files, use the gpdf application. For PS files, use ggv.

Both gpdf and ggv are integrated into Nautilus. Double-clicking on a PDF or PS file while in Nautilus
opens the file in the large pane of the Nautilus window. You can then scroll through and even print
the files.

Both applications can be reached from a shell prompt by entering the name of the application followed
by the path to the file.

gpdf /home/user/PDF/foo.pdf

The above command opens the file foo.pdf, located in user’s PDF/ directory, with the gpdf appli-
cation.

ggv /home/user/PS/bar.ps

The above command opens the file bar.ps, located in user’s PS/ directory, with the ggv application.



Chapter 10.
Audio, Video, and Games

This chapter presents you with the lighter side of Red Hat Enterprise Linux. From games and toys to
multimedia applications, Red Hat Enterprise Linux provides many packages to assist you in having
some fun with your computer.

10.1. Playing Audio CDs
To play an audio CD, place it in your CD-ROM drive. The CD Player application should appear au-
tomatically and begin playing the first audio track. If the interface does not appear, click Applications
(the main menu on the panel) => Sound & Video => CD Player to launch the CD Player application.

Figure 10-1. CD Player Interface

The CD Player interface acts similar to a standard CD player, with play, pause, and stop functions.
There is even a sliding bar that allows you to adjust the volume. Press the Next track and Previous
Track buttons to skip forward or backward one track; you can also use the Track List drop down
menu to select a track from the available listing.

You can edit the track listings for your CDs by clicking the Open track editor button. You can also
change the way the application functions by clicking on the Open Preferences button. Here you can
set themes for the player as well as set the behavior of the CD-ROM drive when you open or quit the
CD Player application.

Figure 10-2. CD Player Preferences
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10.2. Playing Digital Audio Files
Digital audio has become very popular in recent years. Users enjoy the technology because the sound
quality is excellent compared to analog tape or records, and the files are compact (audio files can
easily be transferred across the Internet).

To take advantage of this technology, Red Hat Enterprise Linux includes the powerful X Multimedia
System (XMMS), a cross-platform multimedia player which allows you to play several digital audio
file formats.

Figure 10-3. XMMS Interface

XMMS can be used for more than just playing digital audio files. By default XMMS can play Ogg
Vorbis, RIFF wave, and most module formats. Additionally, XMMS can be extended via plugins to
play a number of other digital multimedia formats.

To launch XMMS, go to Main Menu => Sound & Video => Audio Player.

To launch XMMS from a shell prompt, type the command xmms.

10.2.1. Using XMMS

To play an audio file with XMMS, click the Open button and choose a file from the Load File(s)
window.

Figure 10-4. The Load File(s) Window
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In Figure 10-4, you see that there are several files to choose from. The files that end in .ogg are Ogg
Vorbis files, a popular new audio file format, while the .pls file is an audio playlist file. You can use
XMMS to add audio files into a list and then save it as a playlist. This can be convenient if you have
several audio files and you want to categorize them (for example, by genre or artist). Highlight the file
you wish to play (if you have multiple files, click and hold the mouse button and drag it over all of the
files you want to open) and click OK. Notice that XMMS begins to play your audio files immediately.
To adjust the volume click and drag the volume slider (the long slider above the Open button) to the
left to lower the volume or to the right to increase it, like you would when using a CD player. There
are also buttons to stop, pause, and skip (backward and forward) your audio files.

To learn more about using XMMS and its many options, refer to the man page by entering man xmms
at a shell prompt.

10.3. Troubleshooting Your Sound Card
If, for some reason, you do not hear sound and know that you do have a sound card installed, you can
run the Sound Card Configuration Tool utility.

To use the Sound Card Configuration Tool, choose Applications => System Settings => Sound-
card Detection. A window opens, prompting you for your root password.

Note

Most sound cards are supported by Red Hat Enterprise Linux, but there are some sound cards that
are not completely compatible or may not work at all. If you are having trouble configuring your sound
card, check the Hardware Compatibility List at http://hardware.redhat.com/hcl/ to see if your card is
supported.

The Sound Card Configuration Tool utility probes your system for sound cards. If the utility detects
a plug and play sound card, it automatically tries to configure the correct settings for your card. You
can then click the Play test sound button to play a sound sample. If you can hear the sample, select
OK and your sound card configuration is complete.

Tip

It is possible that your sound has been muted. To check this, click on the Volume Control icon on the
top Panel. Check the Volume Control application available from the Applications (the main menu
on the panel) => Sound & Video => Volume Control. If any of the mute boxes have been checked,
un-check them and try the Sound Card Configuration Tool again.
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Figure 10-5. Sound Card Configuration Tool

10.3.1. If Sound Card Configuration Tool Does Not Work
If the Sound Card Configuration Tool does not work (if the sample does not play and you still do
not have audio sounds), there are alternatives, although they are not quite as simple as running the
Sound Card Configuration Tool. You can edit your modules.conf file as discussed in the next
section (this strategy is not recommended for most new users) or refer to the documentation that came
with your sound card for more information.

10.3.1.1. Manual Sound Card Configuration
If your sound card is not a plug and play card, you can manually edit your /etc/modules.conf file
to include the sound card module that it should use. You must have root privileges to alter this file.
The following is an example of the text to add to your /etc/modules.conf file:

alias sound sb
alias midi opl3
options opl3 io=0x388
options sb io=0x220 irq=7 dma=0,1 mpu_io=0x300

For information on configuring sound manually, refer to the Linux Sound HOWTO at the Linux Doc-
umentation Project webpage:

http://www.tldp.org/HOWTO/Sound-HOWTO/

10.4. Troubleshooting Your Video Card
Video card configuration is handled during the Red Hat Enterprise Linux installation (refer to the Red
Hat Linux Installation Guide for more information). However, if you did not choose to configure a
video card at that time, or if you need to reconfigure your settings, you can use the X Configuration
Tool utility. Use this utility if you install a new video card.

Note

The X Configuration Tool backs up your system’s original video configuration file to
/etc/X11/XF86Config.backup in case you need it to switch back to a previous configuration.



Chapter 10. Audio, Video, and Games 105

To run the X Configuration Tool, click Applications => System Settings => Display. A pop-up
window prompts you for your root password. You can also start from a shell prompt by typing the
command system-config-xfree86, which then prompts you to enter your root password. If you
are working from a shell prompt and X is not working, system-config-xfree86 attempts to start
a minimal X session to allow you to continue your configuration.

Note

If you have recently entered your root password for a different application, you may not be prompted
to enter it again.

Figure 10-6. X Configuration Tool

To configure your monitor manually, click the Hardware tab, then click the Configure... button next
to the Monitor Type entry. A pop-up window displays a list of monitor models. Choose your model
and click OK. You can also let the X Configuration Tool probe your monitor for the correct model
and vertical/horizontal frequency settings.

To configure your video card manually, click the Hardware tab, then click the Configure... button
next to the Video Card entry. A pop-up window displays a list of video card models. Choose your
model and click OK. You can also let the X Configuration Tool probe your video card for the correct
model and settings by clicking the Probe Videocard button.

When you have finished reconfiguring your video card and monitor, you should be able to start an X
session and enjoy your graphical desktop environment.

10.5. Games
Playing games under Red Hat Enterprise Linux is a fun way to pass the time.

Game availablity depends on the variant of Red Hat Enterprise Linux you installed. You must have
those game packages installed before they appear under the Applications => Games menu. Refer
to the Red Hat Enterprise Linux System Administration Guide for details on installing additional
packages.
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To start a game, click Applications => Games and select the game of your choice. Figure 10-7 shows
a fun game for kids of all ages called Same GNOME. In this game you point your mouse at matching
marbles until they start to spin; then, you can click them to make them disappear. The object of the
game is to make all the marbles disappear.

Figure 10-7. Same GNOME — Match the Marbles Game

10.6. Finding Games Online
There are many games available within Red Hat Enterprise Linux and online. For more information,
here are a few suggestions:

• http://www.tuxgames.com/ — A store where you can buy games just for Linux.

• http://www.linuxgames.com/ — T Linux gaming news site.

• http://happypenguin.org/ — The Linux gaming repository.

You can also browse the Internet for linux games using a search engine, such as
http://www.google.com/.
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Working with Digital Cameras

Digital cameras have recently grown in popularity because of their increasing image quality and easy
interaction with desktop PCs. Digital cameras create high-quality images that you can to others over
the Internet or print on a color printer. Red Hat Enterprise Linux supports several brands of digital
cameras and has applications that help you access, view, and modify your digital photographs.

11.1. Nautilus and Digital Cameras
Nautilus has the built-in ability to work with USB devices. If your digital camera connects via a USB
connection, Red Hat Enterprise Linux may not require special software or configuration to access the
images stored on your camera.

To use Nautilus to access your camera:

1. Plug the USB cable into your camera and to your computer.

2. Turn your camera on and put it in the settings recommended by your manufacturer for connect-
ing to a computer.

3. If Nautilus recognizes your camera, a new icon appears on the Desktop. This icon will be named
Type of memory card Removable Media.

4. You can browse through this folder as with any other directory; double-click on the icon to open
the folder.

5. Your images may exist a few directories down, inside the initial directory. Recall that Nautilus
displays images as thumbnails, so your pictures are easy to recognize.

6. To save the images to your computer, copy and paste the thumbnails to your preferred directory.

7. When you are finished, right-click on the icon and select Unmount Volume before disconnect-
ing your camera.

11.2. Using gThumb
Red Hat Enterprise Linux supports over 100 digital camera models. So, whether your camera uses
a USB or serial port to communicate with your computer, it is likely that Red Hat Enterprise Linux
supports it.

gThumb is a graphical application that allows you to interface with your digital camera. gThumb
works directly with your digital camera, allowing you to open, view, save, and delete images directly.
You can also download the images to your computer and modify them with image manipulation
programs such as The GIMP (refer to Chapter 12 Working with Images for more information about
image manipulation tools).

To start gThumb, choose Applications (the main menu on the panel) => Graphics => Photo Tool.
You can also start gThumb by typing gthumb at a shell prompt.

Before you begin using gThumb, configure it to work with your digital camera. From the File menu,
select Import Photos.... The Import Photos window opens. On the left is an icon of a camera. If
you have not configured gThumb before, the icon has a red slash through it and the label No camera
detected. Click on the icon to open the Camera Model window. This window was two drop-down
menus: the first allows you to select your camera model from an extensive list, and the second allows
you to select the type of port your camera uses to connect to your computer. Make your selections and
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click the OK button. At the Import Photos screen, select the destination of your photos and click the
Import button.

FIXME - Image of Import Screen

FIXME - Image of Camera Model Screen

Figure 11-1. Adding a Camera in gThumb

Imported photos are listed in the right pane of the main screen. To view an individual image, double-
click on its thumbnail. To return to viewing all images, click on the Folders icon at the top left of the
screen.

gThumb can also categorize your photos. Double-click on a thumbnail to open the image in gTh-
umb’s main screen. Select the Categories icon from the toolbar. Scroll through the list of categories
and click on the ones to associate with your image. You can create and deleted categories by clicking
on the New and Delete icons. When you are finished, click the OK button.

gThumb has many more features. Refer to the Help Contents or view the documentation at
http://gthumb.sourceforge.net for additional information.
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Working with Images

Digital images are ubiquitous — they are available on the Internet, through email, and even on CD
from film developers. These images are files, and can be manipulated with software available on your
Red Hat Enterprise Linux system. Red Hat Enterprise Linux allows you to save, view, edit, and create
image files.

12.1. Saving Images
Images that are not copyrighted can be saved directly from many web pages. Right click on an image
and select either Save Image or Save Image As, depending on the browser you use to view the web
pages. Some web sites have disabled this function because their images are copyrighted.

Images in email messages may also be saved on your system. These images arrive as attachments to
the email message. An attachment is any extra file that is sent together with an email. Depending on
the type of attachment and the email program you use, the attachment may be displayed as part of the
message. Check the Help contents of the email program you use to determine how to save attachments
to your computer.

Images you receive on a CD or other removable media device can be copied and pasted from that
medium to a new location on your system. Refer to Chapter 13 Diskettes and CD-ROMs for more
information on removable media and Nautilus.

12.2. Viewing Images
This section discusses some of the common tools for viewing image files. Red Hat Enterprise Linux
contains light, fast applications that display images as well as full-featured applications that display
and edit images.

12.2.1. Nautilus
As discussed in Section 2.1 Using Nautilus, Nautilus displays image files as thumbnails. To view a
larger display of the image, double-click on the thumbnail. Nautilus opens the file in the default image
viewing application, Eyes of GNOME.

12.2.2. gThumb
gThumb is a powerful image viewer for graphical desktop users that supports several image file
formats.

gThumb is useful for viewing individual image files as well as browsing collections of files in folders.
It supports zoom in and zoom out functions, as well as thumbnails of all image files within a directory.
It also supports several advanced options not found in Nautilus.

gThumb can be started from your desktop panel by selecting Applications => Graphics => Photo
Tool. Start the application from a shell prompt by entering the command gthumb. gThumb will
browse your user home directory by default. If you have any images in this directory, the gallery panel
will automatically generate thumbnails in the main display area.
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Figure 12-1. gThumb Displaying a Folder of Images

The gThumb interface has a text field for you to enter a particular path to your image directories.
Right-clicking on an image in the display area opens a pop-up menu of file management options such
as renaming, moving, copying, and converting an image from one file format to another. You can also
set an image as your desktop wallpaper within the pop-up menu.

You can combine functions within gThumb and create a dynamic presentation effect for groups of
images within a directory. In the text field below the toolbar, type the path to the directory where
your images are located and highlight the first image in the main gallery panel. Clicking the Slide
Show button on the toolbar starts a full-screen slide show. By default, each image in the slide show
is presented for 4 seconds. You can stop the slide show at any time by pressing [Esc] or by moving
your mouse cursor and clicking the Restore Normal View pop-up button that appears on the top left
corner of the screen.

12.2.3. GIMP
To start the GIMP, select Applications => Graphics => The GIMP. The first time the application
starts, you must go through an installation process. Select Continue to accept the default options of
the installation. Once the GIMP has installed, use it to display your image file by selecting File =>
Open and navigating to the file on your system. Double-click on the file to display it.

12.3. Editing and Creating Images with the GIMP
The GNU Image Manipulation Program (GIMP) is a powerful application that can alter, manipulate,
enhance, and create digital image files. FIXME discusses how to start the application. The following
sections discuss the main features of the application.

12.3.1. Saving an Image
To save an image file, right-click on the image, choose File, and select either Save or Save As. The
Save Image window opens. Navigate to the directory where you would like to save your file. Enter a
name for your file in the field at the bottom of the window.

You must choose a file type for your image. By default, the GIMP will save your file according to the
extension you type at the end of your file name. You may also select the file type from the Determine
File Type drop-down menu above the file name field. When you are ready to save, click the OK
button.
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Depending on the file type you selected, another window with options may open. Ingeneral, it is a
good idea to accept the settings that the GIMP suggests. Click the OK button again to complete the
save process.

12.3.2. Editing an Image
To crop an image:

1. Open the image.

2. Right click on the image and select Tools => Transform Tools => Crop and Resize.

3. Left-click and drag the mouse pointer to create a frame that fits the part of the image to keep.

4. Click the Crop button in the window that opens as you drag the frame across the image.

5. If you are unhappy with the cropped image, press [Ctrl]-[Z].

To Rotate an Image:

1. Open the image.

2. Right-click on the image and select Image => Transform, then select any of the Flip or Rotate
options.

3. If you are unhappy with the changes, press [Ctrl]-[Z].

To Add Text to an Image:

1. Open the image.

2. Right-click on the image and select Tools => Paint Tools => Text.
3. Left-click where the text should begin.

4. Type the text into the GIMP Text Editor window.

5. Click the OK button.

6. Your text appears on the image.

7. If you are unhappy with the changes, press [Ctrl]-[Z].

To apply a filter:

1. Open the file.

2. Right-click on the image and select Filters.

3. Choose any of the filters available.

4. Choose options for the filter.

5. Click the OK button.

6. If you are unhappy with the changes, press [Ctrl]-[Z].

To create a new image:

1. Choose File => New.

2. Ener the image size, image type, and fill type of the file.

3. Click the OK button.

4. Edit and manipulate the image with the GIMP’s various tools.
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5. Save your file.

While this chapter covers image applications briefly, there is much more detailed information avail-
able. Refer to the following resources if you are interested in learning more about the applications in
this chapter.

The GIMP has a help browser accessible by choosing Help => Help... from the GIMP toolbar menu.
This is an excellent place to begin searching for answers. However, if the Help menu does not provide
enough information, try the following resources:

12.3.2.1. Useful Websites
The Web has several sites of interest if you are looking for more detailed information about an appli-
cation covered in this chapter:

• http://www.gimp.org/ — The official GIMP website.

• http://www.rru.com/~meo/gimp/faq-user.html — A GIMP Frequently Asked Questions (FAQ) list
by GIMP users (as opposed to developers).

• http://gimp-savvy.com/ — The companion website to the book Grokking the GIMP, by Carey
Bunks. The entire book is also available on the site for download

• http://tigert.gimp.org/gimp/ — The GIMP website of tigert (Tuomas Kuosmanen).

12.3.2.2. Related Books
If you need in-depth information about the many capabilities of the GIMP, try your favorite bookstore.
The following books were available at the time of this writing:

• The Artists’ Guide to the GIMP by Michael J. Hammel; Frank Kasper and Associates, Inc.

• GIMP Essential Reference by Alex Harford; New Riders Publishing

• GIMP for Linux Bible by Stephanie Cottrell Bryant, et al; Hungry Minds, Inc.

• GIMP: The Official Handbook by Karin Kylander and Olof S. Kylander; Coriolis Group

• Grokking the GIMP by Carey Bunks; New Riders Publishing

• Sams Teach Yourself GIMP in 24 Hours by Joshua and Ramona Pruitt; Sams

• GIMP Pocket Reference by Sven Neumann; O’Reilly and Associates
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Diskettes and CD-ROMs

Using removable media with Red Hat Enterprise Linux requires some explanation. This chapter dis-
cusses how to read and write files to and from diskettes, CD-ROMs, and USB Flash Drives.

13.1. Using Diskettes
Diskettes are one of the oldest removable media solutions available for the personal computer (PC).
Diskettes are ideal as a portable storage solution for small files that need to be physically moved
around. For example, if two PCs are not on the same network, diskettes are a great solution to transfer
files from one computer to the other. Diskettes degrade with time, and should not be used for long
term storage.

13.1.1. Mounting and Unmounting a Diskette
Diskettes must be mounted before use and unmounted before they are ejected from the drive. To
mount a diskette means to attach it to your current file system. Strictly speaking, Red Hat Enter-
prise Linux attaches the contents of the diskette to your computer’s file system under the directory
/media/floppy/. Diskettes may be mounted manually from a shell prompt. Nautilus also has the
ability to auto-mount diskettes.

To manually mount a diskette:

1. Insert the diskette in the diskette drive.

2. At a shell prompt, enter the command mount /media/floppy/.

3. The diskette drive activity light should blink as it is mounted to /media/floppy/.

4. You can access the contents of the diskette by browsing to that directory from a shell prompt or
through a file browser like Nautilus.

To mount a diskette with Nautilus:

1. Inser the diskette into the drive.

2. Double-click on the Computer icon on your desktop.The Computer window opens.

3. Double-click the Floppy icon. Nautilus automatically mounts the diskette and opens a window
with the diskette’s contents.

4. At the same time, a diskette icon appears on the desktop. Double-click this icon at any time
to open a window with the diskette’s contents. Files dragged onto the icon are copied to the
diskette.

To unmount a disk manually:

1. Open a terminal window.

2. At the shell prompt, enter the command umount /media/floppy/.

To unmount a diskette with Nautilus:

1. Right-click on the diskette icon on the desktop.
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2. Select Unmount Volume from the menu.

Once the diskette has been unmounted, you can safely eject it from the drive.

Note

If you do not unmount a diskette before ejecting it, the files you meant to transfer to it will not actually
be written on the diskette. You may also be unable to mount a new diskette, or the old data may be
written over the new diskette. Be certain to unmount your diskettes before removing them.

13.1.2. Putting Linux Files on an MS-DOS Diskette
To copy files from a Red Hat Enterprise Linux system to an MS-DOS formatted diskette so that
a Windows machine can read it, be certain that the diskette is formatted with an MS-DOS (FAT)
file system. Diskettes that are pre-formatted by the manufacturer are generally formatted with a
FAT file system. You can also format the diskette with the Windows OS or with gfloppy. Refer to
Section 13.1.3 Formatting a Diskette for more detail on formatting.

Files may be copied to and deleted from the diskette with the same shell prompt commands or actions
in Nautilus as described in Section 4.5 Manipulating Files in Your Current Working Directory. You
can then unmount the diskette and eject it from the drive. The files on the diskette should now be
accessible from the Windows machine.

13.1.3. Formatting a Diskette
The native file system for exclusively Red Hat Enterprise Linux diskettes is ext2. Once you have
created an ext2 file system on your diskette, you can manipulate its contents the same ways that you
manipulate directories and files on your hard drive.

Warning

Formatting a diskette will permanently erase all of its contents. Be sure to backup any files that you
need before performing any of the following operations on your diskettes.

13.1.3.1. Formatting with gfloppy
To start gfloppy, choose Applications => System Tools => Floppy Formatter. From a shell prompt,
type /usr/bin/gfloppy. gfloppy will not format a diskette that is mounted to your file system.
Make certain that the diskette icon is not visible on your desktop before proceeding. If the diskette is
mounted, right-click on the icon and choose Unmount Volume before proceeding.

As shown in Figure 13-1, the gfloppy interface is small and has few options. The default settings
are sufficient for most users and needs; however, you can format your diskette with an MS-DOS file
system type if necessary. You can also choose the density of your diskette (if you are not using the
usual high density 3.5" 1.44MB diskette). You can also elect to quick format the diskette if it was
previously formatted as ext2.
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Figure 13-1. gfloppy

Change the settings in gfloppy to suit your needs; then click Format. A status box appears on top of
the main window, showing you the status of formatting and verification. Once complete, close gfloppy
and either eject or mount and use the diskette.

13.1.3.2. Using mke2fs

The mke2fs command is used to create a Linux ext2 file system on a device such as a hard drive
partition or (in this case) a diskette. mke2fs essentially formats the device and creates an empty,
Linux-compatible device which can then be used for storing files and data.

Insert your diskette into the drive and issue the following command at a shell prompt:

/sbin/mke2fs /dev/fd0

On Linux systems, /dev/fd0 refers to the first diskette drive. If your computer has more than one
diskette drive, your primary diskette drive is /dev/fd0, your second /dev/fd1, and so on.

The mke2fs utility has a number of options. The -c option makes the mke2fs command check the
device for bad blocks before creating the file system. The other options are covered in the mke2fs
man page.

Once you have created an ext2 file system on the diskette, it is ready to be used with your Red Hat
Enterprise Linux system.

13.2. CD- and DVD-ROMs
The CD-ROM format is a popular medium for software, music, and data file. As the costs involved
plummet, DVD-ROMs are also becoming more popular. THis section discusses how to use CDs and
DVDs with your Red Hat Enterprise Linux system.

13.2.1. Using CD-ROMs with Your File Manager
Nautilus automatically mounts both Compact Discs (CDs) and Digital Versatile Discs (DVDs) by
default. Nautilus will then do one of the following, depending on the typ of CD or DVD: for audio
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CDs, Nautilus starts CD Player; for data CDs and DVDs, Nautilus opens a file browser window that
displays the contents of the disk.

Figure 13-2. Contents of a CD-ROM in Nautilus

When Nautilus auto-mounts a CD or DVD, it places an icon on the desktop that matches the type of
media inserted. Double-clicking the icon preforms the default action for that medium: for example,
double-clicking the Audio CD starts the CD Player application.

You can also access the CD or DVD by double-clicking on the Computer icon on your desktop, then
double-clicking on the appropriate icon inside the Computer window.

This icon can also be used to unmount and eject your CD or DVD. Right-click on the icon and select
Eject to remove the disk from your system.

Tip

Nautilus will not let you browse an audio CD. To copy files from an audio CD to your computer, use
Sound Juicer.

Tip

If any applications, file browsers, or terminal windows have the CD or DVD open, or any of its files,
Nautilus will not eject the media. Close all such files and terminal windows before proceeding.

13.2.2. CDs and DVDs From the Shell Prompt
If the CD or DVD is not currently mounted, you can mount it manually.

1. Insert a CD or DVD into the appropriate drive.

2. Open a terminal window.

3. At the shell prompt, enter the command mount /media/cdrom/.

The CD or DVD is now mounted and available for use. You can unmount and eject the CD or DVD
by entering the command umount /media/cdrom/. You can then safely press the eject button on
your CD or DVD drive to retrieve the disk.
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13.3. CD/DVD-Rs and CD/DVD-RWs
CD-writable (CD-R) media are an inexpensive way to back up as much as 760MB of data, includ-
ing applications, personal files, and multimedia files. CD-rewritable (CD-RW) media are also very
common, and allow the user to write files to the media multiple times.

Recently, the DVD equivalents of these media have become more common and more affordable. They
behave similarly to CDs, but can store up to 4.7GB of information. DVDs, in general, cannot be read
by CD-ROM drives, though most DVD-ROM drives can read CDs. Refer to the manufacturer of your
drive for more information regarding compatible formats.

Below, we discuss tools for both CDs and DVDs.

13.3.1. Using CD/DVD Creator
Nautilus has an integrated tool, CD/DVD Creator, that allows you to write to CDs and DVDs.

CD/DVD Creator allows you to drag and drop files from a Nautilus window to the CD/DVD Creator
interface. To access the CD/DVD Creator feature in Nautilus, insert a blank CD-R(W) into your drive
and the CD/DVD Creator window automatically starts. You can also open CD/DVD Creator from a
Nautilus window by selecting Go => CD Creator.

Figure 13-3. The CD/DVD Creator Interface in Nautilus

Open a new Nautilus window and select the files or directories you want to write to CD or DVD, then
drag the files and folders to the CD/DVD Creator window.

When you are ready to write the files to your CD or DVD, click the Write to CD button in the
CD/DVD Creator window. The Write to Disk window opens. Select the write speed, name the CD
or DVD, and click the Write button when finished.
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Figure 13-4. The CD/DVD Creator Write Dialog Box

By default, the CD or DVD should automatically eject from your drive when it is finished. Since it is
generally recommended to periodically backup personal files, CD/DVD Creator can help you do so
quickly.

13.3.2. Using CD-Rs and CD-RWs with Command Line Tools
There are two shell prompt applications used to write image to CDs and DVDs: mkisofs and
cdrecord. These utilities have several advanced options that are beyond the scope of this guide;
however, for basic image creation and writing, these tools save some time over the graphical
alternatives such as CD/DVD Creator.

13.3.2.1. Using mkisofs

The mkisofs utility creates ISO9660 image files that can be written to a CD or DVD. The images
created by mkisofs can include all types of files. It is most useful for archival and file backup pur-
poses. For CDs, make sure that the total data to be written is less than 760MB. For DVDs, make sure
that it is less than 4.7GB of data.

Suppose you wish to backup a directory called /home/user/, but exclude the subdirectory
/home/user/junk/ because it contains unnecessary files. You want to create an ISO image called
backup.iso and write it to CD or DVD. Backing up your data as an ISO9660 image is useful in
that it can be read by both Red Hat Enterprise Linux and Windows systems. This can be done with
mkisofs by running the following command:

mkisofs -o backup.iso -x /home/joeuser/junk/ -J -R -A -V -v /home/joeuser/

The image is created in your current working directory. Table 13-1 explains each command
line option. For more information on using mkisofs, refer to the additional resources in
Section 13.4 Additional Resources.

You can now use the ISO image file with cdrecord, the command line based CD recording utility.
For more information about using cdrecord, refer to Section 13.3.2.2 Using cdrecord.

Option Function

-o Specifies an output file name of the ISO image.

-J Generates Joliet naming records; useful if the CD is used in
Windows environments.

-R Generates Rock Ridge (RR) naming records to preserve filename
length and casing, especially for UNIX/Linux environments.
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Option Function

-A Sets an Application ID — a text string that will be written into
the volume header of the image which can be useful to determine
what applications are on the CD.

-V Sets a Volume ID — a name that is assigned to it if the image is
burned, and the disc is mounted in Solaris and Windows
environments.

-v Sets verbose execution, which is useful for viewing the status of
the image as it is being made.

-x Excludes any directory immediately following this option; this
option can be repeated (for example, ... -x /home/joe/trash -x
/home/joe/delete ...).

Table 13-1. mkisofs Options

13.3.2.2. Using cdrecord

The cdrecord utility writes audio, data, and mixed-mode (a combination of audio, video, and/or
data) CDs and DVDs using options to configure several aspects of the write process, including speed,
device, and data settings.

To use cdrecord, you must first establish the device address of your CD or DVD device by running
the following command as root at a shell prompt:

cdrecord -scanbus

This command shows all CD and DVD devices on your computer. It is important to remember the
device address of the device used to write your CD. The following is an example output from running
cdrecord -scanbus.

Cdrecord 1.8 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jorg Schilling
Using libscg version ’schily-0.1’
scsibus0:

0,0,0 0) *
0,1,0 1) *
0,2,0 2) *
0,3,0 3)’HP ’ ’CD-Writer+ 9200 ’ ’1.0c’ Removable CD-ROM
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

To write the backup file image created with mkisofs in the previous section, switch to the root user
and type the following at a shell prompt:

cdrecord -v -eject speed=4 dev=0,3,0 backup.iso

The command sets the write speed (4), the device address (0,3,0), and sets write output (verbose [-v]),
which is useful for tracking the status of the write process. The -eject argument ejects the media
after the write process is complete. The same command can also be used for burning ISO image files
downloaded from the Internet, such as Red Hat Enterprise Linux ISO images.

You can use cdrecord to blank CD-RW or DVD-RW discs for reuse by typing the following:

cdrecord --dev=0,3,0 --blank=fast
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13.4. Additional Resources
This section briefly covers several applications. Refer to the following resources for more information
about the applications in this chapter.

13.4.1. Installed Documentation

• cdrecordman page — Discusses how to burn data, audio and mixed-mode CDs and DVDs. Offers
all options and commands in detail, including some example commands for common CD and DVD
burning tasks.

• /usr/share/doc/cdrecord-<version> (where <version> is the version of cdrecord
installed on your system) — Several documentation files are included with general usage and li-
censing information.

• mkisofs man page — Comprehensive detail of the utility, including some warnings about creating
certain types of ISO images. Offers all options and commands in detail, including some example
commands for creating common ISO image files.

• /usr/share/doc/mkisofs-<version> (where <version> is the version of mkisofs in-
stalled on your system) — Several documentation files are included with general usage and licens-
ing information.

• /usr/share/doc/dvdrecord-<version>/ (where <version> is the version of
dvdrecord installed on your system) — For users who have DVD-R(+W) devices, this set of
documentation helps you get started mastering DVD-ROMs for data backup and multimedia
presentation.

13.4.2. Useful Websites

• http://freshmeat.net/projects/cdrecord/ — The cdrecord project page on Freshmeat is regularly
updated with the newest releases, news, and user commentary.

13.5. USB Flash Drives
A recent development in removable media is the USB Flash Drive. This is a small, solid-state memory
device, normally no larger than a pen.They can be carried conveniently on a key ring, and are some-
times referred to as ’USB Keys’ as a result. These small drives can contain files, directories, and even
software. Red Hat Enterprise Linux has the ability to use these drives through the auto-mount features
of Nautilus.

Like diskettes, USB drives are useful for carrying files between machines not on the same network,
or between computers that use different operating sytems. Linux can read files from a USB drive
formatted to work in Windows. However, if you encrypt the files or filesystem on your USB drive,
Linux may not be able to read those files.

13.5.1. Mounting your USB drive
When you plug the drive into a USB port o your Red Hat Enterprise Linux system, several things hap-
pen. Nautilus recognizes the drive and auto-mounts it to the directory /media/<manufacturer>/,
where <manufacturer> is the name of the maker of your drive. Nautilus also creates an incon
of the same name on your desktop. Finally, Nautilus adds a similar icon to the Computer window.
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To mount your USB drive manually:

1. Open a terminal window.

2. Enter the command mount /media/<manufacturer>/.

To mount your USB drive with Nautilus

1. Open the Computer window from the desktop.

2. Double-click the USB key icon, or right-click on the icon and select Mount Volume.

13.5.2. Accessing the USB drive
You can access your USB drive from the desktop or from a shell prompt. From the desktop, you can
either double-click the icon or you can first open the Computer window, then double-click the USB
drive icon. From a shell prompt, enter the command cd /media/<manufacturer>, making
sure to replace <manufacturer> with the drive’s manufacturer.

13.5.3. Unmounting the USB drive
You must unmount your USB drive before removing it from your system, or problems similar to those
that can affect diskettes may aflict your USB drive.

To unmount your USB drive manually:

1. Open a terminal window.

2. Enter the command umount /media/<manufacturer> at the shell prompt.

To unmount your USB drive with Nautilus

1. Locate the USB drive icon on your desktop or inside the Computer window.

2. Right-click on the icon and select Unmount Volume.

Once the USB drive has been unmounted, you may safely remove it from your USB port.

Tip

The icon for the USB drive will remain visible from the Computer window as long as the drive is
plugged in to the port. It will remain visible even if the drive is not mounted. If you think your drive
should have files on it but cannot see them, verify that the drive is mounted.
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III. Troubleshooting Your System

If you ever run into problems using your Red Hat Enterprise Linux system, there are steps you can
take and tools you can use to recover from issues that get you back to using your system normally.
From booting into rescue mode to changing a forgotten password, this part can show you how to
troubleshoot several common issues that you may run into in the course of using Red Hat Enterprise
Linux.
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Chapter 14.
Frequently Asked Questions

This chapter answers some of the most common questions about using Red Hat Enterprise Linux
that you may ask as you become more familiar with it. From recovering forgotten passwords to trou-
bleshooting package installation problems, this chapter guides you step-by-step through some com-
mon tasks to get you on your way.

14.1. Localhost Login and Password
I have installed Red Hat Enterprise Linux. After rebooting, I get a message telling me it needs a
localhost login and password. What are these?

Unless you specified a hostname for your computer, or received that information from a network con-
nection, your Red Hat Enterprise Linux installation names your machine localhost.localdomain
by default.

When you get to that initial prompt, it is asking you to log in to your system. If you created a user
account with the Setup Agent, you can log in using that username and password. If you did not create
a user account, then you can log in as the super user, also known as root. The root password is the
system password you assigned during installation.

It is highly recommended that you create at least one user account for regular use of your Red
Hat Enterprise Linux system. You can create a new user after logging in as root with the User
Manager graphical tool or the useradd shell prompt utility. For more information, refer to
Section 1.6 Creating a User Account.

14.2. Forgotten root Password
Help! I forgot my root password. How do I log in now?

You can log in using single-user mode and create a new root password.

To enter single-user mode, reboot your computer. If you use the default boot loader, GRUB, you can
enter single user mode by performing the following:

1. At the boot loader menu, use the arrow keys to highlight the installation you want to edit and
type [A] to enter into append mode.

2. You are presented with a prompt that looks similar to the following:
grub append> ro root=LABEL=/

3. Press the Spacebar once to add a blank space, then add the word single to tell GRUB to boot
into single-user Linux mode. The result should look like the following:
ro root=LABEL=/ single

4. Press [Enter] and GRUB will boot single-user Linux mode. After it finishes loading, you will
be presented with a shell prompt similar to the following:
sh-2.05b#

5. You can now change the root password by typing
passwd root

You will be asked to re-type the password for verification. Once you are finished, the password
will be changed. You can then reboot by typing reboot at the prompt; then you can log in to
root as you normally would.
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14.3. Forgotten user Password
I’ve forgotten my user password. How do I get a new one?

Passwords are stored in encrypted files on your Red Hat Enterprise Linux system: users cannot read
a file and see their own or other passwords. If you forget your user password, you must create a new
one.

If you realize that you have forgotten your pasword while logged in, you can create a new one for
yourself. Open a shell prompt and enter the command passwd. The passwd command asks for the
new password, which you will have to enter twice. The next time you log in, use the new password.

If you are not logged in when you realize you have forgotten your password, log in as the root user.
Open a shell prompt and enter the command passwd username, where username is your normal
user name. The passwd command requires you to enter the new password twice. Log out of your
system. You can now log back in with your normal user name and your new password.

14.4. Changing Passwords
How do I change my root or user password?

The process for changing the password of root is the same as that for changing the password for a
user. First, log in to the appropriate account. Open a shell prompt and enter the command passwd.
The passwd command asks for the new password, which you will have to enter twice. The next time
you log in, use the new password.

14.5. Password Maintenance
How often should I change my password? What should my password look like?

For security reasons, it is a good idea to change your root and user passwords regularly. Experts vary
on how often this change should occur, but most agree that passwords should be changed multiple
times each year.

Passwords should not be based on a dictionary word should be at least six characters, and should
include: both lower-case and upper-case letters, at least one number, and at least one punctuation
mark. Don’t write your password down or store it in an unencrypted file. Don’t give your password to
anyone.

User passwords can be set to automatically expire after a certain amount of time. Refer to the Red Hat
Enterprise Linux System Administration Guide for more information.

14.6. Starting Applications
I installed an application I downloaded from the Internet, and everything seemed to go fine, but I still
get command not found when I type its name. I think I have the right name, so why does it not
start?

If you are trying to start an application from the shell prompt and it is not working, try
typing out the full directory path before the name of the application’s executable (such as
/usr/local/bin/my-executable).

For example, imagine that you have downloaded the setiathome client application and want to try
it out. You follow the directions for installing the software, which creates a subdirectory in your home
directory called seti/. Now, start the application using the full path to the executable file as shown
below:

/home/joe/seti/setiathome
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The reason you may need to type the full pathnames in order to start an application is because the
executable was not placed in a directory where your user shell environment knew it could be found
(such as /usr/local/bin).

You can customize your settings so that you are not required to use the type the full path to the
application each time. To do this, you must edit your PATH environment variable.

14.6.1. Editing Your PATH
If you frequently start programs that are not located in a directory that your user shell has been
configured to search, you must edit your user shell configuration file to add the directory containing
the executable you wish to run. You can do this by adding the directory to your PATH environment
variable.

Caution

These instructions are intended only for user accounts. Avoid modifying files such as the root user’s
.bash_profile, because of the potential security risks.

Start a text editor, such as gedit or vi, at a shell prompt. You can open the file called .bash_profile
by typing the following:

gedit .bash_profile

Look for a PATH statement, similar to the one shown below.

PATH=$PATH:$HOME/bin:/usr/local/bin:

To the end of this statement, add $HOME/seti as shown below:

PATH=$PATH:$HOME/bin:/usr/local/bin/:$HOME/seti:

Save the file and exit the text editor.

You can then make the changes to .bash_profile take effect immediately by typing the following
command:

source .bash_profile

By adding paths to your .bash_profile, you can place utilities and programs in your path and be
able to execute them without having to type ./ in front of the command.

Tip

For more information about using and configuring your shell prompt refer to
Chapter 4 Shell Prompt Basics.
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14.7. Finding Commands Quickly
I was looking at a man page yesterday, but I cannot remember the name of the command I was reading
about, and I did not write it down. How do I get the man page back?

The command you used is stored in a file called .bash_history. By default, this file records the last
500 commands you typed at the shell prompt.

You can glimpse the history of your commands by typing history at the shell prompt, but the results
are displayed too quickly for you to read every line.

Another way to view .bash_history is with a utility such as less. Type less .bash_history
at the shell prompt and the results will display one page at a time. To move forward a screen, press
the [Space] bar; to move back a screen, press the [b] key, and to quit, press [q].

Paging through .bash_history to find a command can be tedious. Alternatively, you can search
through the file for keywords using grep, a powerful search utility.

Say you were reading the man page the day before, but cannot recall its name. To search for the
command, type:

history | grep man

All the commands you typed which have the word man in them are now highlighted.

There are many ways to use your command history. For other tips and tricks, see
Section 14.8 Tips on Using Command History.

14.8. Tips on Using Command History
What are some other ways I can use command history?

If you type history, a numbered list scrolls by very quickly, showing you the previous 500 com-
mands you have used.

You probably do not need to see all of the last 500 commands, so the command history 20 might
be useful. This way, only the previous 20 commands you typed are displayed (you can use any quantity
as an argument of the history command).

14.8.1. Other Shortcuts
Here are other command history shortcuts which may be useful to you:

• "Bang, bang": Typing !! (called "bang bang") executes the last command in the history.

• "Bang number": Typing !number (as in !302) executes the command which is numbered 302 in
the history file.

• "Bang string": Typing !string (as in !rpm) executes a command with the most recent match-
ing string from the history file.

• [Up arrow] and [down arrow]: At the shell or GUI terminal prompt, you can press the up arrow
to move back through previous commands in your history list (the down arrow moves you for-
ward through the commands) until you find the command you want. Press [Enter] to execute the
command, just as if you had typed it on the command line.
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14.9. Keep ls Output from Scrolling
Whenever I type ls I can barely see the output of the directory because it scrolls by too quickly. How
can I actually read the output?

To prevent the output of ls from scrolling by too quickly, pipe the output to a utility such as less or
more. You are then able to see the output one screen at at time.

To read the contents of /etc with less, type the following command at the shell prompt:

ls -al /etc | less

To move forward a screen, press [Space] bar; to move back a screen, press the [b] key; to quit, press
[q].

You can achieve the same results with more, another paging utility.

14.9.1. Printing ls Output
You can also print directory listings by piping the output to a printer in the same way that you piped
the output to your screen. If you have configured a printer, type the following to pipe the output of a
command to the printer:

ls -al /etc | lpr

14.10. Accessing a Windows Partition
I have a dual-boot system with Red Hat Enterprise Linux and Windows 98. Is there a way to access
my Windows partition while I am running Linux?

You can access another partition on your system (for example, a Windows partition), in two different
ways.

You should first determine where your Windows partition is located by determining what physical hard
disk your Windows partition is located in (such as the primary master IDE drive or the the first SCSI
drive). To find this information, you can use the Hardware Browser, which lists detailed information
about the hardware in your Red Hat Enterprise Linux system.

To start the Hardware Browser, choose Main Menu => System Tools => Hardware Browser.
Figure 14-1 shows Hardware Browser in action.
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Figure 14-1. Hardware Browser hard disk device listing

Select Hard Drives from the panel and find your Windows partition from the Disk Information
displayed. Windows partitions normally use the FAT or FAT32 file system type. This file system type
can be mounted and read within Linux; however, if your Windows partition uses NTFS, then you
cannot mount and read from it as Red Hat Enterprise Linux does not support NTFS file systems. Note
the Device information for your Windows partition, as this is the device that you mount to access your
Windows data.

Once you have determined where your Windows partition is located on your hard drive, log in as root
(type su and then enter the root password) at a shell prompt.

Create a directory in which the Windows partition is mounted by typing the following command. For
example:

mkdir /mnt/windows

Before you can access the partition, you must mount it in the directory you just created. As root, type
the following command at a shell prompt (where /dev/hda1 is the Windows partition you found via
Hardware Browser):

mount -t vfat /dev/hda1 /mnt/windows

You may then logout of root user mode and access your Windows data by changing into the mounted
Windows partition:

cd /mnt/windows

To automatically mount a Windows partition every time you boot your Red Hat Enterprise Linux
system, you must modify the /etc/fstab file, which configures all file systems and disk device
mounting options.

At a shell prompt, su - to root, following the above example.

Next, open the /etc/fstab in a text editor by typing (for example):

gedit /etc/fstab

Add the following on a new line (replacing /dev/hda1 with the Windows partition you found via
Hardware Browser):

/dev/hda1 /mnt/windows vfat auto,umask=0 0 0
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Save the file and exit your text editor.

The next time the system is rebooted, the /etc/fstab file is read, and the Windows partition is
automatically mounted in the directory /mnt/windows. To access the partition at a shell prompt,
type the command cd /mnt/windows. To navigate through directories or files with spaces, surround
the name of the directory or file with quotation marks, as in ls "Program Files".

14.11. Error Messages During Installation of RPMs
How do I install an RPM from a CD or the Internet? I keep getting an error message when I use RPM.

If you are getting an error message similar to failed to open /var/lib/rpm/packages.rpm,
it is because you do not have proper permission to install RPM files.

When you install software, you are often required to make system-wide changes which only root can
make, such as creating new directories outside of your home directory or making changes to your
system configuration. If you are using your normal user account, you do not have permission to make
such changes by default.

You need to be the root user to install RPM files. At a shell prompt, switch to the root user by running
the following command:

su -

After entering the root password when prompted, you should then be able to install the RPM file
without further errors. For more information about using RPM and Package Management Tool,
refer to the Red Hat Enterprise Linux System Administration Guide on the Red Hat Enterprise Linux
Documentation CD or online at http://www.redhat.com/docs/.

14.12. Changing Login from Console to X at Startup
How do I change my login from the console to the graphical screen?

Instead of logging in to your system at the console and typing the startx command to start the X
Window System, you can configure your system so that you can log in directly to X.

You must edit one file, /etc/inittab, by changing just one number in the runlevel section. When
you are finished, reboot the computer. The next time you log in, you will have a graphical login
prompt.

Open a shell prompt. If you are in your user (home) account, change to the root user by using the su
command:

su -

Now, type gedit /etc/inittab to edit the file with gedit. The file /etc/inittab will open.
Within the first screen, you will see a section of the file which looks like this:

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#



132 Chapter 14. Frequently Asked Questions

id:3:initdefault:

To change from a console to a graphical login, you should change the number in the line
id:3:initdefault: from a 3 to a 5.

Warning

Change only the number of the default runlevel from 3 to 5.

Your changed line should look like the following:

id:5:initdefault:

When you are satisfied with your change, save and exit the file using the [Ctrl]-[x] keys. You will see
a message telling you that the file has been modified, and asking you to confirm your change. Type
[Y] for yes.

Now, your next login after reboot will be from the graphical screen.



IV. Appendix

This part contains supplemental information and instruction that you may find useful during the course
of your Red Hat Enterprise Linux usage. Perhaps you want to use the KDE graphical desktop envi-
ronment, or learn more about configuring your system to send and receive encrypted email. This
section shows you time-saving keyboard shortcuts, discusses the Red Hat Enterprise Linux directory
structure, and more.
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Appendix A.
KDE: The K Desktop Environment

The K Desktop Environment (KDE) is a graphical desktop, similar in function to the GNOME desktop
explored in the main text of the manual. It uses many of the same freatures as GNOME, including
icons, windows, menus, and a panel.

This appendix covers the basics of using KDE: system navigation, working with files and applications,
and customizing the desktop.

The KDE default desktop looks similar to Figure A-1.

Figure A-1. A Typical KDE Desktop

If you would like to learn more about KDE, visit the official website at http://www.kde.org/.

A.1. Customizing KDE
The behavior and appearance of KDE is highly customizable. To open the Control Center, select
Main Menu => Preferences => Control Center. The following list explains some of the configura-
tion options in detail.

KDE Components
This section lets you configure the Konqueror file manager and customize certain file operations.
You can also associate files to applications that you prefer (for example, assigning all digital
music files to open in XMMS instead of the default player).

Appearance & Themes
This sections allows you to customize the visual aspect of your desktop environment. You can
customize background images and configure fonts, themes, icons, panel elements, screensavers,
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and window border appearance. You can also customize mouse and keyboard events which makes
working with the desktop as efficient for your needs as possible.

Regional & Accessibility
This section allows you to set country and language options to your particular locale. For users
with sight or hearing impairments, you can also configure accessibility features such as audible
and visual cues and keyboard/mouse customization.

System Administration
This section is an advanced system configuration interface. You need your root password to
configure most of these options. This section allows you to install new fonts, configure login
management, set system paths, and more. It is strongly recommended that you leave these settings
at their default values unless you understand the consequences of changing them.

Web Browsing
This section allows you to configure the Konqueror Web browser. You can configure options
such as cache sizes, website cookies, plugins, proxy settings (if available), and enhanced brows-
ing using keyword shortcuts.

A.2. Introducing Konqueror
Konqueror is the file manager for KDE. It is equivalent to GNOME’s Nautilus.

Konqueror provides a graphical display of your system and personal files. Like Nautilus, Konqueror
allows you to configure your desktop and your Red Hat Enterprise Linux system, access network
resources and more. Konqueror makes use of icons, the Panel, and Trash. Below are some of the
tools KDE provides; each is an example of Konqueror.

A.2.1. User’s Home
KDE does not place a Home icon on the Desktop by default. It can be reached from the Main Menu,
however. This opens a Konqueror window with the contents of the user’s home directory.

Tip

You can add a Home icon to your desktop by dragging the icon from the Main Menu to the desktop
and selecting Copy Here.

Konqueror behaves as a browser by default; it opens files and directories inside the large pane of the
current window rather than opening a new instance of Konqueror. You can open directories and files
in new tabs, just as in Firefox or other web browsers. To do so, right-click on the file or directory to
open and select Open in New Tab.

A.2.2. Trash
KDE includes a Trash icon similar to that of other operating systems; files inside the Trash are not
deleted until you choose to do so. The Trash bin can be opened by double-clicking on the desktop
icon. The Trash opens as a Konqueror window, which allows you to easily nove files in and out. To
empty the Trash, right-click on the desktop icon and select Empty Trash Bin.
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A.2.3. Removable Media
KDE works with removable media, including diskettes, CD-, and DVD-ROMs.

A.2.3.1. Diskettes
Recall that diskettes must be mounted before use and unmounted after use to be sure that your files
are not damaged. To mount a diskette with Konqueror, first open a Konqueror window, then choose
Devices from the sidebar. Double-click on the Floppy icon to mount the diskette. When you are
finished, return to the Devices directory, right-click on the Floppy icon, and select Unmount Volume
before ejecting the diskette.

A.2.3.2. CD-ROM and DVD-ROM
CDs and DVDs auto-mount when you insert them into the appropriate drive. To display the contents
of the media, open a Konqueror window, choose Devices from the sidebar, and double-click on the
appropriate icon. If the media does not auto-mount, open a Konqueror window and choose Devices
from the sidebar. Right-click on the appropriate icon in the large pane of the Konqueror window
and select Mount Volume. Konqueror mounts the media and displays its contents in the large pane
of the window. When you are finished, right-click on the appropriate icon in the Devices section of
Konqueror and select Eject. Konqueror unmounts the media and ejects the CD or DVD.

A.2.4. Customizing Konqueror
The behavior of Konqueror can also be customized. With a Konqueror window open, select Settings
=> Configure Konqueror.
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Figure A-2. The Konqueror Configuration Window

The configuration window opens. in the left pane is a list of icons representing the types of cus-
tomizatins you can make. Clicking on each icon in turn displays customization options. For example,
the Appearance icon allows you to select the font face and size of your Konqueror windows. Browse
through the various options and make your selections. Click the Apply button to save your changes,
and finally click the OK button to exit the configuration window.

A.3. Using Konqueror
Konqueror is the file manager and a Web browser for the KDE desktop. Konqueror allows you to
configure your KDE desktop, configure your Red Hat Enterprise Linux system, play multimedia files,
browse digital images, surf the Web, and more from one interface. This section explains some of the
ways Konqueror can help you work with and enjoy your Red Hat Enterprise Linux system.

To start Konqueror for file management, click on your home directory icon .

Konqueror opens up in a window on your desktop, allowing you to navigate through your home
directory and throughout your Red Hat Enterprise Linux file system. After exploring, you can return
to your home directory by clicking the Home button on the toolbar.
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Figure A-3. The Konqueror File Manager

You can navigate through the file system by clicking on folders within the main window pane or
through the hierarchical file system viewer on the navigation panel as shown in Figure A-3. Files and
folders in the main window frame can be moved or copied to another folder or sent to the trash. You
can also delete files and folders by right-clicking on the item and choosing Delete.

Konqueror also displays thumbnail icons for text, images, PostScript/PDF files, and Web files. It can
also preview sounds from digital audio files.

A.3.1. The Navigation Panel
Another useful feature of Konqueror is the navigation panel. This panel appears on the left side of
the Konqueror file browser window by default. The navigation panel makes many of your sytem
resources available to you in convenient tabbed icons. Figure A-4 shows the navigation panel.
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Figure A-4. Working with the Navigation Panel

The navigation panel lets you access your Web bookmarks, browsing history, network resources,
file system, and has a built-in media player for playing multimedia files without opening a separate
application. The navigation panel makes Konqueror an efficient solution for users who want fast and
easy access to all of their files and information.

A.4. Using the KDE Desktop
As previously mentioned, the KDE graphical desktop displays the various application windows,
launch icons, panels, and other tools that make up the KDE experience on Red Hat Enterprise Linux.
These tools are discussed in detail in the following sections of this Appendix. This section discusses
tow specific features: adding new apllication launchers to the desktop and the customization options
for the desktop itself.

A.4.1. Adding Application Launchers to the Desktop
You can add application launchers to your desktop in KDE. The procedure is the same as for GNOME.
Refer to Section 2.2.1 Adding Application Launchers for more information.

A.4.2. Configuring the Desktop
To configure the desktop, right-click on an unused portion of the desktop and select Configure Desk-
top....
The Configure-Desktop window contains the Background, Behavior, Multiple Desktops, Screen
Saver, and Display configuration icons. Click each icon in turn and select the configuration options
you prefer.
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Figure A-5. Desktop Background Configuration

Two of the options you can set are the number and names of your desktops.

Figure A-6. Virtual Desktop Configuration

Click on the Multiple Desktops icon. Select the number of desktops available to you, then enter names
for the desktops in the text fields. To save your changes, click the Apply button. To exit, click the OK
button.

A.5. Using the Panel
The panel stretches across the bottom of the desktop. By default, it contains the Main Menu and
quick-launch icons for starting a Web browser, email client, word processor, and other commonly
used applications.
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Figure A-7. The Panel

Applets are small applications that run on the panel. There are several types of applets: some perform
functions such as system monitoring, time and date display, and others launch applications. Some
applets run on the panel by default. This section covers them in detail.

A.5.1. The Pager
By default, KDE provides four desktops that you can use to display multiple applications without
having to crowd all of them onto one desktop. Each desktop can hold icons, open applications, and be
individually customized.

Figure A-8. The Pager

For example, while you are writing a message in Evolution on desktop one, you can have Mozilla
browsing the Web on desktop two, the OpenOffice.org Writer word processor open on desktop three,
and so on.

A.5.2. The Taskbar
The taskbar displays all running applications, both minimized and displayed, on all desktops.

Figure A-9. Applications on the Taskbar

You can maximize running applications or bring them to the front of your working windows by click-
ing on the associated item on the taskbar.

Tip

Another way to bring minimized or background windows to the front is to use the [Alt] and [Tab] keys.
To pick an item from the taskbar, hold down both the [Alt]-[Tab] key. To scroll through the tasks, hold
down the [Alt] key, while tapping the [Tab] key. When you have found the task you want to maximize
and bring to the front, release both keys and the application appears on the desktop.

The Taskbar is also configurable. Right-click on the handle — the small arrow that appears to the left
of the taskbar — and select Configure Taskbar.
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A.5.3. The Main Menu
The Main Menu is the central point for using KDE. Clicking on the Main Menu icon on the
panel displays a large master menu from which you can perform tasks such as launch applications,
find files, and configure your desktop. The main menu also contains several submenus that organize
applications and tools into major categories, including Graphics, Internet, Office, Games, and more.

From the Main Menu, you can lock your session, which displays a password-protected screensaver.
You can also run applications from a command line as well as logout of your KDE session.

A.5.4. Configuring the Panel
As with the other tools available with KDE, the panel is configurable. Right-click on the blank portio
of the Panel and select Configure Panel. Configure the panel’s orientation and size, or set the panel’s
hiding configuration.

Figure A-10. Panel Settings

A.5.5. Adding Applets to the Panel
To further customize the panel for your particular needs, you can include additional launcher icons to
start applications without using the Main Menu. To add an application launcher to the panel, right-
click on an unused portion the panel and choose Add. Then select Application Button and make your
choice from the menus.

To add a new launcher to the panel, right-click the panel and choose Add => Application Button and
choose the application or resource you wish to add to the panel. This automatically adds an icon on the
panel. You can move the icon anywhere you want on the panel by right-clicking the icon and choosing
Move Application Button, where Application is the name of the application associated with
the icon.
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A.6. Browsing the Web with Konqueror
Konqueror is not only a file browser, but is also a full-featured web browser as well. To launch Kon-
queror choose Main Menu => Internet => Konqueror.

Figure A-11. Welcome to Konqueror

To begin your Web session, enter a URL in the Location field. For example, enter
http://www.redhat.com/ into the field. If your internet connection is working properly,
Konqueror displays a web page similar to the one pictured in Figure A-11.

Press [Enter] to connect to the webpage. You can navigate the webpage using your mouse and key-
board. To scroll up and down a webpage, click the the scroll bar on the right side of the browser
window as you drag the mouse up and down. You can also press the arrow keys on your keyboard to
move up and down the webpage.

To load any new content on the webpage, click the Refresh button on the toolbar or press [F5]. This
reloads the page along with any new content.

To stop a page from loading, click the Stop button on the toolbar or press [Esc].

To move back to a previously loaded webpage or move forward to a recently loaded page, click the
Back and Forward buttons or press [Alt] and the left or right arrow key to move backward or forward
one webpage, respectively.

Konqueror also allows you to load multiple pages within one browser window, alleviating the need
to have multiple browser windows open at the same time. Konqueror uses tabs to accomplish loading
multiple pages in one window. To open a link in a new tab, right-click the link and choose Open in
New Tab (or Open in Background Tab if you want to keep your current tab on top). The tabs appear
with the header of the webpage displayed for easy reference. Click the tab of the webpage you want
to display. To close a tab, right-click on it and choose Close Tab from the menu.

For additional information on using Konqueror, go to Help (on the top menu panel) => Konqueror
Handbook.
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Figure A-12. The Konqueror Handbook

A.7. Using Konqueror to View Images
You can also use the Konqueror file manager to view images. Using Konqueror as an image browser
works similarly to Nautilus. Konqueror automatically generates thumbnail preview icons within the
file browser window. When you double-click on a thumbnail icon, the browser displays the image in
its native size, as shown in Figure A-13.

Figure A-13. Viewing an Image in Konqueror

To zoom in and out of an image, you first need to change the way Konqueror renders the image.
From the window menu, choose View => View Mode => Image Viewer Part. This re-displays the
image and allows you to rotate and zoom in on the image using the two magnifying glass icons or the
magnification percentage drop-down menu on the toolbar, as shown in Figure A-14.
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Figure A-14. Image viewing configuration on the Konqueror Toolbar

You can also open the image with more advanced image viewers, such as the GIMP. Right-click on
the image, choose Open With... and select the GIMP. You can also select Other..., which opens
a pop-up menu that lists all available applications. Make your selection from the various graphics
applications, as shown in Figure A-15.

Figure A-15. The Open With... Dialog Box

A.8. KMail
KMail is an email tool for KDE. It has an intuitive graphical interface similar to Evolution that allows
you to send and receive email using a graphical interface. To open KMail, click on the Main Menu
=> Internet => KMail.
Before using KMail, you must configure it to send and receive mail. To run the configuration tool,
select Settings from the KMail toolbar, and click on Configure KMail.
The Configure Mail Client window consists of the following sections: Identities, Network, Ap-
pearance, Composer, Security, and Folders. To begin sending and receiving messages, you must
change the settings in the Identities and Network tabs. Have your email information from your
service provider or administrator handy to fill in the required information. For additional informa-



Appendix A. KDE: The K Desktop Environment 147

tion, refer to the KMail user manual (Help => KMail Handbook) or visit KMail’s homepage at
http://kmail.kde.org.

Figure A-16. KMail Main Screen

Once you have configured the email settings, begin sending and receiving email by clicking on the
Get Mail icon in the upper left of the screen. The folders on the left side of the KMail screen allow
you to view emails you have received, emails ready to be sent, emails you have sent, and more.

To compose a mail, click on the new message icon in the tool bar: . A new message window
opens with a blank email template.

Figure A-17. KMail New Email Message Screen



148 Appendix A. KDE: The K Desktop Environment

Once you have composed a message and entered an email address to send the email to, click Send in

the toolbar: .

A.9. Logging Out of KDE
There are two ways to log out of your KDE session. From the Main Menu, select Logout User,
where User is your account username. To log out from the desktop, right-click on the desktop and,
from the menu, select Logout User where User is your account username. In either case click
Logout and your session ends.

Figure A-18. KDE Logout Screen

A.10. Finding Help
You can access a comprehensive set of documentation about KDE through the HelpCenter.

Figure A-19. The HelpCenter
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You can access the HelpCenter from the Main Menu by selecting Help. To access HelpCenter from
the desktop, right-click on the desktop and select the Help => K Desktop Handbook.

The opening screen of the HelpCenter browser appears like Figure A-19. From this main page, you
can view help documentation on topics such as using and configuring the desktop, working with the
many applications included with KDE, and working with the Konquerer file manager.
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Appendix B.
Getting Started with Gnu Privacy Guard

Have you ever wondered if your email can be read during its transmission from you to other people,
or from other people to you? Unfortunately, complete strangers could conceivably intercept or even
tamper with your email.

In traditional (also known as "snail") mail, letters are usually sealed within envelopes, stamped and
delivered from post office branch to branch until they reach their destination. But sending mail through
the Internet is much less secure; email is usually transmitted as unencrypted text from server to server.
No special steps are taken to protect your correspondence from being seen or tampered with by other
people.

To help you protect your privacy, Red Hat Enterprise Linux 4 includes GnuPG, the GNU Privacy
Guard, which is installed by default during a typical Red Hat Enterprise Linux installation. It is also
referred to as GPG.

GnuPG is a tool for secure communication; it is a complete and free replacement for the encryption
technology of PGP (Pretty Good Privacy, a widely popular encryption application). Using GnuPG, you
can encrypt your data and correspondence as well as authenticate your correspondence by digitally
signing your work. GnuPG is also capable of decrypting and verifying PGP 5.x.

Because GnuPG is compatible with other encryption standards, your secure correspondence is proba-
bly compatible with email applications on other operating systems, such as Windows and Macintosh.

GnuPG uses public key cryptography to provide users with a secure exchange of data. In a public
key cryptography scheme, you generate two keys: a public key and a private key. You exchange your
public key with correspondents or with a keyserver; you should never reveal your private key.

Encryption depends upon the use of keys. In conventional or symmetric cryptography, both ends of
the transaction have the same key, which they use to decode each other’s transmissions. In public key
cryptography, two keys co-exist: a public key and a private key. A person or an organization keeps
their private key a secret, and publishes their public key. Data encoded with the public key can only be
decoded with the private key; data encoded with the private key can only be decoded with the public
key.

Important

Remember that your public key can be given to anyone with whom you want to communicate securely,
but you must never give away your private key.

For the most part, cryptography is beyond the scope of this publication; volumes have been written
about the subject. In this chapter, however, we hope you gain enough understanding about GnuPG to
begin using cryptography in your own correspondence. If you want to learn more about GnuPG, PGP
and encryption technology, see Section B.8 Additional Resources.

B.1. Configuration File
The first time you run a GnuPG command, a .gnupg directory is created in your home directory.
Starting with version 1.2, the configuration filename has change from .gnupg/options to
.gnupg/gpg.conf. If .gnupg/gpg.conf is not found in your home directory, .gnupg/options
is used. If you only use version 1.2 or higher, it is recommended that you rename your configuration
file with the following command:
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mv ~/.gnupg/options ~/.gnupg/gpg.conf

If you are upgrading from a version prior to 1.0.7, you can create signature caches in your keyring to
decrease the keyring access time. To perform this operation, execute the following command once:

gpg --rebuild-keydb-caches

B.2. Warning Messages
When executing GnuPG commands, you may see the following message:

gpg: Warning: using insecure memory!

This warning is because non-root users can not lock memory pages. If users could lock memory pages,
they could perform out-of-memory Denial of Service (DoS) attacks; thus, it is a possible security
problem. For details, refer to http://www.gnupg.org/(en)/documentation/faqs.html#q6.1.

You might also see the following message:

gpg: WARNING: unsafe permissions on configuration file "/home/username/.gnupg/gpg.conf"

This message is shown if the file permissions of your configuration file allows others to read it. If
you see this warning, it is recommended that you execute the following command to change the file
permissions:

chmod 600 ~/.gnupg/gpg.conf

Another common warning messages is as follows:

gpg: WARNING: unsafe enclosing directory permissions on configuration file
"/home/username/.gnupg/gpg.conf"

This message is shown if the file permissions of the directory that contains the configuration file allows
others to read its contents. If you see this warning, it is recommended that you execute the following
command to change the file permissions:

chmod 700 ~/.gnupg

If you upgraded from a previous version of GnuPG, you might see the message:

gpg: /home/username/.gnupg/gpg.conf:82: deprecated option "honor-http-proxy"
gpg: please use "keyserver-options honor-http-proxy" instead

This warning is because your ~/.gnupg/gpg.conf file contains the line:

honor-http-proxy

Version 1.0.7 and higher prefers a different syntax. Change the line to the following:

keyserver-options honor-http-proxy
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B.3. Generating a Keypair
To begin using GnuPG, you must first generate a new keypair: a public key and a private key.

To generate a keypair, at a shell prompt, type the following command:

gpg --gen-key

Since you work with your user account most frequently, you should perform this action while logged
in to your user account (not as root).

You see an introductory screen, with key options, including one recommended option (the default),
similar to the following:

gpg (GnuPG) 1.2.6; Copyright (C) 2004 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

gpg: keyring ’/home/user/.gnupg/secring.gpg’ created

Please select what kind of key you want:
(1) DSA and ElGamal (default)
(2) DSA (sign only)
(5) RSA (sign only)

Your selection?

Most of the screens which require you to choose an option lists the default option, within parentheses.
You can accept the default options by pressing [Enter].

In the first screen, you should accept the default option: (1) DSA and ElGamal. This option allows
you to create a digital signature and encrypt (and decrypt) with two types of technologies. Type 1 and
then press [Enter].

Next, choose the key size, or how long the key should be. Generally, the longer the key, the more
resistant against attacks your messages are. The default size, 1024 bits, should be sufficiently strong
for most users, so press [Enter].

The next option asks you to specify how long you want your key to be valid. Usually, the default (0
= key does not expire) is fine. If you do choose an expiration date, remember that anyone with
whom you exchanged your public key also have to be informed of its expiration and supplied with a
new public key. If you do not choose an expiration date, then you are asked to confirm your decision.
Press [y] and [Enter] to confirm your decision.

Your next task is to provide a user ID that consists of your name, your email address, and an optional
comment. When you are finished, you are presented with a summary of the information you entered.

The next option is to make any changes to the information you just entered. If you are satisfied with
your entries, press [O].

Once you accept your choices, you must enter a passphrase.

Tip

Like your account passwords, a good passphrase is essential for optimal security in GnuPG. For
example, mix your passphrase with uppercase and lowercase letters, use numbers, or punctuation
marks.
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Once you enter and verify your passphrase, your keys are generated, and a message similar to the
following is displayed:

We need to generate a lot of random bytes. It is a good idea to perform
some other action (type on the keyboard, move the mouse, utilize the
disks) during the prime generation; this gives the random number
generator a better chance to gain enough entropy.
+++++.+++++.++++++++....++++++++++..+++++.+++++.+++++++.+++++++
+++.++++++++++++++++++++++++++++++++++++++..........................++++

When the activity on the screen ceases, your new keys are made and placed in the directory .gnupg
in your home directory. To list your keys, use the command:

gpg --list-keys

You will see something similar to the following:

/home/username/.gnupg/pubring.gpg
-----------------------------------------
pub 1024D/B7085C8A 2000-06-18 Your Name <you@example.com>

sub 1024g/E12AF9C4 2000-06-18

If you created a GnuPG key with version 1.0.6 or lower, exported your private key, and imported it
into a new one, you have to explicitly trust your own key to sign items with version 1.0.7 or higher.
To trust your key, type the following command (replace <user-id>):

gpg --edit-key <user-id>

At the Command> prompt type trust and select 5 = I trust ultimately to trust your own key.

B.4. Generating a Revocation Certificate
Once you have created your keypair, you should create a revocation certificate for your public key. If
you forget your passphrase, or if it has been compromised, you can publish this certificate to inform
users that your public key should no longer be used.

Note

When you generate a revocation certificate, you are not revoking the key you just created. Instead,
you are giving yourself a safe way to revoke your key from public use in case you forget your
passphrase, switch ISPs (addresses), or suffer a hard drive crash. The revocation certificate can
then be used to disqualify your public key.

Your signature is valid to others who read your correspondence before your key is revoked, and you
are able to decrypt messages received prior to its revocation. To generate a revocation certificate, use
the --gen-revoke option:

gpg --output revoke.asc --gen-revoke you@example.com

Note that if you omit the --output revoke.asc option from the above, your revocation certificate
is returned to the standard output, which is your monitor screen. While you can copy and paste the
contents of the output into a file of your choice using a text editor, it is probably easier to send the
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output to a file in your login directory. That way, you can keep the certificate for use later, or move it
to a diskette and store it someplace safe.

The output looks similar to the following:

sec 1024D/823D25A9 2000-04-26 Your Name <you@example.com>

Create a revocation certificate for this key?

Press [Y] and [Enter] to create a revocation certificate for the listed key. Next, you are asked to select
the reason for revocation and provide an optional description. After confirming the reason, enter the
passphrase you used to generate the key.

Once your revocation certificate has been created (revoke.asc), it is located in your login directory.
You should copy the certificate to a diskette and store it in a secure place. (If you do not know how to
copy a file to a diskette in Red Hat Enterprise Linux, see the Red Hat Enterprise Linux Step By Step
Guide, Section 13.1 Using Diskettes).

B.5. Exporting your Public Key
Before you can use public key cryptography, other people must have a copy of your public key. To
send your key to correspondents or to a keyserver, you must export the key.

To export your key, so you can display it on a webpage or paste it in email, type the following com-
mand:

gpg --armor --export you@example.com > mykey.asc

You do not see any output, because not only did you export your public key, you redirected the output
to a file called, for example, mykey.asc. (Without the addition of > mykey.asc, the key would
have been displayed as the standard output on the monitor screen.)

Now, the file mykey.asc can be inserted into email or exported to a keyserver. To see the key, type
less mykey.asc to open the file in a pager (type [q] to quit the pager). It should look like the
following:

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.2.1 (GNU/Linux)
Comment: For info see http://www.gnupg.org
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iLyPH1QAoI33Ft/0HBqLtqdtP4vWYQRbibjW
=BMEc
-----END PGP PUBLIC KEY BLOCK-----

B.5.1. Exporting to a Keyserver
If you are only writing to a few correspondents, you can export your public key and send it to them
personally. If you correspond with many people, however, distribution of your key can be time con-
suming. Instead, you can use a keyserver.

A keyserver is a repository on the Internet which can store and distribute your public key to anyone
who requests it. Many keyservers are available, and most try to remain synchronized with each other;
sending your key to one keyserver is like distributing it to them all. A correspondent can request your
public key from a from a keyserver, import that key to their keyring, and they are ready for secure
correspondence with you.

Tip

Because most keyservers are synchronized, sending your public key to one keyserver is usually as
good as sending it to them all. You can, however, locate different keyservers. One place to begin your
search for keyservers and more information is Keyserver.Net available at http://www.keyserver.net.

You can send your public key from either the shell prompt or from a browser; of course, you must be
online to send or receive keys from a keyserver.

• From the shell prompt, type the following:
gpg --keyserver search.keyserver.net --send-key you@example.com

• From your browser, go to Keyserver.Net (http://www.keyserver.net) and select the option to add
your own PGP public key.

Your next task is to copy and paste your public key into the appropriate area on the webpage. If you
need instructions on how to do that, use the following:

• Open your exported public key file (such as mykey.asc, which was created in
Section B.5 Exporting your Public Key) with a pager — for example, use the less mykey.asc
command.

• Using your mouse, copy the file by highlighting all the lines from the BEGIN PGP to END PGP
notations (see Figure B-1).

• Paste the contents of the file mykey.asc into the appropriate area of the page on Keyserver.Net
by middle-clicking with your mouse (or left- and right-clicking if you are using a two-button
mouse). Then select the Submit button on the keyserver page. (If you make a mistake, press the
Reset button on the page to clear your pasted key.)



Appendix B. Getting Started with Gnu Privacy Guard 157

Figure B-1. Copying Your Public Key

Note that if you are submitting your key to another Web-based keyserver, the above transaction is
essentially the same.

That is all you need to do. Regardless of whether you use the shell prompt or the Web, you see a
message that your key was successfully submitted — either at the shell prompt or at the keyserver’s
website. From now on, users who want to communicate securely with you can import your public key
and add it to their keyring.

B.6. Importing a Public Key
The other end of key exchange is importing other people’s public keys to your keyring — is just as
simple as exporting keys. When you import someone’s public key, you can decrypt their email and
check their digital signature against their public key on your keyring.

One of the easiest ways to import a key is to download the key or save it from a website.

After downloading a key and saving it to the file key.asc, use the following command to add it to
your keyring.

gpg --import key.asc

Another way to save a key is to use a browser’s Save As feature. If you are using a browser such
as Mozilla, and you locate a key at a keyserver, you can save the page as a text file (go to File =>
Save Page As). In the drop-down box next to Files of Type, choose Text Files (*.txt). Then, you can
import the key — but remember the name of the file you saved. For example, if you saved a key as a
text file called newkey.txt, to import the file, at a shell prompt, type the following command:

gpg --import newkey.txt
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The output looks similar to the following:

gpg: key F78FFE84: public key imported
gpg: Total number processed: 1
gpg: imported: 1

To check that the process was successful, use the gpg --list-keys command; you should see your
newly imported key listed on your keyring.

When you import a public key, you add that key to your keyring (a file in which public and secret keys
are kept). Then, when you download a document or file from that entity, you can check the validity of
that document against the key you added to your keyring.

B.7. What Are Digital Signatures?
Digital signatures can be compared to your written signature. Unlike traditional correspondence, in
which it might be possible to tamper with your written signature, digital signatures can not be forged.
That is because the signature is created with your unique secret key and can be verified by your
recipient using your public key.

A digital signature timestamps a document; essentially, that means that the time you signed the doc-
ument is part of that signature. So if anyone tries to modify the document, the verification of the
signature fails. Some email applications, such as Exmh or KDE’s KMail, include the ability to sign
documents with GnuPG within the application’s interface.

Two useful types of digital signatures are clearsigned documents and detached signatures. Both types
of signatures incorporate the same security of authenticity, without requiring your recipient to decrypt
your entire message.

In a clearsigned message, your signature appears as a text block within the context of your letter; a
detached signature is sent as a separate file with your correspondence.

B.8. Additional Resources
There is more to encryption technology than can be covered in one slim introduction to GnuPG. Here
are some resources where you can learn more.

B.8.1. Installed Documentation

• man gpg and info gpg — Quick Reference of GnuPG commands and options.

B.8.2. Useful Websites

• http://www.gnupg.org — The GnuPG website with links to the latest GnuPG releases, a compre-
hensive user’s guide, and other cryptography resources.

• http://hotwired.lycos.com/webmonkey/backend/security/tutorials/tutorial1.html — Visit the
Encryption Tutorial from Webmonkey to learn more about encryption and how to apply
encryption techniques.

• http://www.eff.org/pub/Privacy — The Electronic Frontier Foundation, "Privacy, Security, Crypto,
& Surveillance" Archive.
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B.8.3. Related Books

• The Official PGP User’s Guide by Philip R. Zimmerman; MIT Press

• PGP: Pretty Good Privacy by Simson Garfinkel; O’Reilly & Associates, Inc.

• E-Mail Security: How to Keep Your Electronic Messages Private by Bruce Schneier; John Wiley &
Sons
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Appendix C.
Applications

The following table is a quick reference guide to the applications available on your Red Hat Enterprise
Linux system. While these are the recommended applications, many other commands and applicatons
are available.

Category Application Location

Audio Playback XMMS Applications (the main menu on the panel) =>
Sound & Video => Audio Player

Rhythmbox Applications (the main menu on the panel) =>
Sound & Video => Music Player

Audio Recorder Sound Recorder Applications (the main menu on the panel) =>
Sound & Video => Sound Recorder

Sound Juicer Applications (the main menu on the panel) =>
Sound & Video => Sound Juicer

CD Recording X Cd Roast Applications (the main menu on the panel) =>
System Tools => CD Writer

cdrecord From a shell prompt, enter the command
cdrecord.

Charts and Diagrams Dia Applications (the main menu on the panel) =>
Office => Dia Diagrams

XFig Applications (the main menu on the panel) =>
Graphics => Xfig

Chat GAIM Applications (the main menu on the panel) =>
Internet => IM

Kopete Applications (the main menu on the panel) =>
Internet => Kopete

Digital Cameras gThumb Applications (the main menu on the panel) =>
Graphics => Photo Tool

Email Clients Evolution Applications (the main menu on the panel) =>
Internet => Email

Email Clients,
continued

Thunderbird, mutt Applications (the main menu on the panel) =>
Internet => Thunderbird or enter the
command mutt at a shell prompt.

Fax Fax Viewer (KFax) Applications (the main menu on the panel) =>
Graphics => KFax

Graphics The GIMP Applications (the main menu on the panel) =>
Grahics => GIMP Image Editor
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Category Application Location

Kolourpaint Applications (the main menu on the panel) =>
Graphics => Kolourpaint

Image Viewers Nautilus Applications (the main menu on the panel) =>
File Browser

KView Applications (the main menu on the panel) =>
Graphics => KView

IRC X-Chat Applications (the main menu on the panel) =>
Internet => IRC

Ksirc Applications (the main menu on the panel) =>
Internet => Ksirc

PDAs Evolution Applications (the main menu on the panel) =>
Internet => Email

KOrganizer Applications (the main menu on the panel) =>
Office => KOrganizer

PDF Viewers GNOME PDF Viewer Applications (the main menu on the panel) =>
Graphics => PDF Viewer

KPDF Applications (the main menu on the panel) =>
Graphics => KPDF

PostScript Viewers GNOME Ghostview Applications (the main menu on the panel) =>
Graphics => PostScript Viewer

KGhostView Applications (the main menu on the panel) =>
Graphics => KGhostView

Presentations OpenOffice.org
Impress

Applications (the main menu on the panel) =>
Office => OpenOffice.org Impress

Project Management Imendio Applications (the main menu on the panel) =>
Office => Project Planner

Scanners Kooka Applications (the main menu on the panel) =>
Graphics => Kooka

xsane At a shell prompt, enter the command xsane

Spreadsheets OpenOffice.org Calc Applications (the main menu on the panel) =>
Office => OpenOffice.org Calc

Text Editors gedit Applications (the main menu on the panel) =>
Accessories => Text Editor

nano, vi From a shell prompt, enter the command nano
or vi.

Video Players Helix Player Applications (the main menu on the panel) =>
Sound & Video => Helix Player

Volume Controls Volume Control Applications (the main menu on the panel) =>
Sound & Video => Volume Control

Web Browsers Firefox Applications (the main menu on the panel) =>
Internet => Firefox
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Category Application Location

Konquerer, links Applications (the main menu on the panel) =>
Internet => Konqueror or enter the command
links at a shell prompt.

Word Processors OpenOffice.org
Writer

Applications (the main menu on the panel) =>
Office => OpenOffice.org Writer

Table C-1. Applications
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Appendix D.
A Comparison of Common DOS and Linux
Commands

Many Linux commands typed at a shell prompt are similar to the commands you would type in DOS.
In fact, some commands are identical.

This appendix provides common commands used at the DOS prompt in Windows and their coun-
terparts in Linux. Basic examples of how the command are used at the Linux shell prompt are also
provided. Note that these commands usually have a number of options. To learn more about each
command, read its associated man page (for example, type man ls at the shell prompt to read about
the ls command).

Command’s
Purpose

MS-DOS Linux Basic Linux Example

Copies files copy cp cp thisfile.txt /home/thisdirectory

Moves files move mv mv thisfile.txt /home/thisdirectory

Lists files dir ls ls

Clears screen cls clear clear

Closes shell
prompt

exit exit exit

Displays or sets
date

date date date

Deletes files del rm rm thisfile.txt

"Echoes" output to
the screen

echo echo echo this message

Edits text files edit gedit(a) gedit thisfile.txt

Compares the
contents of files

fc diff diff file1 file2

Finds a string of
text in a file

find grep grep word or phrase thisfile.txt

Formats a diskette format a:
(if diskette
is in A:)

mke2fs /sbin/mke2fs /dev/fd0 (/dev/fd0 is the
Linux equivalent of A:)

Displays command
help

command
/?

man or
info

man command

Creates a directory mkdir mkdir mkdir directory

Views contents of a
file

more less(b) less thisfile.txt

Renames a file ren mv(c) mv thisfile.txt thatfile.txt
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Command’s
Purpose

MS-DOS Linux Basic Linux Example

Displays your
location in the file
system

chdir pwd pwd

Changes directories
with a specified
path (absolute
path)

cd
pathname

cd
pathname

cd /directory/directory

Changes directories
with a relative path

cd.. cd .. cd ..

Displays the time time date date

Shows amount of
RAM in use

mem free free

Notes:
a. Gedit is a graphical text editor; other editors you can use in place of Gedit include nano and
vi.
b. The more pager can also be used to page through a file one screen at a time.
c. The mv command can both move a file and, if you want to rename a file in the same directory,
"move" that file to the same directory with a new name.

Table D-1. Similar Commands
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System Directories

This is a list of the primary Red Hat Enterprise Linux system directories. Each directory is described
briefly. For additional directory information, refer to the Red Hat Enterprise Linux System Adminis-
tration Guide and the Red Hat Enterprise Linux Reference Guide.

• /bin/ — Used to store user commands. The directory /usr/bin/ also stores user commands.

• /sbin/ — Location of many system commands, such as shutdown. The directory /usr/sbin/
also contains many system commands.

• /root/ — The home directory of root, the superuser.

• /misc/ — This directory is used for automatically mounting directories on removeable devices
(such as Zip drives) and remote directories (such as NFS shares) using autofs. Refer to the autofs
manual page (type man autofs at a shell prompt) for more information.

• /mnt/ — This directory typically contains the mount points for file systems mounted after the
system is booted.

• /media/ — This directory contains the mount points for removable media, such as diskettes, CD-
ROMs, and USB flash drives.

• /boot/ — Contains the kernel and other files used during system startup.

• /lost+found/ — Used by fsck to place orphaned files (files without names).

• /lib/ — Contains many device modules and library files used by programs in /bin/ and /sbin/.
The directory /usr/lib/ contains library files for user applications.

• /dev/ — Stores device files.

• /etc/ — Contains configuration files and directories.

• /var/ — For variable (or constantly changing) files, such as log files and the printer spool.

• /usr/ — Contains files and directories directly relating to users of the system, such as programs
and supporting library files.

• /proc/ — A virtual file system (not actually stored on the disk) that contains system information
used by certain programs.

• /initrd/ — A directory that is used to mount the initrd.img image file and load needed device
modules during bootup.

Warning

Do not delete the /initrd/ directory. You will be unable to boot your computer if you delete the
directory and then reboot your Red Hat Enterprise Linux system.

• /tftpboot/ — Contains files and applications needed for Preboot Execution Environment (PXE),
a service that allows client machines and machines without hard drives to boot an operating system
from an image on a central PXE server.

• /tmp/ — The temporary directory for users and programs. /tmp/ allows all users on a system read
and write access.

• /home/ — Default location of user home directories.

• /opt/ — Directory where optional files and programs are stored. This directory is used mainly by
third-party developers for easy installation and uninstallation of their software packages.
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Appendix F.
Keyboard Shortcuts

Here are a few keyboard shortcuts you can use to perform common tasks quickly. Many more are
available in addition to what is listed here. For more command line and keyboard shortcuts, visit:

http://linux-newbie.sunsite.dk/html/lnag.html

• [Ctrl] + [Alt] + [Backspace] = kills your current X session. Kills your graphical desktop session
and returns you to the login screen. Use this if the normal exit procedure does not work.

• [Ctrl] + [Alt] + [Delete] = From a non-graphical shell prompt, shuts down your Red Hat Enterprise
Linux system. Use only when the normal shutdown procedure does not work. In a graphical desktop
session, this shortcut displays the desktop logout screen that allows you to logout, reboot, or shut
down your system.

• [Ctrl] + [Alt] + [Fn] = switches screens. [Ctrl]+[Alt] + one of the function keys displays an available
screen. By default, [F1] through [F6] are text-mode shell prompt screens and [F7] is the graphical
desktop screen.

• [Alt] + [Tab] = switches tasks in a graphical desktop environment. If you have more than one
application open at a time, you can use [Alt] + [Tab] to switch among open tasks and applications.

• [Ctrl] + [a] = moves cursor to the beginning of a line. This works in most text editors and in the
URL field in Mozilla.

• [Ctrl] + [d] = logout of (and close) shell prompt. Use this quick shortcut instead of typing exit or
logout.

• [Ctrl] + [e] = moves cursor to end of a line. This works in most text editors and in the URL field in
Mozilla.

• [Ctrl] + [l] = clears the terminal. This shortcut does the same thing as typing clear at a command
line.

• [Ctrl] + [u] = clears the current line. If you are working in a terminal, use this shortcut to clear the
current line from the cursor all the way to the beginning of the line.

• [Middle Mouse Button] = pastes highlighted text. Use the left mouse button to highlight the text.
Point the cursor to the spot where you want it pasted. Click the middle mouse button to paste it. In
a system with a two-button mouse, if you configured your mouse to emulate a third mouse button,
you can click both the left and right mouse buttons simultaneously to perform a paste.

• [Tab] = command autocomplete. Use this command when using a shell prompt. Type the first few
characters of a command or filename and then press the [Tab] key. It will automatically complete
the command or show all commands that match the characters you typed.

• [Up] and [Down] Arrow = shows command history. When using a shell prompt, press the [up] or
[down] arrow to scroll through a history of commands you have typed from the current directory.
When you see the command you want to use, press [Enter].
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